LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 05-11-2004, 02:02 PM   #1
B00ddha
LQ Newbie
 
Registered: Apr 2004
Posts: 5

Rep: Reputation: 0
Activating network card


I recently installed slackware on my computer. It will not allow me to go online or have any kind of networking. I had this problem when I was using FC1, but I was able to just activate the card. It shows that the card is there but I can't figure out how to activate it. In FC1 under the old KDE there was a simple utility in the menu that would do it. Now I can't find it and can't find the command line equivilant to activate it. Anyone know where the program is in kde 3.1 or the command for the command line to activate it?
 
Old 05-11-2004, 02:06 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Try running:
ifconfig eth0 up
or
ifup eth0

To see if it is enabled and it's IP try:
ifconfig
 
Old 05-11-2004, 06:11 PM   #3
Bean101
LQ Newbie
 
Registered: Mar 2004
Distribution: Slackware 9.1
Posts: 7

Rep: Reputation: 0
first see if its enabled by doing
ifconfig -a
if its not showing up then u will probably have to find the driver that your card uses and uncomment the line from /etc/rc.d/rc.modules
eg: my netgear FA311 uses natsemi driver, so in rc.modules it looks like
/sbin/modprobe natsemi
instead of
#/sbin/modprobe natsemi

if it is showing up in ifconfig
you could try putting this in /etc/rc.d/rc.inet1.conf

# Config information for eth0:
IPADDR[1]="10.0.0.1"
NETMASK[1]="255.255.255.0"
USE_DHCP[1]="no"
DHCP_HOSTNAME[1]=""

doing that should set the ip when the box boots.

or set it using netconfig, then reboot or run /etc/rc.d/rc.inet1

u could also try

ifconfig eth0 10.0.0.1 netmask 255.255.255.0 broadcast 10.0.0.0

those are the only ways i can think of how to set the ip, lemme know if it helped.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Activating a wireless network card IanB1972 Linux - Wireless Networking 4 11-19-2005 10:05 AM
Activating Sound and Network Ragnar78 Linux - Hardware 0 01-31-2005 07:34 PM
activating a network interface marri Programming 2 11-10-2004 10:47 PM
Activating TV Card dunmarie Linux - Newbie 1 08-14-2003 02:28 PM
Problem activating network card with no IP address Olusegun Linux - Networking 1 12-30-2002 03:38 PM


All times are GMT -5. The time now is 02:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration