LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-14-2003, 07:57 AM   #1
c0c0deuz
Member
 
Registered: Aug 2001
Location: Qc, Canada
Distribution: RedHat, Mandrake, FreeEOS
Posts: 336

Rep: Reputation: 30
500 OOPS: unrecognised variable in config file


Installing vsftpd on my RH8, i have got this message trying to use virual users...
Looking at previous posts, i check for an open wuftpd but i dont see it at all. I check the processes and no active process forwu-ftpd.
How can i diagnose this problem?
1st: Is it in vsftpd.conf file, the unrecognised variable
2nd: Is there a way to locate the line where is that variable.
thanks
 
Old 03-14-2003, 09:09 AM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
I'm assuming that you get this message when you try and start the vsftpd service right? If so, then it is almost definetly a problem in your vsftpd.conf file. You may want to post it so we can have a look if you can't figure out what the problem is.
 
Old 03-17-2003, 12:06 PM   #3
c0c0deuz
Member
 
Registered: Aug 2001
Location: Qc, Canada
Distribution: RedHat, Mandrake, FreeEOS
Posts: 336

Original Poster
Rep: Reputation: 30
Here it is...

anonymous_enable=NO
local_enable=YES
write_enable=NO
local_umask=022
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_std_format=YES
ftpd_banner=Welcome if invited!!!
chroot_local_user=YES
guest_enable=YES
guest_username=virtual
listen=Yes
listen-port=10021
passv_min_port=40000
passv_max_port=40999
pam_service_name=vsftpd
 
Old 03-17-2003, 01:08 PM   #4
SlickWilly
Member
 
Registered: Dec 2002
Posts: 327

Rep: Reputation: 30
I don't have vsftp but the error message is complaining about one of the variables you're setting there being something it doesn't understand.

A brief perusal of that file shows :

listen-port=10021

which looks out of place - because all the *other* lines use an underscore instead of a dash.

I'd bet this slice of apple-pie with cream on my desk that this is your problem.

Try changing the - to a _ and see if that helps. If not, read up on the vsftp config file, look at the variables they list, and compare them to yours.

Slick.
 
Old 03-18-2003, 07:17 AM   #5
c0c0deuz
Member
 
Registered: Aug 2001
Location: Qc, Canada
Distribution: RedHat, Mandrake, FreeEOS
Posts: 336

Original Poster
Rep: Reputation: 30
Well i just changed it and it still give my that code when i launch the service...
Is there a way to find out where it fails in the script?
 
Old 03-18-2003, 07:36 AM   #6
c0c0deuz
Member
 
Registered: Aug 2001
Location: Qc, Canada
Distribution: RedHat, Mandrake, FreeEOS
Posts: 336

Original Poster
Rep: Reputation: 30
Got it!
passv_min_port=40000
passv_max_port=40999

should read:

pasv_min_port=40000
pasv_max_port=40999
 
Old 03-18-2003, 09:57 AM   #7
SlickWilly
Member
 
Registered: Dec 2002
Posts: 327

Rep: Reputation: 30
Woot

You win! To where shall I mail your apple pie?

Last edited by SlickWilly; 03-18-2003 at 09:58 AM.
 
Old 03-25-2003, 09:22 AM   #8
c0c0deuz
Member
 
Registered: Aug 2001
Location: Qc, Canada
Distribution: RedHat, Mandrake, FreeEOS
Posts: 336

Original Poster
Rep: Reputation: 30
I have an other 500: OOPS unrecognised variable in config file

This is after trying to had two type of virtual users: one that can upload and download (User1)and the other that can only download(User2).
See: ftp://vsftpd.beasts.org/users/cevans...RTUAL_USERS_2/

I did used a other post for that same question but a tought it would by more adequate to continue on that tread that have the correct subject:

Here is the added lines that i put in vsftpd.conf:
--------------------------------------------------
user_config_dir=/etc/vsftpd_user_conf
echo "anon_world_readable_only=NO">/etc/vsftpd_user_conf/User2
--------------------------------------------------

the last line give me the unrecognised variable after starting the demon.

The question is:
Do i have to create user2 first? since they are virtual users i tought that the only user i had to create was 'vitrual'

Also, question 2 is:
Do i have to point to the directory /etc/vsftpd_user_conf for the user some how?

Thanks
 
Old 03-25-2003, 09:39 AM   #9
SlickWilly
Member
 
Registered: Dec 2002
Posts: 327

Rep: Reputation: 30
Um.. yeah,

that line - the echo line, is a one-time deal. Just do the echo from the command line and your user is set up.

You don't need it in your conf file - the program is attempting to parse the conf file and barfing when it hits that line - it doesn't know what to do with it.

The echo command will create a file - called User2 - in /etc/vsftpd_user_conf the contents of which will be 'anon_world_readable_only=NO'

When your ftp program hits the line :

user_config_dir=/etc/vsftpd_user_conf

in your conf file it knows it should be doing per user checking, and looks in that directory for your user settings (which you just made using the echo).

So.. take the 'echo' line out of your config file, and you'll be fine.

Slick.
 
Old 03-26-2003, 07:29 AM   #10
c0c0deuz
Member
 
Registered: Aug 2001
Location: Qc, Canada
Distribution: RedHat, Mandrake, FreeEOS
Posts: 336

Original Poster
Rep: Reputation: 30
Yes,
you were right again!

Now, the ftp is working fine.
I understand that the config for individual vuser are shoved in the vsftpd_user_conf directory,
is it possible to give to the vuser that have upload and download rights the access to a directory within the ftpsite that wouldn't be visible the the vuser with download right only?
And if so, how?
Many thanks
 
Old 04-05-2007, 05:09 PM   #11
cmnorton
Member
 
Registered: Feb 2005
Distribution: Ubuntu, CentOS
Posts: 585

Rep: Reputation: 35
vsftpd failure

I am getting this error:

/usr/sbin/vsftpd vsftpd
500 OOPS: missing value in config file for: ELF

on Fedora 6. I rebooted after downloading an Evolution update. After that vsftpd woul;d not run. Would someone be willing to look at my vsftpd.conf?

Thanks.
cmn

Here is vtpd.conf:

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES

pam_service_name=vsftpd
userlist_enable=YES
#enable for standalone mode
listen=YES
tcp_wrappers=YES
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
500 OOpS error w/ vsftpd 5amYan *BSD 5 11-08-2006 05:59 PM
500VSFTPD Error [OOPS: missing value in config file for: ] rhonneil Linux - Newbie 1 04-20-2006 01:56 AM
VSFTP: 500 OOPS: unrecognised variable in config file snapper64 Linux - Software 4 07-01-2005 04:16 PM
VSFTP Unrecognised Variable? sjblasko82 Linux - Software 2 11-16-2004 05:16 PM
VSFTPD Debian VSFTPD "unrecognised variable in config file" DCT Linux - Software 0 05-29-2004 11:59 PM


All times are GMT -5. The time now is 06:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration