LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-03-2003, 07:38 AM   #1
patrickdepingui
Member
 
Registered: Mar 2003
Distribution: Slackware
Posts: 53

Rep: Reputation: 15
3c509B NIC detected, but can only ping to myself


Hi,

I have a 3com 3c509 B NIC and Slackware 8.1. The card was automatically detected by Slackware and the driver loads on startup.

My computer is the client, that connects through a hub to another computer that is connected with internet.

The problem: I can only ping to myself (192.168.1.2) but not to 192.168.1.1 (the server) or any other pc.

When I look at the LED on the network card, it is not lit (which means no link) , and the LED on the hub isn't lit either. I am sure the hub and the cable work.

What could be the problem?
Thanks
Patrick de Pinguin
 
Old 04-03-2003, 08:32 AM   #2
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
Do a 'lsmod' (assuming you didn't recompile your kernel to get your NIC working, and are using LKMs instead) and ensure that the '3c509' module is being listed at loaded. Next, check your /etc/modules.conf for a line that says 'alias eth0 3c509'. After that, double check your eth0 interface configuration file and make sure that it's not using 'lo' as a interface or something else strange... After that, do a 'ifup eth0' and see if you can get that link light on.
 
Old 04-05-2003, 03:25 AM   #3
patrickdepingui
Member
 
Registered: Mar 2003
Distribution: Slackware
Posts: 53

Original Poster
Rep: Reputation: 15
lsmod lists 3c509 correctly

I've put an alias line in modules.conf

I don't exactly now what the interface configuration file is.
Do you mean rc.inet1 and rc.inet2 ? (slackware)

When I do ifconfig, it lists both eth0 and lo. Should there be only one of them?

I've done an ifconfig eth0 up (=ifup) and a ifconfig lo down
Do I have to reboot after that?

Anyway the link LED isn't let yet.

Could it be that it has something to do with the ISA pnp not yet disabled. There could be some issues to get the card detected with pnp enabled, but since my card was correctly detected I thought it wasn't necessary.

What can I do next?
Patrick de Pinguin
 
Old 04-05-2003, 07:57 AM   #4
fsbooks
Member
 
Registered: Jan 2002
Location: Missoula. Montana, USA
Distribution: fedora, slackware, suse
Posts: 447

Rep: Reputation: 31
How about a listing of "ifconfig" and/or "netstat -r" to start?
 
Old 04-05-2003, 08:40 AM   #5
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
Okay:

If lsmod lists 3c509 correctly, then you don't have any ISP-PNP issues. If a kernel module loads properly, you are in good shape as far as the OS recognizing the hardware is concerned.

I'm starting to think that the lights on your NIC don't work, have you ever seen them lit (like, while using Windows on this PC)? I know you said that the patch cable is good, but do you have another you could swap it with?

lo is the local loop back interface for localhost / 127.0.0.1 and is needed to keep the most basic network-related functions of the system running. Don't ever 'ifdown lo'! You do want both 'lo' and 'eth0' up.

Linux, unlike Windows, does not need to be rebooted every time you look at it the wrong way. Configuring and bringing interfaces up and down should never require a reboot.

I couldn't tell ya where the interface configuration files are for Slack, I'm really only familiar with RedHat (as far as Linux distrobutions go). In RedHat, this file is /etc/sysconfig/network-scripts/ifcfg-eth0, but it's probably different on Slack.
 
Old 04-05-2003, 09:49 AM   #6
patrickdepingui
Member
 
Registered: Mar 2003
Distribution: Slackware
Posts: 53

Original Poster
Rep: Reputation: 15
Hi, I got it to work.

I will explain what i did for those who are having the same problems.

I think the main problem was the card. I have a 3c509 COMBO card, so it has RJ45, BNC and AUI. I had to manually set the transceiver type to TP RJ45.

To do this you have to execute the 3c5x9cfg.exe program that is on the second boot disk, that came along with the card. If you don't have those, you can download it from
http://www.3com.com/products/en_US/s...d&search=3c509

If you're like me and didn't have DOS anymore, you can still run the program. Put command.com (from a dos or windows pc) on a disk, and boot your computer from this diskette. You'll get a A:> prompt. Then insert the second boot disk and execute 3c5x9cfg.exe .

The settings I changed are
- Transceiver type (to TP RJ45),
- pnp disabled (I don't know if I had to, but I did it anyway since other sites said this wouldn't harm)
- Modem speed (to "no modem" as I read this somewhere on the internet)

That's about it. Then click OK do write the new settings to the card.

From now on the link on the card was lit, and everything worked like it had to.

Thanks everyone for the advice!
Patrick de Pinguin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gigabit NIC not detected Wraezor Linux - Hardware 9 08-01-2005 09:14 AM
nic not detected gnmabc Linux - Networking 7 06-13-2005 04:57 PM
How to specify the NIC detected by pcap wangjinyi Linux - Software 0 09-23-2004 02:42 AM
old question... trying to install NIC: 3com 3c509b-TPO kngharv Linux - Software 4 10-31-2002 05:03 PM
3C509B-TPO NIC installation isbrower Linux - Networking 7 04-13-2001 08:18 AM


All times are GMT -5. The time now is 11:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration