LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-17-2006, 07:35 PM   #1
baisa
LQ Newbie
 
Registered: May 2004
Posts: 5

Rep: Reputation: 0
2nd RTL8169 NIC getting funky dev name


I have two RTL8169 adapters and an Intel motherboard adapter in my PC. It assigns correctly as follows:
eth0: 1st pci adapter, RTL8169
eth1: Intel adapter

but it doesn't assign an eth2 to my 2nd pci RTL
instead, i see some funky dev name, like:
dev15326 or dev29982 (it changes every time)

those aren't detected in the gui for network config, but if i run
ifconfig using those names, i can get the adapter to start working properly -- but weirdly, I do see the second pci card listed in the network gui, as "eth2", but if I try creating an eth2 connection using that eth2 hardware device, it never works, i just get an error msg "that hardware device doesn't seem to exist" when i try starting it

anyone have any idea why my second pci adapter is getting such a weird device name, and why it doesn't just get called "eth2"???

i've tried a couple of things, like changing PNP OS setting in the BIOS, but that doesn't seem to help


thanks for any help?
 
Old 06-19-2006, 05:23 AM   #2
Notwerk
Member
 
Registered: Apr 2005
Location: Jordan
Distribution: Debian (Sarge), Ubuntu (6.06)
Posts: 271

Rep: Reputation: 30
1) Which distro are you using?
2) What modules are loaded in the kernel?
Code:
#lsmod
#cat /etc/modprobe.conf

Last edited by Notwerk; 06-19-2006 at 05:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2nd NIC? Cornholio Slackware 3 04-25-2005 10:17 AM
rtl8169 gigabit ethernet NIC problem on ipcop icga Linux - Networking 6 12-03-2004 03:26 AM
RTL8169 NIC and Fedora Core 2 putnampp Linux - Networking 0 08-25-2004 08:44 PM
1st nic regular FTP, 2nd nic SSH Riselong Linux - Distributions 2 02-02-2004 05:13 PM
2nd NIC def1014 Linux - Networking 3 10-23-2002 08:54 AM


All times are GMT -5. The time now is 07:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration