LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-09-2003, 06:54 AM   #1
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
*INCREDIBLY* slow internet access. Help greatly appreciated.


OK I need help. My linux (dial-up) internet connection has reached nauseatingly slow speeds and I can't work out why. It has some quick spurts here and there but for the most part it's really slow (we're talking <1.0 kb/s!). Usually it starts of reasonably (after a reboot) and then gets steadily slower regardless if I log off and log back on.

A little background info... I run Debian stable/testing with kernel 2.4.21 (custom). My pppd version is 2.4.1. I've recently reinstalled my entire Linux system. I WAS running kernel 2.4.20 just fine with very fast (for a dial-up) and stable speeds. After reinstall, I first tried the "vanilla" flavour (kernel 2.2.20) and all seemed to work fine. I compiled a custom kernel (2.4.21) and the internet speed went to the scheizehaus. Admittedly I didn't try through minicom. I kept getting VJ decompression errors. Obviously, I thought I did something wrong in the kernel config. So after unsuccessfully trying a few more times I ditched everything and reinstalled debian with the "bf24" flavour (kernel 2.4.18)... Same problem. Recompiled my 2.4.21 kernel... Same problem. I'm at wit's end here (Win XP works fine, btw).

After trawling the man pages and the internet (very slowly), I'm no closer to solving the problem. I've tried specifying novj and novjccomp in my setup to no avail. I've tried bsdcomp 15 15, deflate 15 15, nobsdcomp (didn't really want to try nodeflate). What annoys me is that I've never had to do any of these before. Also it seems that the 2.2.20 kernel can handle itself OK. I might have to sacrifice my ext3 file system and go back because these speeds are just plain STUPID. I can't post my kernel .config file (or anything else for that matter) but I'll be happy to email any files to any interested parties at a moments notice. If you wish me to do so my address is *********.

I'm really in need of help here.

Edit: all instances of the word "urgent" (<-- except this one) have been removed.

Last edited by adz; 02-27-2004 at 08:41 PM.
 
Old 08-09-2003, 07:30 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
please don't use words like "urgent" it comes across quite badly to our voluntary members. thanks
 
Old 08-09-2003, 07:51 AM   #3
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
well first give us the output of "ifconfig", of "route -n" and tell us what is your modem.
 
Old 08-09-2003, 07:57 AM   #4
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Original Poster
Rep: Reputation: 53
Output of "ifconfig":

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

ppp0 Link encap:Point-to-Point Protocol
inet addr:203.213.83.234 P-t-P:202.7.209.206 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:1024 errors:201 dropped:0 overruns:0 frame:0
TX packets:1035 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:490842 (479.3 KiB) TX bytes:163617 (159.7 KiB)

Output of "route -n"

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
202.7.209.206 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
0.0.0.0 202.7.209.206 0.0.0.0 UG 0 0 0 ppp0

My modem is a Rockwell Lightfax. It's your garden variety 56k external modem.

Last edited by adz; 08-09-2003 at 08:00 AM.
 
Old 08-09-2003, 11:11 AM   #5
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
well first make sure that your serial cable is OK.
Bad cable may give you silly error and downspeed.

And decrease your MTU size to 1492 (ifconfig ppp0 mtu 1492) it may help, cuz your provider maybe add something to your packet so routers then need to fragment it (it greatly lower speed). To permanently decrease this option take a look in /etc/ppp. I can't tell you exactly where is the value for this option in it, because it changes depending distro.

But I tought about your problem, you said it appeared when you recompiled your kernel for the first time. There's several options in the kernel about PPP, maybe you enabled (or disabled?) something that were not required and this cause problem? There's several options about encryption and packet compression that can only be used if your provider use it. Maybe you should take a look at it and try different options set? It think it is in "Networking Option" Submenu.

NB : Using a different "flavor" of kernel is not the best idea since you don't even know what the kernel contain... What's about a real kernel recompilation, from source with options YOU choose?
 
Old 08-10-2003, 01:23 AM   #6
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Original Poster
Rep: Reputation: 53
Firstly my cable is OK because all is well in windows and kernel 2.2.20.

Secondly, I'll give the mtu idea a try. Sounds workable (but don't understand why changing kernels would affect this).

Thirdly, I've tried recompiling my kernel with all sorts of networking (and otherwise) options but couldn't get it to work. If you like email me and I'll send you a copy of my kernel .config file.

NB: I only installed the "flavours" from the installation cd (during debian installation). In debian you get to choose between a few different ones when you boot from the cd. This is no different to any other distro except that most distros don't give you any such options your stuck with whatever they give you. And yes I have done a real compilation from source. That's what caused all the trouble seemingly. I say seemingly because I've compiled the 2.4.20 kernel before with no problems. Now any 2.4.x kernel seems to cause errors with internet.
 
Old 08-10-2003, 08:39 AM   #7
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
Send a copy of your .config using FTP at elf.servebeer.com. Log in as anonymous.

And try to get a real fresh kernel source from kernel.org.
 
Old 08-11-2003, 01:18 AM   #8
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Original Poster
Rep: Reputation: 53
OK. I've sent you that file. Have fun with it.
 
Old 08-11-2003, 10:06 AM   #9
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
Wow, what a nice box you seem to have!!!
All SCSI eh?

I think you are missing some option in networking.
Enable Packet Socket : nmaper IO. (not sure what it does but it talks about network speed, what's your problem now.
Enable Socket Filtering
I think you should include the following option, instead of using them as modules (maybe your PPP forget to load a certain module?):
Include PPP Filtering
Include PPP Support for async serial line
Include PPP Support for syn TTY port
Include PPP Support Deflate Compression

and at my opinion, you should remove the following because these options have to be supported by your provider too:
Remove PPP Support BSD-Compress Compression
Remove Six bit SLIP Encapsulation


Try this and give me news.
 
Old 08-11-2003, 09:39 PM   #10
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Original Poster
Rep: Reputation: 53
Well.... Tentatively, (let me stress the word tentatively) the problem seems to be solved. My ppp connections are now fast again and I've got a 2.4.21 kernel loaded (770k). Not quite as trim as I had it once but close enough. Mind you I did load soundcore into the kernel this time and not as a module.

What was the problem I hear you ask...? Short answer: dunno. Long answer: I downloaded the 2.2.20 kernel source and did "make oldconfig" to rip off the old settings (which seemed to work). I then used that as a basis to make by 2.4.21 kernel. Somehow it worked. I'll review the differences more closely later but I thought I'd let you all know that all is well again (seemingly). I have a theory that it may not be the kernel, in fact, that was the problem but one of the modules that I had loaded. As yet I don't know which one. Thanks all (elf and cees) for all your help/support.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Switch runs incredibly slow newuser455 General 7 11-14-2005 08:02 PM
VNC incredibly slow (SuSE) Brian Knoblauch Linux - Software 2 07-30-2005 06:15 PM
doom running incredibly slow JackSmith Linux - Games 3 03-15-2005 10:38 PM
fedora 1 INCREDIBLY slow yoyoguy2 Fedora 14 02-13-2005 03:06 AM
Suse 9.1 incredibly slow Vorticies Linux - Distributions 4 06-12-2004 01:06 PM


All times are GMT -5. The time now is 06:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration