LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-20-2001, 07:59 PM   #1
matt
Member
 
Registered: Jul 2001
Location: Chicago
Distribution: RH7.1 ; OSX
Posts: 62

Rep: Reputation: 15
Angry \\Localhost is not accessible


Howdy folks,

Just set up Samba, and something odd is happening. From my Win98 box, I can see my Linux box (Localhost - lame name, I know) in Network Neighborhood. But when I click on it, I get the message:

\\Localhost is not accessible.
The computer or sharename could not be found. Make sure you typed it correctly, and try again.

I can ping it, and I can ping the 98 box from the Linux box. But I don't even get a password prompt from Network Neighborhood when trying to access the Linux box.

Ideas?
Thanks,

)M.
 
Old 08-20-2001, 08:15 PM   #2
loganwva
Member
 
Registered: Jul 2001
Location: West Virginia
Distribution: SuSE 9.1
Posts: 117

Rep: Reputation: 15
Did you start the Samba server, under the status menu you have to start the smbd and nmbd server. That sounds like the message I get when Samba is not running.
 
Old 08-20-2001, 08:30 PM   #3
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
If you can see the servername listed on your Net 'Hood then smb is running.

Did you add users to smb (smbpasswd -a -U username) --> required for user level access.

What kind of service have you setup on the smb server? (share/user/server)

Have you set up any shares on the server? Do they have the correct access controls on both the smb.conf and unix permissions.

Last edited by mcleodnine; 08-20-2001 at 08:34 PM.
 
Old 08-20-2001, 11:25 PM   #4
cinnix
Member
 
Registered: Jun 2001
Location: Northern Ohio
Distribution: RedHat, Engarde and LFS
Posts: 237

Rep: Reputation: 30
The domain name whould be the same as the workgroup name. This can all be changed in Network Neighborhood properties. You also have to set up the Microsoft network client.
 
Old 08-20-2001, 11:49 PM   #5
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
You only need to set up the "Client for Microsoft Networks" and the TCP/IP protocol. If you can see the server name (the NetBIOS name) in your Network Neighborhood window then you've already got it. You don't need to set up "File and Printer Sharing" as that is only needed to share files + printers _from_ the Windows client.
 
Old 08-25-2001, 11:45 AM   #6
matt
Member
 
Registered: Jul 2001
Location: Chicago
Distribution: RH7.1 ; OSX
Posts: 62

Original Poster
Rep: Reputation: 15
Howdy and thanks for the quick replies!









In response to your questions and suggestions:









* Samba is running the SMB and NMBD services. When I start Samba from a command line, they both startup "OK"









* The Domain and Workgroup name are the same on the Windows box.









* The Microsoft Network Client is setup as the default login. (This computer used to be on a Windows network).









* TCP/IP is setup correctly on the windows box for the adapter. Both Windows and Linux are on the same subnet and use the same gateway.

The windows ip is 173.111.111.113 and linux is 173.111.111.112






When I use 'smbclient -L localhost I get:



_______________

SSL: Error setting CA cert locations: error: 00000000:lib(0):func(0):reason(0)

trying default locations.

added interface ip=173.111.111.112 bcast=173.111.255.255 nmask=255.255.0.0



Domain = [WORKGROUP] OS=[Unix] Server=[Samba 2.0.7]



Sharename / Type

--------------------------

homes / Disk

tmp / Disk

/mnt/zip100.0 / Disk

IPC$ / IPC



Server

---------

LOCALHOST



Workgroup

---------------

WORKGROUP



______________________________



And here's my configuration file:

______________________________

# Global parameters

[global]

encrypt passwords = Yes

log file = /var/log/samba-log.%m

max log size = 50

dns proxy = No

wins support = Yes

comment = Red Hat Samba Server

hosts allow = 173.111.111.113/255.255.0.0

strict locking = Yes

volume = Red Hat 7.1



[homes]

comment = Home Directories

path = /home/matt

guest account = matt

writeable = Yes

create mask = 0750

guest ok = Yes

strict locking = No



[tmp]

comment = Temporary file space

path = /tmp

writeable = Yes

guest ok = Yes



[/mnt/zip100.0]

path = /mnt/zip100.0

guest account = matt

writeable = Yes

guest ok = Yes

strict locking = No



_______________________



Another weird thing is happening. On the Windows box, when I go to Network Neighborhood, I initially don't see the linux box. But then I ping it, and it's there!



But I still get the same message: //Localhost not accessible.



Been toiling at this on and off all week... Needless to say any new insight is much appreciated!!!



)M.
 
Old 08-25-2001, 01:08 PM   #7
sancho5
Member
 
Registered: Jul 2001
Location: Utah
Distribution: RedHat v7.3, OpenBSD 3.3, FreeBSD 5.0
Posts: 327

Rep: Reputation: 30
I don't know if you confirmed it or not, but did you set up an encrypted user password on your linux box? If no, windows is sending a hashed p/w and linux isn't reading it. Be sure to run
Code:
#smbpasswd -a <username>
where <username> is the login name from your windoze box and the password matches. Restart the daemons and you should be able to connect.
 
Old 08-25-2001, 01:46 PM   #8
Jase
Member
 
Registered: May 2001
Location: Panama City Beach, FL
Distribution: *.BSD
Posts: 113

Rep: Reputation: 15
this is my smb.conf. All I can say is,...remove everything from the file and use ONLY what you need. This is what I used to get mine working,.........finally,....lol

Code:
[global]
        workgroup = workgroup
        encrypt passwords = yes 
        server string = FILE BITCH
        security = user

[pub] 
        comment = For testing only, please
        path = /var/ftp/pub
        read only = no
        guest ok = yes
        comment = whatever you want here
 
Old 08-25-2001, 02:11 PM   #9
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Your 'hosts allow' is a little on the funky side. If you want the entire subnet to see it, you should use 173.111.0.0 255.255.0.0 as the bitmasking will be, well, different. I'm too lazy to find it right now, but if you look through the Net2 HowTo you should be able to find the netmask section. Have a look.

A 'netbios name' for your server might help windows see the server.

If you have 'win support = yes' then you might also want to add ' name resolve order = wins lmhosts host bcast '

Gotta run - We're having a garage sale and it's super busy!
 
Old 08-26-2001, 11:18 AM   #10
matt
Member
 
Registered: Jul 2001
Location: Chicago
Distribution: RH7.1 ; OSX
Posts: 62

Original Poster
Rep: Reputation: 15
Thanks for all the posts - even while having a garage sale! Hope it went well. I've worked at many a garage sale that's gotten out of hand and gave me nightmares about haggling with the oddest of people.

If anything, I'm learning a lot about my system, but still no luck with an actual connection to Samba from my Windoze box. (//BigRed not accessible...)

Here's the latest:
GATEWAY (windoze):

*There's a dail up TCP/IP, which I don't touch.

*The Ethernet TCP/IP settings are:
IP: 192.168.1.2
Sub: 255.255.255.0
Wins: 192.168.1.1 (Linux)
No Gateway or DNS are defined, since it didn't seem to help any.

*The login I use is the same as my main LInux user (non-root).

*Network neighborhood will sometimes show the linux box (I successfully changed the hostname to BigRed), and other times it will not show it, and only show Gateway or say that the network is not browseable. It seems to mostly show BigRed after a reboot. Then if I close the NN window and reopen it, there's either nothing except the Entire Network icon, sometimes joined by Gateway.

*I added BigRed to the C:/Windows/host.sam file, and also created an Lmhosts.sam file:
192.168.1.1 BigRed #PRE
But this doesn't seem to matter as I can only ping BigRed by IP, and not name.

BIGRED (linux):
*Active Interfaces:
lo 127.0.0.1
eth0: 192.168.1.1
No default Gateway or Device specified.

*smbpasswd file:
matt:500:long encrypted password

*For the smbusers file, I added the last line as an experiment, which didn't help:
root = admisitrator admin
nobody = guest pcguest smbguest
matt = smbuser user

*Hosts file:
127.0.0.1 BigRed.localdomain
192.168.1.1 BigRed
192.168.1.2 Gateway (Windoze)

And lastly, here's my smb.conf file:

# Global parameters
workgroup = WORKGROUP
server string = Samba SMB Server
security = share
encrypt passwords = yes
ssl CA certFile = /usr/share/ssl/certs/ca-bundle.crt
wins support = yes

[public]
comment = public
path = /home/public
read only = no
guest ok = yes
public = yes

[data]
comment = Data
path = /home/samba/data
read only = no
guest ok = yes
public = yes

___________________

If you've read this far - Thank you! I"ve been banging my head against the wall for most of my weekend (some weekend!)

Any help is much, much, mucho appreciated.

)M.
 
Old 08-27-2001, 08:49 PM   #11
matt
Member
 
Registered: Jul 2001
Location: Chicago
Distribution: RH7.1 ; OSX
Posts: 62

Original Poster
Rep: Reputation: 15
So get this,

I added 255.255.255.1 as the gateway on both computers.

I can use the :

smbclient "\\\Gateway\\d"

command and samba over to the shared drives on my PC, no problemo. But, I still get that damn message from Windoze when trying to log onto LInux. What gives?

)M.

Last edited by matt; 08-27-2001 at 09:44 PM.
 
Old 08-27-2001, 09:11 PM   #12
drjimstuckinwin
Member
 
Registered: Mar 2001
Location: Manchester UK
Distribution: Mainly Fedora
Posts: 496

Rep: Reputation: 30
At risk of insulting you...
1 Setup network.... ping your localmschines
2 Setup Samba ..... see yourlocalmachines
3 Setup NAT via IPTables i.e. minimum
echo =1 /proc/sys/net/ipv4/ipforward
or something like that.
There are multiple posts on these boards about NAT and I don't have access to my RH machine to tell you exactly what you need to type, but that's nearly it!
Jim
 
Old 09-01-2001, 08:59 PM   #13
matt
Member
 
Registered: Jul 2001
Location: Chicago
Distribution: RH7.1 ; OSX
Posts: 62

Original Poster
Rep: Reputation: 15
I've removed the gateway, since it was causing problems with the modem and isn't needed on my little LAN, as I found out.

*******************************************

For those of you following this thread, I've started another one called:

Dualing Browse Masters?
Which is here:
http://www.linuxquestions.org/questi...&threadid=6127

And the adventure continues...

)M.

ps. Picked up Craig Hunt's Samba Admin book. It's great and well written (a rarity in computer books), and I'm learning a ton, but still no resolution on this particular problem.

Last edited by matt; 09-01-2001 at 09:03 PM.
 
Old 10-02-2001, 12:02 PM   #14
humbads
LQ Newbie
 
Registered: Oct 2001
Posts: 1

Rep: Reputation: 0
try ipchains

I had the same problem for many days and many hours. (Yes, I'm a newbie to linux.) I even bought that Craig Hunt book. Today, I determined myself to fix it and found out that my ipchains firewall was configured to disallow all inbound connections except a few. I'm running redhat 7.1, and I configured the firewall when I installed it.

Here's my updated /etc/sysconfig/ipchains file:

# Firewall configuration written by lokkit
# Manual customization of this file is not recommended.
# Note: ifup-post will punch the current nameservers through the
# firewall; such entries will *not* be listed here.
:input ACCEPT
:forward ACCEPT
:output ACCEPT
-A input -s 0/0 -d 0/0 22 -p tcp -y -j ACCEPT
-A input -s 0/0 -d 0/0 80 -p tcp -y -j ACCEPT
-A input -s 0/0 -d 0/0 21 -p tcp -y -j ACCEPT
-A input -s 0/0 -d 0/0 139 -p tcp -y -j ACCEPT (***added***)
-A input -s 0/0 -d 0/0 139 -p udp -y -j ACCEPT (***added***)
-A input -s 0/0 -d 0/0 901 -p tcp -y -j ACCEPT (***added***)
-A input -s 0/0 -d 0/0 -i lo -j ACCEPT
-A input -s 64.79.64.4 53 -d 0/0 -p udp -j ACCEPT
-A input -s 64.79.64.5 53 -d 0/0 -p udp -j ACCEPT
-A input -s 0/0 -d 0/0 -p tcp -y -j REJECT
-A input -s 0/0 -d 0/0 -p udp -j REJECT

I added the three lines to enable samba on port 139 and swat on port 901 and it worked.

Shailesh

Last edited by humbads; 10-03-2001 at 02:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Change localhost name in username@localhost n175uj Linux - Newbie 4 07-01-2005 08:25 PM
Message from syslogd@localhost localhost kernel: Disabling IRQ #21 ylts Linux - Hardware 0 02-26-2005 08:01 AM
NTFS (winxp) drive is accessible only by root, why NTFS (winxp) drive not accessible Samppa72 Linux - Software 1 07-26-2004 03:13 PM
dns requests from localhost to localhost keex Linux - Networking 2 11-13-2003 01:47 PM
computer name is not accessible TriniMan Linux - Networking 4 04-30-2002 09:20 AM


All times are GMT -5. The time now is 01:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration