LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Mobile
User Name
Password
Linux - Mobile This forum is for the discussion of all topics relating to Mobile Linux. This includes Android, Tizen, LiMo, Maemo, MeeGo, Openmoko, Ubuntu Mobile, WebOS, Firefox OS, Open Mobile Alliance and other similar projects and products.
A reminder that LQ now has a dedicated Android sister site: AndroidQuestions.org

Notices

Reply
 
Search this Thread
Old 03-23-2011, 07:07 PM   #1
preetb123
LQ Newbie
 
Registered: Jan 2011
Posts: 28

Rep: Reputation: 0
reboot failed error while loading new zImage in the android emulator


I have compiled Linux source for android and now i have a zImage that is to be loaded on existing emulator.

Kernel: arch/arm/boot/Image is ready
Kernel: arch/arm/boot/zImage is ready


i get the following error while i try to install new zImage in the emulator

root@ubuntu:~/android-sdk-linux_x86/tools# ./emulator -avd avd1.5 -kernel ~/common/arch/arm/boot/zImage -show-kernel -verbose
.
.
.
yaffs: Attempting MTD mount on 31.2, "mtdblock2"
yaffs_read_super: isCheckpointed 0
sh: can't access tty; job control turned off
# init: cannot find '/system/bin/playmp3', disabling 'bootsound'
init: cannot find '/system/bin/dbus-daemon', disabling 'dbus'
eth0: link up
init: untracked pid 579 exited
init: untracked pid 578 exited
warning: `rild' uses 32-bit capabilities (legacy support in use)
init: untracked pid 592 exited
init: untracked pid 601 exited
init: untracked pid 604 exited
init: untracked pid 605 exited
init: critical process 'servicemanager' exited 4 times in 4 minutes; rebooting into recovery mode
save exit: isCheckpointed 1
save exit: isCheckpointed 1
Restarting system with command 'recovery'.
Reboot failed -- System halted
emulator: User configuration saved to /home/preetam/.android/avd/avd1.5.avd/emulator-user.ini
root@ubuntu:~/android-sdk-linux_x86/tools#


where am i doing wrong, and what is the correct way?

please someone help. i need this urgently..

thank you!
 
Old 04-13-2011, 02:47 AM   #2
EricTRA
Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 18 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290
Hello,

You marked your thread as SOLVED. Do you mind sharing with the community what the answer/solution was so that others in similar situation can see if it works for them? Have fun with Linux. Off the Zero Reply List.

Kind regards,

Eric
 
Old 04-14-2011, 04:45 AM   #3
preetb123
LQ Newbie
 
Registered: Jan 2011
Posts: 28

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by EricTRA View Post
Hello,

You marked your thread as SOLVED. Do you mind sharing with the community what the answer/solution was so that others in similar situation can see if it works for them? Have fun with Linux. Off the Zero Reply List.

Kind regards,

Eric
I compiled zImage for Android 2.1 emulator, and tried to load it in Android 1.5 emulator. So it didn't work. When i loaded it in 2.1, it works fine.
If anyone has any problems regarding compiling kernel images for android emulator(any version), feel free to post your question in this thread. I am not yet successful with compiling kernel images for real android phones. I tried to Samsung Galaxy but the compiled image didn't work in the phone and the phone bricked. I am trying with it. If anyone has any idea, please share.

Thank you.!
 
  


Reply

Tags
android, emulator, kernel module, kernel source, reboot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reboot Error: "initlog: error while loading shared libraries: libpopt.so.0" saranga2000 Linux - Enterprise 4 04-26-2013 06:50 PM
[SOLVED] error while loading new compiled Linux kernel image into the android emulator(1.5) preetb123 Linux - Mobile 0 03-21-2011 11:48 AM
Could not start Android emulator in Slackware 13.1 kemsiro Slackware 9 02-10-2011 04:28 AM
Android Development in Linux.How To install Android Emulator?? jeevanism Linux - Mobile 3 12-28-2010 09:24 AM
'GRUB Loading stage2. Read Error' message after first reboot alexsandra Fedora - Installation 3 06-30-2008 04:22 PM


All times are GMT -5. The time now is 06:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration