LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Mobile (http://www.linuxquestions.org/questions/linux-mobile-81/)
-   -   reboot failed error while loading new zImage in the android emulator (http://www.linuxquestions.org/questions/linux-mobile-81/reboot-failed-error-while-loading-new-zimage-in-the-android-emulator-870600/)

preetb123 03-23-2011 08:07 PM

reboot failed error while loading new zImage in the android emulator
 
I have compiled Linux source for android and now i have a zImage that is to be loaded on existing emulator.

Kernel: arch/arm/boot/Image is ready
Kernel: arch/arm/boot/zImage is ready


i get the following error while i try to install new zImage in the emulator

root@ubuntu:~/android-sdk-linux_x86/tools# ./emulator -avd avd1.5 -kernel ~/common/arch/arm/boot/zImage -show-kernel -verbose
.
.
.
yaffs: Attempting MTD mount on 31.2, "mtdblock2"
yaffs_read_super: isCheckpointed 0
sh: can't access tty; job control turned off
# init: cannot find '/system/bin/playmp3', disabling 'bootsound'
init: cannot find '/system/bin/dbus-daemon', disabling 'dbus'
eth0: link up
init: untracked pid 579 exited
init: untracked pid 578 exited
warning: `rild' uses 32-bit capabilities (legacy support in use)
init: untracked pid 592 exited
init: untracked pid 601 exited
init: untracked pid 604 exited
init: untracked pid 605 exited
init: critical process 'servicemanager' exited 4 times in 4 minutes; rebooting into recovery mode
save exit: isCheckpointed 1
save exit: isCheckpointed 1
Restarting system with command 'recovery'.
Reboot failed -- System halted
emulator: User configuration saved to /home/preetam/.android/avd/avd1.5.avd/emulator-user.ini
root@ubuntu:~/android-sdk-linux_x86/tools#


where am i doing wrong, and what is the correct way?

please someone help. i need this urgently..

thank you!

EricTRA 04-13-2011 03:47 AM

Hello,

You marked your thread as SOLVED. Do you mind sharing with the community what the answer/solution was so that others in similar situation can see if it works for them? Have fun with Linux. Off the Zero Reply List.

Kind regards,

Eric

preetb123 04-14-2011 05:45 AM

Quote:

Originally Posted by EricTRA (Post 4323010)
Hello,

You marked your thread as SOLVED. Do you mind sharing with the community what the answer/solution was so that others in similar situation can see if it works for them? Have fun with Linux. Off the Zero Reply List.

Kind regards,

Eric

I compiled zImage for Android 2.1 emulator, and tried to load it in Android 1.5 emulator. So it didn't work. When i loaded it in 2.1, it works fine.
If anyone has any problems regarding compiling kernel images for android emulator(any version), feel free to post your question in this thread. I am not yet successful with compiling kernel images for real android phones. I tried to Samsung Galaxy but the compiled image didn't work in the phone and the phone bricked. I am trying with it. If anyone has any idea, please share.

Thank you.!


All times are GMT -5. The time now is 03:54 AM.