LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Mobile
User Name
Password
Linux - Mobile This forum is for the discussion of all topics relating to Mobile Linux. This includes Android, Tizen, LiMo, Maemo, MeeGo, Openmoko, Ubuntu Mobile, WebOS, Firefox OS, Open Mobile Alliance and other similar projects and products.
A reminder that LQ now has a dedicated Android sister site: AndroidQuestions.org

Notices

Reply
 
Search this Thread
Old 09-23-2009, 12:48 PM   #1
kev000
Member
 
Registered: Oct 2006
Posts: 53

Rep: Reputation: 15
permissions issue in audio/alsa/pulseaudio


I'm developing linuxice and I'm currently having an issue with getting sound working. LinuxICE is based on ubuntu but built from the ground up with only the bare necessities (ie, no GDM, etc). I'm starting a minimal session by logging into the user via mingetty in /etc/event.d/tty1 and then startx via ~/.bash_profile.

aplay -l says i have no sound cards, while sudo aplay -l lists it correctly. Pulseaudio reports that it's using a NULL Output device for sound. Killing it and restarting it does nothing.

ck-list-sesssions lists: "active = FALSE".

Any help would be appreciated. My guess is that consolekit (or something else), isn't giving the user permission for the audio devices and thus pulseaudio run in user mode cannot access the sound devices either...

thanks
 
Old 09-23-2009, 09:55 PM   #2
kev000
Member
 
Registered: Oct 2006
Posts: 53

Original Poster
Rep: Reputation: 15
Here's the output of getfacl /dev/snd/* :

Code:
# file: dev/snd/pcmC0D0c
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D0p
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D1c
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/seq
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/timer
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---
 
Old 10-27-2009, 09:39 PM   #3
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: LFS-Version SVN-20091202, Arch 2009.08
Posts: 1,485

Rep: Reputation: 66
I had a similar problem in gentoo after a fresh build on my laptop.

Make sure that your user is added to the audio group in /etc/group
otherwise they will not have the correct permissions to access the audio hardware.

Sorry for the late reply btw I have been MIA from this site for a while now.

Last edited by exvor; 10-27-2009 at 09:40 PM. Reason: im a tard
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva: how to disable pulseaudio and enable Alsa veezee Linux - Hardware 5 09-16-2009 08:21 AM
sound is very faint (alsa and pulseaudio, Fedora 10) bach-fiend Linux - Newbie 3 02-16-2009 03:11 PM
smplayer: video+audio stutters with pulseaudio, audio files play fine GamerX Linux - Desktop 1 02-06-2009 08:53 PM
PulseAudio permissions issue pauledwards03 Linux - Software 1 07-15-2008 07:47 PM
ALSA sound audio issue resolved - You may find this useful fuzzyworm Linux - Software 0 03-26-2006 04:42 PM


All times are GMT -5. The time now is 06:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration