LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Mobile
User Name
Password
Linux - Mobile This forum is for the discussion of all topics relating to Mobile Linux. This includes Android, Tizen, LiMo, Maemo, MeeGo, Openmoko, Ubuntu Mobile, WebOS, Firefox OS, Open Mobile Alliance and other similar projects and products.
A reminder that LQ now has a dedicated Android sister site: AndroidQuestions.org

Notices

Reply
 
Search this Thread
Old 11-07-2011, 02:15 PM   #1
Jorcelangelo
LQ Newbie
 
Registered: Nov 2011
Location: USA
Distribution: Ubuntu / Fedora
Posts: 4
Blog Entries: 1

Rep: Reputation: Disabled
LXDE on Android


Hello,

I need some help. I have a Debian Squeeze on a loop on my Android cellphone Samsung Galaxy S. It is working just fine on terminal. I just chalenged my self to install the LXDE with the following commands:

aptitude update
aptitude install lxde

Everything ran just fine on the instalation. Now when attempted to run the LXDE with the command

startx

It don't want to come up and says:

Fatal server error:
no screens found

what should I do now to get this LXDE running?
 
Old 11-08-2011, 02:07 AM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,429

Rep: Reputation: 100Reputation: 100
Edit xorg.conf and add the monitor? May reside in /etc/X11...

I don't know anything about cellphones but that`s the place where the x system will look for screens.

Last edited by j-ray; 11-08-2011 at 02:08 AM. Reason: typo
 
Old 11-08-2011, 06:46 AM   #3
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,224

Rep: Reputation: 251Reputation: 251Reputation: 251
Option 1: Specify nomodeset on the kernel line when you boot Squeeze. This will force Xorg to use the vesa driver, which may work betterthan whatever driver your system is trying to use.

Option 2: Run Xorg -configure (as root) to create the file xorg.conf.new. If there were errors reported, you will probably need to edit this file before copying or moving it to /etc/X11/xorg.conf.
 
Old 12-07-2011, 09:53 PM   #4
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,325
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
Sorry I can't help but as a request, if u get lxde working, can you please post pics of your device
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Android App Build Environment With Eclipse, Android SDK, PhoneGap (Fedora 14) LXer Syndicated Linux News 2 02-01-2011 11:11 AM
LXer: Setting Up An Android App Build Environment With Eclipse, Android SDK, PhoneGap (Ubuntu 10.10) LXer Syndicated Linux News 0 01-27-2011 11:30 AM
LXer: Get Started with Android application development using Linux and Android SDK LXer Syndicated Linux News 0 01-06-2011 01:50 PM
LXer: What I like about Android - and what I don't -- My Android Review (including my Favorite Apps) LXer Syndicated Linux News 0 11-18-2010 02:20 PM
Opensuse 11.2 lxde or PclinuxOs 2009.4 lxde damipereira Linux - Distributions 1 02-16-2010 02:51 AM


All times are GMT -5. The time now is 06:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration