LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Mobile
User Name
Password
Linux - Mobile This forum is for the discussion of all topics relating to Mobile Linux. This includes Android, Tizen, LiMo, Maemo, MeeGo, Openmoko, Ubuntu Mobile, WebOS, Firefox OS, Open Mobile Alliance and other similar projects and products.
A reminder that LQ now has a dedicated Android sister site: AndroidQuestions.org

Notices

Reply
 
Search this Thread
Old 08-02-2011, 07:10 AM   #1
ddilip
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Rep: Reputation: Disabled
Cannot Install Adnroid Patches.


Hi everyone.
I m tring to integrate SmartCard Api with my Android emulator on my red hat machine. After installation on android2.2, 2.3 and 3.0. I have tried to install the 3 patches.

smartcard-api-2.2.1.patch
uicc.patch
emulator.patch
cts.patch

I have followed the followig web link to intsall this patch files.

http://code.google.com/p/seek-for-an...ldingTheSystem.

While the installation get starts it is asking the File to patch.


[root@localhost smartcard-api-2_2_1]# patch -p1 < uicc.patch
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -urBNpa ref/frameworks/base/telephony/java/com/android/internal/telephony/CommandException.java work/frameworks/base/telephony/java/com/android/internal/telephony/CommandException.java
|--- ref/frameworks/base/telephony/java/com/android/internal/telephony/CommandException.java 2011-07-15 10:03:59.000000000 +0200
|+++ work/frameworks/base/telephony/java/com/android/internal/telephony/CommandException.java 2011-07-15 10:16:19.000000000 +0200
--------------------------
File to patch:




I have tried to give some paths. But that did not matches anymore.

Any one Can you help me to install these patches??????


Thanks,
Dilip.
 
Old 08-02-2011, 08:21 AM   #2
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
Hello,

Normally whenever I am dealing with patch files that do not work, due to either compatibility, different versions, etc, I just edit the needed files manually. I do this by opening the patch file by itself, then the file that needs to be patched, in separate windows, and then I just scroll, copy, and paste over. If you need more assistance, please let me know.

Cheers,

Josh
 
1 members found this post helpful.
Old 08-02-2011, 08:30 AM   #3
ddilip
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Re: Android patches not working

Hello Josh,

I m really happy about your reply for my post.

I ll be happy if you send me some more deep ideas on this request.


Thanks,
Dilip.


Quote:
Originally Posted by corp769 View Post
Hello,

Normally whenever I am dealing with patch files that do not work, due to either compatibility, different versions, etc, I just edit the needed files manually. I do this by opening the patch file by itself, then the file that needs to be patched, in separate windows, and then I just scroll, copy, and paste over. If you need more assistance, please let me know.

Cheers,

Josh
 
Old 08-02-2011, 09:01 AM   #4
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
I already gave you my ideas and my two cents. If you don't understand, send me the patch file and the file that needs to be patched to my email.

Cheers,

Josh
 
Old 02-29-2012, 03:24 AM   #5
simo_s
LQ Newbie
 
Registered: Feb 2012
Posts: 2

Rep: Reputation: Disabled
Hello
ddilip, I'm also trying to use the same tutorial of seek-android you have mentionned to build the system, please have you found a solution to this problem?
My problem is that I don't know which source files I have to patch with patches I've downloaded.
Thank you.
 
Old 02-29-2012, 04:53 AM   #6
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
Quote:
Originally Posted by simo_s View Post
Hello
ddilip, I'm also trying to use the same tutorial of seek-android you have mentionned to build the system, please have you found a solution to this problem?
My problem is that I don't know which source files I have to patch with patches I've downloaded.
Thank you.
Look at the patch files themselves - The files that need to be patched will be within the contents; The filename is listed so it knows which files to patch.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which KDB patches should i to install? errik_zhang Suse/Novell 0 12-15-2008 08:48 PM
how to install patches in linux phanee Linux - Software 1 12-21-2005 07:17 AM
How to install patches. tchurch Suse/Novell 1 01-20-2005 03:06 AM
RedHat patches vs open source patches paulsh2k4 Linux - Software 1 10-14-2004 03:18 AM
Which Security Patches to install Karen61 Linux - Security 2 11-12-2003 03:20 PM


All times are GMT -5. The time now is 08:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration