LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux Mint (http://www.linuxquestions.org/questions/linux-mint-84/)
-   -   Trying to boot Linux Mint 9 from USB flash drive: "vesamenu.c32: Not a COM32R image" (http://www.linuxquestions.org/questions/linux-mint-84/trying-to-boot-linux-mint-9-from-usb-flash-drive-vesamenu-c32-not-a-com32r-image-829397/)

Kenny_Strawn 08-30-2010 06:32 PM

Trying to boot Linux Mint 9 from USB flash drive: "vesamenu.c32: Not a COM32R image"
 
I used Ubuntu's 'usb-creator-gtk' to write Linux Mint to a USB flash drive and it reported success. Then, when I rebooted, I got the following error message from Syslinux:

Code:

vesamenu.c32: Not a COM32R image
boot:

What the hell went wrong? Syslinux.cfg looks fine:

Code:


default vesamenu.c32
timeout 100

menu background splash.jpg
menu title Welcome to Linux Mint 9 Isadora
menu color border 0 #00eeeeee #00000000
menu color sel 7 #ffffffff #33eeeeee
menu color title 0 #ffeeeeee #00000000
menu color tabmsg 0 #ffeeeeee #00000000
menu color unsel 0 #ffeeeeee #00000000
menu color hotsel 0 #ff000000 #ffffffff
menu color hotkey 7 #ffffffff #ff000000
menu color timeout_msg 0 #ffffffff #00000000
menu color timeout 0 #ffffffff #00000000
menu color cmdline 0 #ffffffff #00000000
menu hidden
menu hiddenrow 6
label live
menu label Start Linux Mint
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/mint.seed boot=casper initrd=/casper/initrd.lz quiet splash --
menu default
label xforcevesa
menu label Start Linux Mint (compatibility mode)
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/mint.seed boot=casper xforcevesa initrd=/casper/initrd.lz ramdisk_size=1048576 root=/dev/ram rw noapic noapci nosplash irqpoll --
label check
menu label Check the integrity of the CD
kernel /casper/vmlinuz
append noprompt boot=casper integrity-check initrd=/casper/initrd.lz quiet splash --
label memtest
menu label Memory Test
kernel memtest
label local
menu label Boot from local drive
localboot 0x80

Can any of you tell me what's wrong with USB Creator's autogenerated configuration?

linus72 08-30-2010 06:47 PM

googling i got this
https://bugs.launchpad.net/ubuntu/+s...or/+bug/617779

I always thought 9.04's was the best usb-creator
I'd just use a different vesamenu.c32 from any other livecd,etc

Kenny_Strawn 08-30-2010 06:57 PM

I am downgrading to Lucid's USB creator right now, will see how it works. I will also have to rewrite the image to the drive.

Kenny_Strawn 08-30-2010 07:15 PM

I found out that this is a problem with Syslinux, not USB Creator, and labeled it as such.

Thread marked Solved.

Kenny_Strawn 08-30-2010 07:32 PM

As an extension on how I solved my problem, I downgraded Syslinux to Lucid's version as well and it worked.

bpasdar 10-07-2010 05:01 PM

This worked for me...
 
This workaround worked for me...


From http://my.opera.com/toman/blog/setti...-new-hardware:
After some fiddling around with the syslinux config files and still not getting it to boot properly, I found a deceptively simple workaround for this: Just type "help" on the BOOT prompt, and when you get the help menu, just hit enter. The system will now boot!

Confirmed that this also works for me when booting a USB stick created by 10.10's USB creator.

cmc 11-25-2010 01:26 PM

I had the same problem, but then I used unetbootin to make my usb and it works just fine. Hope this helps, ( it did for me)

testingg2 12-28-2010 08:17 AM

got here googling "vesamenu.c32 not a com32r image"
installed the deb packages for lucid (0.2.22) in a maverick-based distro (mint 10)
still produces the same error ! any ideas ?

testingg2 12-28-2010 08:18 AM

got here googling "vesamenu.c32 not a com32r image"
installed the deb packages for lucid (0.2.22) in a maverick-based distro (mint 10)
still produces the same error ! any ideas ?

linus72 12-28-2010 08:23 AM

to correct this problem you must use the appropriate *.c32 from the correct version of syslinux

but you ca just copy your syslinux version stuff to usb and reinstall syslinux
assuminng usb is sdb1 and mounted at /media/disk
open terminal, become root with "sudo su" plus your password and
Code:

cp -r /usr/lib/syslinux/vesamenu.c32 /media/disk/syslinux/
syslinux /dev/sdb1

on slackware syslinux is in /usr/share

linuxmintbiz 01-02-2011 12:40 AM

Easiest thing to do when you get this error is:
hit tab
type "live"
press enter
then everything shoot boot up

n1ck 01-09-2011 07:32 AM

thanks saved me alot of time

gcx302 02-23-2011 04:30 PM

Linuxmintbiz,

Thanks much for that tip. I have been playing around for 2 weeks with various Linux distros and USB flash drive
creation tools (Live USB Creator, Universal USB Installer, Unetbootin, etc.) - just to make a bootable flash drive
for any Windows computer (I have Windows XP, Windows Vista, and Windows 7 systems). I had fooled around with Linux
(mostly SuSe and Red Hat) around 2007 - but had not been around it much since then. Just wanted to get back with it.

Mercifully, success with Linx Mint 10 came when I did 2 things:

A. Stopped using an 8 GB flash drive because it could not be formatted with FAT, only FAT32. Began using 2 GB and 4 GB
sticks.

B. Even though I go the error about vesamenu.c32 at boot up - I hit the TAB key, and then Enter - and the disk then
booted and brought me to the Linux Mint 10 desktop.

linuxmintbiz 02-24-2011 01:55 AM

Glad I could help :)

babuntu 03-06-2011 03:56 PM

easily solved
 
Each example I see of syslinux.cfg is different from mine, but the key lines are the same, and when you hit "tab" at the "boot" prompt you should see those options (label) for booting
live
xforcevesa
install
textonly
debug
memtest


...then, as noted by others, if you type one of these commands you will boot in that mode.

So type "live" and you will boot normally.

But, like you, I wanted to do it automatically; that's how I got here; looking for answers. Not quick enough!!

So I experimented....

*****Change the "default" where, at or near the first line of syslinux.cfg, it says

default vesamenu.c32

replace "vesamenu.c32" with "live" and voila!!!! the autoboot we wanted!!

default live
prompt 0
timeout 300

menu title ArtistX DVD 1.0
menu background splash.png
menu color title 1;37;44 #c0ffffff #00000000 std

label live
menu label live - boot the Live System
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/custom.seed boot=casper initrd=/casper/initrd.gz quiet splash --

label xforcevesa
menu label xforcevesa - boot Live in safe graphics mode
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/custom.seed boot=casper xforcevesa initrd=/casper/initrd.gz quiet splash --

label install
menu label install - start the installer directly
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/custom.seed boot=casper only-ubiquity initrd=/casper/initrd.gz quiet splash --

label textonly
menu label textonly - boot Live in textonly mode
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/custom.seed boot=casper textonly initrd=/casper/initrd.gz quiet --

label debug
menu label debug - boot the Live System without splash and show boot info
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/custom.seed boot=casper initrd=/casper/initrd.gz nosplash --

label memtest
menu label memtest - Run memtest
kernel /isolinux/memtest
append -

label hd
menu label hd - boot the first hard disk
localboot 0x80
append -


All times are GMT -5. The time now is 12:57 AM.