LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 07-10-2014, 06:39 AM   #1
Zuon
LQ Newbie
 
Registered: Jun 2014
Location: Southern Alberta
Distribution: Linux Mint DE
Posts: 14

Rep: Reputation: Disabled
Taskbar on wrong monitor


I am running LMDE - Mate with dual monitors, since I installed the Nvidia driver 319 my taskbar moved to the right monitor and the desktop icons remained on the left monitor.

I have used Nvidia Settings to set the left monitor as primary yet the taskbar remains on the wrong monitor.

I used Monitors (from Mate Menu) to set the default monitor yet this setting is ignored as well.

I have Googled and tried various other solutions as well but nothing has been able to restore the taskbar to the correct monitor.

Any help would be kindly welcomed!

Last edited by Zuon; 07-10-2014 at 07:30 AM. Reason: Corrected Title
 
Old 07-10-2014, 08:47 AM   #2
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,068

Rep: Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804
I read at the Mint forums a few days ago that you could right-click on the Taskbar and select Properties and select New Panel and hold the Alt key down while dragging the taskbar to the other monitor. Not sure this will work in your case.
 
Old 07-10-2014, 10:26 AM   #3
Zuon
LQ Newbie
 
Registered: Jun 2014
Location: Southern Alberta
Distribution: Linux Mint DE
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
...right-click on the Taskbar and select Properties and select New Panel and hold the Alt key down while dragging the taskbar to the other monitor...
I actually just tried this, I was able to move the taskbar but on restart it went back to where it was.

Thank you anyway!
 
Old 07-10-2014, 12:58 PM   #4
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,068

Rep: Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804
I'm not sure what your intentions are? I have an Acer notebookd with a 10 inch screen so I don't care about dual monitors, I just want to view on the second monitor which is a Vizio TV. If you want both monitors showing the same display, you have to have checked the box Same image in all monitors. If you don't, uncheck it. When you go to the Control Center and Monitors, you can click on the image of the 2nd monitor and that will enable you to set resolution, etc. for it. Repeat the process for the notebook. If you have checked the 'mirror images' box the highest resolution will be whichever has the lowest, probably the notebook. I came across a number of posts in regard to different setup on the Mint forums when I was doing this. I just did this a couple of days ago and it was trial and error and some online searching before I got what I wanted.

Quote:
I was able to move the taskbar but on restart it went back to where it was
I don't know about that. This is an actual install on your hard drive of Mint, correct? not a Live DVD or flash.

Last edited by yancek; 07-10-2014 at 01:00 PM.
 
Old 07-10-2014, 01:14 PM   #5
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,508

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
Something else to add to the pool of suggestions: Have you tried renaming the various hidden configuration directories in your home directory so that your WM will start from scratch and assing monitors? Also, how are you running this is it inerama, seperate X sessions something else?
I'm running Debian with the NVIDIA drivers on my desktop -- I use XFCE but I have LXDE installed so if you let me have more specifics I may (within reason and time permissing) be able to test things.
 
Old 07-10-2014, 01:30 PM   #6
Zuon
LQ Newbie
 
Registered: Jun 2014
Location: Southern Alberta
Distribution: Linux Mint DE
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
I'm not sure what your intentions are?
Umm, to have the taskbar on the left monitor where it was to begin with, until I installed the Nvidia driver...

This is new install of LMDE, yes an "actual" install. No special settings, nothing was changed no separate X session, no nothing except installing the Nvidia driver.

Quote:
Have you tried renaming the various hidden configuration directories in your home directory so that your WM will start from scratch and assing monitors?
No and I don't have a clue what you are talking about.


Once again, like I stated before the usual process of using Nvidia Settings does not stick. On restart or logout the taskbar moves back to the monitor on the right even though it is set use the left monitor as the primary/default.

I really think you are over complicating this.
 
Old 07-10-2014, 01:37 PM   #7
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,508

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
Quote:
Originally Posted by Zuon View Post
Once again, like I stated before the usual process of using Nvidia Settings does not stick. On restart or logout the taskbar moves back to the monitor on the right even though it is set use the left monitor as the primary/default
First things first, did you run nvidia-config with root permissions and save the xorg.conf? How are you setting up the monitors and what does your xorg.conf look like?
 
Old 07-10-2014, 01:42 PM   #8
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,508

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
I missed your reply to me (you can hit the quote button). There are directories within your home directory whose names start with a '.' Character and can only be seen by telling your file manager to look at hidden files (much like Windows). What I am suggesting is that you rename the ones your window manager looks in for settings and reboot as your window manager will reassign the monitors.
 
Old 07-10-2014, 02:54 PM   #9
Zuon
LQ Newbie
 
Registered: Jun 2014
Location: Southern Alberta
Distribution: Linux Mint DE
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
First things first, did you run nvidia-config with root permissions and save the xorg.conf?
Yes I did.

I set monitors to "Twin View" which is different from "Same view both monitors"

Here it is.
Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 319.72  (pbuilder@cake)  Sat Nov  9 14:29:01 UTC 2013

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 319.72  (pbuilder@cake)  Sat Nov  9 14:15:48 UTC 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics W2453"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTS 450"
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: nvidia-auto-select +1920+0, DFP: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 
Old 07-10-2014, 02:58 PM   #10
Zuon
LQ Newbie
 
Registered: Jun 2014
Location: Southern Alberta
Distribution: Linux Mint DE
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
What I am suggesting is that you rename the ones your window manager looks in for settings and reboot as your window manager will reassign the monitors.
Yes I understand you. Just not sure which files to rename.

I don't see how this would help since the monitors are assigned properly "right" and "left" with left as primary.
 
Old 07-11-2014, 08:09 AM   #11
Zuon
LQ Newbie
 
Registered: Jun 2014
Location: Southern Alberta
Distribution: Linux Mint DE
Posts: 14

Original Poster
Rep: Reputation: Disabled
I re-installed LMDE and after updates I installed Nvidia driver 319. The Taskbar once again moved to the wrong monitor, BUT this time when I changed it in Nvidia settings the settings stuck immediately after logout/login.

So I have no idea what the problem was but I will still mark this thread as solved.
 
  


Reply

Tags
nvidiasettings, taskbar


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK2 Menu button popup going the wrong way in duel monitor setup Keith Hedger Linux - Software 0 03-13-2014 07:45 PM
Expand menu and task bar on the second monitor von.hake Linux - Desktop 0 04-02-2012 05:14 AM
[SOLVED] KDE menu bar: icons all on the left. How to rectify and documentation of menu bar? JZL240I-U Linux - Desktop 5 12-30-2011 11:42 AM
When dual monitors enabled, task bar moves to wrong monitor. ozegoods Linux - Software 1 10-24-2010 08:51 PM
KDE task bar / menu bar has dissaspeared! KingofBLASH Suse/Novell 1 03-05-2006 10:24 PM


All times are GMT -5. The time now is 02:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration