LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 05-08-2013, 04:48 AM   #1
Steve W
Member
 
Registered: Mar 2007
Distribution: Ubuntu 12.04, Mint 12 LXDE
Posts: 431

Rep: Reputation: 36
Switching off startup login


I installed Linux Mint 12 LXDE on someone's old laptop. He's okay with it, but when I installed I automatically set it so he had to login with his user name and password at startup. After using it for a few days, he doesn't want this, and wants the machine to just go straight into Mint LXDE on startup, without any login being required.

I remember, when installing, specifically telling the Mint to ask for a login and password on startup - but try as I might I can now not find the option to switch this off.

Under Ubuntu 12.04 (my system), it is under System Settings/User Accounts, but I can find no similar function under Mint LXDE.

Googling this produces no results I can use. Does anyone here know?

Thank you for any advice you can give.
 
Old 05-08-2013, 05:58 AM   #2
parnmatt
Member
 
Registered: Apr 2013
Location: Lancaster
Distribution: Mac OS X
Posts: 38

Rep: Reputation: 7
I used Mint a while ago, so with a little knowledge of Mint's menus, I used my Google-fu to narrow the search parameters.

I found this on the Mint forums; I believe this maybe the solution.

If not, I'm sure it'll help guide you down the right path.

Last edited by parnmatt; 05-08-2013 at 06:00 AM.
 
Old 05-08-2013, 08:02 AM   #3
Steve W
Member
 
Registered: Mar 2007
Distribution: Ubuntu 12.04, Mint 12 LXDE
Posts: 431

Original Poster
Rep: Reputation: 36
Thanks - but unfortunately not: they are talking about Mint 13, and this one is Mint 12 LXDE (with different menu options). I just have a "Preferences" menu, and nothing currently in there applies to changing the login options.

Unless the GUI I need is not installed by default, and is only part of the installation process, not accessible after installation is complete.

Or perhaps the solution lies in changing an option in a text config file manually.

Does anyone else have any ideas for this problem?
 
Old 05-08-2013, 08:27 AM   #4
parnmatt
Member
 
Registered: Apr 2013
Location: Lancaster
Distribution: Mac OS X
Posts: 38

Rep: Reputation: 7
Ok.

Well I've been checking around found this, which may help — but you have already stated you can't find it in preferences, which may suggest you have different GUI for it.

I'm unsure which display manager is being used, but for GDM (Gnome Display Manager), edit the /etc/gdm3/daemon.conf.
for MDM (Mint Display Manager) edit /etc/mdm/mdm.conf

But as you're using LXDE, I've found three other files that possibly could hold the key /etc/lxdm/default.conf, /etc/lxdm/lxdm.conf, /etc/xdg/lxdm/lxdm.conf

In Each situation, edit the file to include/change values to:
Code:
AutomaticLoginEnable=true
AutomaticLogin=USERNAME
 
1 members found this post helpful.
Old 05-08-2013, 09:58 AM   #5
Steve W
Member
 
Registered: Mar 2007
Distribution: Ubuntu 12.04, Mint 12 LXDE
Posts: 431

Original Poster
Rep: Reputation: 36
Ah, those LXDE config files look like it. Thank you very much for your assistance, parnmatt.
 
Old 05-14-2013, 11:16 AM   #6
Steve W
Member
 
Registered: Mar 2007
Distribution: Ubuntu 12.04, Mint 12 LXDE
Posts: 431

Original Poster
Rep: Reputation: 36
For reference to anyone else reading this thread, I have located what looks like a GUI for this function on LXDE: it is under System Tools/Users and Groups, and offers the user the option not to have to type in the password during login.
 
1 members found this post helpful.
  


Reply

Tags
login, mint, mint 12, password


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Cannot login in Debian after switching to wheeze odin_ago Linux - Software 3 11-06-2011 03:38 PM
Switching from GNOME default on startup lordshipmayhem Mandriva 8 04-18-2004 09:31 AM
Switching login managers Twiggy794 Linux - Software 1 12-07-2003 09:59 PM
Switching language support at login Bert Linux - Software 2 05-02-2003 04:05 PM
Switching back to Red Hat login WMCoolmon Linux - Distributions 5 03-17-2003 03:51 PM


All times are GMT -5. The time now is 05:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration