LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux Mint (http://www.linuxquestions.org/questions/linux-mint-84/)
-   -   Switching off startup login (http://www.linuxquestions.org/questions/linux-mint-84/switching-off-startup-login-4175461133/)

Steve W 05-08-2013 05:48 AM

Switching off startup login
 
I installed Linux Mint 12 LXDE on someone's old laptop. He's okay with it, but when I installed I automatically set it so he had to login with his user name and password at startup. After using it for a few days, he doesn't want this, and wants the machine to just go straight into Mint LXDE on startup, without any login being required.

I remember, when installing, specifically telling the Mint to ask for a login and password on startup - but try as I might I can now not find the option to switch this off.

Under Ubuntu 12.04 (my system), it is under System Settings/User Accounts, but I can find no similar function under Mint LXDE.

Googling this produces no results I can use. Does anyone here know?

Thank you for any advice you can give.

parnmatt 05-08-2013 06:58 AM

I used Mint a while ago, so with a little knowledge of Mint's menus, I used my Google-fu to narrow the search parameters.

I found this on the Mint forums; I believe this maybe the solution.

If not, I'm sure it'll help guide you down the right path.

Steve W 05-08-2013 09:02 AM

Thanks - but unfortunately not: they are talking about Mint 13, and this one is Mint 12 LXDE (with different menu options). I just have a "Preferences" menu, and nothing currently in there applies to changing the login options.

Unless the GUI I need is not installed by default, and is only part of the installation process, not accessible after installation is complete.

Or perhaps the solution lies in changing an option in a text config file manually.

Does anyone else have any ideas for this problem?

parnmatt 05-08-2013 09:27 AM

Ok.

Well I've been checking around found this, which may help — but you have already stated you can't find it in preferences, which may suggest you have different GUI for it.

I'm unsure which display manager is being used, but for GDM (Gnome Display Manager), edit the /etc/gdm3/daemon.conf.
for MDM (Mint Display Manager) edit /etc/mdm/mdm.conf

But as you're using LXDE, I've found three other files that possibly could hold the key /etc/lxdm/default.conf, /etc/lxdm/lxdm.conf, /etc/xdg/lxdm/lxdm.conf

In Each situation, edit the file to include/change values to:
Code:

AutomaticLoginEnable=true
AutomaticLogin=USERNAME


Steve W 05-08-2013 10:58 AM

Ah, those LXDE config files look like it. Thank you very much for your assistance, parnmatt.

Steve W 05-14-2013 12:16 PM

For reference to anyone else reading this thread, I have located what looks like a GUI for this function on LXDE: it is under System Tools/Users and Groups, and offers the user the option not to have to type in the password during login.


All times are GMT -5. The time now is 03:33 AM.