LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 12-29-2012, 01:10 PM   #16
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,972

Rep: Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785

Have you been able to determine if Apache is working? If you have it installed properly, you should be able to access the It Works page by entering the following in your browser: http://localhost/index.html

In Opensuse, you should have the index.html file under /srv/www/htdocs
The info.php file should go there also.

In Mint, they would go under /var/www/

The info.php file should contain this code:

Code:
<?php phpinfo(); ?>
I'm not sure what you mean by "downloaded it" as all you need to do is copy the line above in a text editor and save it to the correct directory as info.php

If you are using Opensuse, you might review the instructions at the link below to see what you are missing:

http://www.howtoforge.com/installing...suse-12.2-lamp
 
Old 12-30-2012, 01:24 PM   #17
bscho
Member
 
Registered: Nov 2012
Location: London
Distribution: Suse, Mint
Posts: 128

Original Poster
Rep: Reputation: Disabled
No php

Using Suse 12.2, trying to get LAMP working;

Apache is working the localhost shows the index page. The php info is in my index.html page. the php.ini is in the document root. So apache must be working because it index .html comes up when I look with a browser at localhost. The MYSQL works OK.

Using mint I have not had any joy, because I cannot load from the servers (ubuntu) the apache. I have a command that I can try which loads the LAMP.

Anything, I can try as I do not want to give up on suse?
 
Old 12-30-2012, 08:54 PM   #18
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,972

Rep: Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785
Quote:
The php info is in my index.html page
I'm not sure what you mean. Did you copy this code
Code:
<?php phpinfo(); ?>
into your index.html page?
I would not expect that to work. It should be copied to a file and saved with a .php extension, EX: info.php, test.php, or whatever. Put it in the same directory in which you have the index.html file. Maybe I'm not reading your post correctly?

Quote:
the php.ini is in the document root
I don't have Opensuse LAMP installed but the php.ini file is usually in the /etc directory.
So what doesn't work on Opensuse?
 
Old 12-31-2012, 12:28 PM   #19
bscho
Member
 
Registered: Nov 2012
Location: London
Distribution: Suse, Mint
Posts: 128

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
I'm not sure what you mean. Did you copy this code
Code:
<?php phpinfo(); ?>
into your index.html page?

yes with html code it ignores the code. I have also put in a file ending html shows nothing and with the php it will not display anything.

I would not expect that to work. It should be copied to a file and saved with a .php extension, EX: info.php, test.php, or whatever. Put it in the same directory in which you have the index.html file. Maybe I'm not reading your post correctly?

No you have it right it just will not do anything.


I don't have Opensuse LAMP installed but the php.ini file is usually in the /etc directory.
So what doesn't work on Opensuse?
php doesnt work, apache and mysql do work.

I think the best is to use mint where there is a lamp command.
 
Old 12-31-2012, 01:40 PM   #20
bscho
Member
 
Registered: Nov 2012
Location: London
Distribution: Suse, Mint
Posts: 128

Original Poster
Rep: Reputation: Disabled
install lampserver

Quote:
Originally Posted by bscho View Post
php doesnt work, apache and mysql do work.

I think the best is to use mint where there is a lamp command.

I have loaded mint 13 and I am dual booting with suse 12.2 and have tried both of your suggested commands with mint;

sudo service mysql start which says no such service and

sudo apt-get install lamp-server which says unable to locate package.

I was connected to the internet so I have no idea what is wrong.
 
Old 12-31-2012, 02:01 PM   #21
bscho
Member
 
Registered: Nov 2012
Location: London
Distribution: Suse, Mint
Posts: 128

Original Poster
Rep: Reputation: Disabled
Mysql server working

Quote:
Originally Posted by bscho View Post
I have loaded mint 13 and I am dual booting with suse 12.2 and have tried both of your suggested commands with mint;

sudo service mysql start which says no such service and

sudo apt-get install lamp-server which says unable to locate package.

I was connected to the internet so I have no idea what is wrong.
Update I have succeded in getting mysql to work in mint.

The command was sudo apt-get install mysql-server-5.5

Can you find out what the lamp-server is called that you used?
 
Old 12-31-2012, 02:31 PM   #22
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,972

Rep: Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785
The command to install it on Mint is: sudo apt-get install lamp-server^
You need the "^" at the end of the command or it won't work. On an American English keyboard, hold down the shift key and hit the numeral 6 key.

If you have apache and mysql running, I'm not sure what problems you might encounter if you now run this command, maybe none??
 
Old 12-31-2012, 03:11 PM   #23
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,972

Rep: Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785
Code:
<?php phpinfo(); ?>
Copy the code above into a text editor. Save it as info.php. Copy or move it to /var/www/ directory. Open firefox or whichever web browser you are using. Enter in the address box: http://localhost/info.php. You should get all the php output. If not, open a terminal and copy and paste the command below, hit the enter key. You should also get some output. If that doesn't work, php isn't install correctly or the php module for apache isn't installed. When you make changes, you need to restart apache also:

Code:
echo "<?php phpinfo(); ?>" | php > phpinfo.txt
Restart apache with: sudo service apache2 restart.

The link below has some good info on a lamp server setup. It is specific to Ubuntu but it should all be the same as Mint is based on Ubuntu.

http://ubuntuarena.wordpress.com/net...ntulinux-mint/
 
Old 01-01-2013, 12:09 PM   #24
bscho
Member
 
Registered: Nov 2012
Location: London
Distribution: Suse, Mint
Posts: 128

Original Poster
Rep: Reputation: Disabled
lamp-server

Quote:
Originally Posted by yancek View Post
The command to install it on Mint is: sudo apt-get install lamp-server^
You need the "^" at the end of the command or it won't work. On an American English keyboard, hold down the shift key and hit the numeral 6 key.

??
Thanks will try that ^ is upper case 6 on my notebook HP635. I guess this means any number
highest?

It has worked and loaded apache and localhost shows "It works"
I have used the info.php code and included in the index.html page.
I have now the info.php? It works!

I am really grateful and thank you for your help and forbearance
getting me there in the end.

Last edited by bscho; 01-01-2013 at 01:18 PM.
 
Old 01-01-2013, 02:46 PM   #25
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,972

Rep: Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785
Glad you got it working. Sometimes it is the smallest things (^) which cause the biggest problems.
 
Old 01-02-2013, 01:07 PM   #26
bscho
Member
 
Registered: Nov 2012
Location: London
Distribution: Suse, Mint
Posts: 128

Original Poster
Rep: Reputation: Disabled
Happy New Year

Quote:
Originally Posted by yancek View Post
Glad you got it working. Sometimes it is the smallest things (^) which cause the biggest problems.
Thanks for your help without it I would never have it working, have a happy new year.
 
Old 01-04-2013, 12:40 PM   #27
bscho
Member
 
Registered: Nov 2012
Location: London
Distribution: Suse, Mint
Posts: 128

Original Poster
Rep: Reputation: Disabled
Mysql works on Suse12.2 and Mint 13

Quote:
Originally Posted by bscho View Post
Thanks for your reply. I have loaded the php and apache several times it does not work.

The book says info.php should be loaded. I have downloaded it to DocumentRoot still no
joy. I feel I am doing something wrong somewhere.

I want to use mint as it looks better than Suse, only I might loose some data.

Again, I thank you for your help.
Thanks again for all your help. I now have full LAMP on both distros.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mysql not starting after changing mysql admin password in fedora prastal Linux - Newbie 1 02-20-2010 07:26 PM
Problem Starting MySQL on Fresh Fedora 8 Install w/ Yum'd MySQL blong4life Linux - Server 2 07-04-2008 07:44 PM
How to overcome the RPM "mysql-5.0.27-1.fc6" conflict with mysql database starting kamakshiganesh Linux - General 0 10-22-2007 07:07 AM
Starting MySQL OLD Error : imeout error occurred trying to start MySQL Daemon Fr33B5D Linux - Software 9 10-28-2006 06:23 AM
Starting up MySQL bwreath Linux - Software 2 01-20-2004 03:20 PM


All times are GMT -5. The time now is 09:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration