LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 05-09-2014, 03:01 PM   #1
joe_2000
Member
 
Registered: Jul 2012
Location: Aachen, Germany
Distribution: Crunchbang, Debian
Posts: 346

Rep: Reputation: 84
ssh: authenticity of host can't be established question opens x dialog


Today I wanted to setup an sshfs mount in the /etc/fstab of my wife's laptop running Mint 13. As usual, I did this through an ssh session so I don't have to interrupt her in what she is doing at the time.
So I entered the stuff in in the fstab and then typed
Code:
mount -a
A lot of error messages came up about no display being available. So I retyped the same command on her laptop and could not believe my eyes. The usual question "authenticity of host can't be established bla bla bla" came up... in a GUI dialog!!! I mean, seriously?!? I have always been a big fan of Linux Mint because it seemed to be the perfect distro to install on non-tech-savyy people's machines around me so I don't have to fix their windows installs. But this is a real turn-off!
I can't believe how anyone could possibly think it's a good idea to open a dialog box from within a terminal session, let alone for something related to ssh.

Ok, sorry for ranting, but I had to get this off of my chest...
 
Old 05-10-2014, 01:17 AM   #2
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,377

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
Are you sure it wasn't just complaining that you are not root when trying to mount? Or are you SSHing into your wife's laptop from itself?
I tend to agree though that popping up an x dialogue when you're using the terminal seems a very stupid thing to do.
 
Old 05-10-2014, 06:09 AM   #3
joe_2000
Member
 
Registered: Jul 2012
Location: Aachen, Germany
Distribution: Crunchbang, Debian
Posts: 346

Original Poster
Rep: Reputation: 84
Quote:
Originally Posted by 273 View Post
Are you sure it wasn't just complaining that you are not root when trying to mount? Or are you SSHing into your wife's laptop from itself?
No I was SSHing into my wife's laptop from my laptop. The reason why I am 100% sure that I was root is that I had edited fstab before in that same terminal session.

But anyway, whatever it complained about, it should have complained in the terminal... I guess this behavior can probably be fixed somewhere, but I don't think I'll bother. I don't actually *need* to be able to do stuff on her laptop via ssh, it's just more convenient for both of us...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How can I disable the authenticity check when ssh'ing to a server for the first time? abefroman Linux - Server 2 10-04-2013 04:16 PM
host opens usb audio endpoint w/o explicitly setting sampling rate rebar Linux - General 3 04-30-2013 12:17 PM
Is there a way to prevent this message:The authenticity of host can't be established. abefroman Linux - Server 8 11-27-2009 02:52 PM
ssh: connect to host .....No route to host soumyacs Linux - Newbie 5 10-27-2009 10:03 AM
How to setup a host.deny and host.allow for SSH? explorer1979 Linux - Security 2 01-31-2005 05:28 PM


All times are GMT -5. The time now is 03:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration