LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 03-23-2013, 09:15 AM   #1
rabirk
Member
 
Registered: Dec 2012
Location: Maryland, US
Distribution: Debian
Posts: 87
Blog Entries: 5

Rep: Reputation: Disabled
Problem with wi-fi


I recently bought a new wireless router, and my Linux Mint (and Slackware; dual booting) seem to have problems connecting to it. Linux Mint had no problems whatsoever with my old router, but now it recognizes the AP and tells me I'm connected to it, and when I log into the router from another computer I see my Linux Mint computer, but the wireless isn't actually working on the computer. Sometimes it works in fits and starts but is very slow. I am now using ethernet and the computer is having no problems.

I've pinged the loopback address with no issues, but pinging the default gateway address, 192.168.1.1, times out with 100% packet loss.

Here are the results from iwconfig:

wlan0 IEEE 802.11bgn ESSID:"Hammurabi"
Mode:Managed Frequency:2.437 GHz Access Point: 60:A4:4C:6A:1B:98
Bit Rate=52 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thrff Fragment thrff
Power Managementn
Link Quality=70/70 Signal level=-16 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:38 Missed beacon:0

Any help would be greatly appreciated.
 
Old 03-23-2013, 09:38 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,854

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Post the output of 'ifconfig' and the command 'netstat -r' ( all commands without quotes ).
 
Old 03-23-2013, 10:07 AM   #3
rabirk
Member
 
Registered: Dec 2012
Location: Maryland, US
Distribution: Debian
Posts: 87
Blog Entries: 5

Original Poster
Rep: Reputation: Disabled
Here is my ifconfig:

eth0 Link encap:Ethernet HWaddr 00:90:f5:cc:c3:10
inet addr:192.168.1.113 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::290:f5ff:fecc:c310/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:19951 errors:0 dropped:0 overruns:0 frame:0
TX packets:11787 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:26161746 (26.1 MB) TX bytes:840195 (840.1 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:212 errors:0 dropped:0 overruns:0 frame:0
TX packets:212 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:29231 (29.2 KB) TX bytes:29231 (29.2 KB)

wlan0 Link encap:Ethernet HWaddr 58:91:cf:00:5e:f1
inet addr:192.168.1.225 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::5a91:cfff:fe00:5ef1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:172 errors:0 dropped:0 overruns:0 frame:0
TX packets:113 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:26143 (26.1 KB) TX bytes:20759 (20.7 KB)


Here is netstat -r:

Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
default www.asusnetwork 0.0.0.0 UG 0 0 0 eth0
link-local * 255.255.0.0 U 0 0 0 wlan0
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 0 0 0 wlan0


Do I need to manually configure the default gateway?
 
Old 03-23-2013, 10:14 AM   #4
ukiuki
Senior Member
 
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,029

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Please use the BBcodes to post that kind of outputs, thank you.

Regards
 
Old 03-23-2013, 10:18 AM   #5
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,854

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Quote:
Do I need to manually configure the default gateway?
Yes, it should point at your router.

192.168.1.1 ? I would guess.
 
1 members found this post helpful.
Old 03-23-2013, 12:02 PM   #6
rabirk
Member
 
Registered: Dec 2012
Location: Maryland, US
Distribution: Debian
Posts: 87
Blog Entries: 5

Original Poster
Rep: Reputation: Disabled
OK, I Googled how to configure the default gateway and edited /etc/network/interfaces, and it seems I'm up and running. Thanks for helping figure out which commands would help me figure this out. I wouldn't have thought of netstat.

I wish I could figure out why the DHCP isn't working. My Mac and iPad connect wirelessly without any difficulty. Any thoughts on that? I think the static configuration will eventually become problematic.
 
Old 03-23-2013, 03:55 PM   #7
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,854

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Have you got free IP addresses? You may need to look into your routers config to see.

There is no reason why a static IP config would become problematic.
 
Old 03-23-2013, 04:48 PM   #8
rabirk
Member
 
Registered: Dec 2012
Location: Maryland, US
Distribution: Debian
Posts: 87
Blog Entries: 5

Original Poster
Rep: Reputation: Disabled
Yes, I have free IP addresses. I was just thinking, since this is a laptop, I'd rather use DHCP for when I take the laptop out of the house.

Unfortunately, the above solution didn't survive a reboot and my wireless is again not functioning, though the information I put in /etc/network/interfaces is still there. I'll have to look into that, too, but thanks for your assistance.
 
Old 03-23-2013, 07:52 PM   #9
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,854

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Does the system have either Network Manager or WICD installed? If yes, you need to do the configuration through that for it to work reliably.

The other option is to uninstall NM or WICD and edit the files. NM and WICD will overwrite the config files.

I use WICD on my netbook. At home I use a fixed IP address. With WICD it only takes a few seconds to configure another access point. Most of the ones I use out of the house are open points, ie, no encryption. It works fine in airports, coffee shops etc.
 
Old 03-23-2013, 08:49 PM   #10
rabirk
Member
 
Registered: Dec 2012
Location: Maryland, US
Distribution: Debian
Posts: 87
Blog Entries: 5

Original Poster
Rep: Reputation: Disabled
I've been using Mint's network GUI to try to get a proper connection, but with little luck. I really can't figure out why it isn't connecting properly. Clicking on the networking icon in the taskbar, I see "unmanaged" next to Wireless. It was like that before I plugged in ethernet, as well. Editing /etc/network/interfaces was the only way I could think of to configure the default gateway. I'll keep messing around with it, but I wish I had a smart way to go about it.
 
Old 03-24-2013, 12:27 AM   #11
awc
LQ Newbie
 
Registered: Aug 2012
Location: North America
Distribution: Mint
Posts: 5

Rep: Reputation: 0
I had the same problem when I upgraded to a D-Link Xtreme Duo WAP. My Mint box would connect to the network but couldn't send packets to anything. All the other computers in my network worked fine so I assumed the problem was the box's hardware. I replaced the wireless NIC with a $20 USB wireless adapter and problem solved.

The problem could be your hardware isn't jiving with the new router, or maybe a driver issue. Try a live disc and see if that works otherwise think about upgrading your NIC.
 
Old 03-24-2013, 10:42 AM   #12
rabirk
Member
 
Registered: Dec 2012
Location: Maryland, US
Distribution: Debian
Posts: 87
Blog Entries: 5

Original Poster
Rep: Reputation: Disabled
Thanks for the suggestion, awc, but I was finally able to reset NetworkManager in Slackware, and I'm running wireless on the laptop now. It's only the network managers in Mint that are giving me a problem at this point. I might just re-install Mint and see if that fixes it, but I like to avoid that step if I can.
 
  


Reply

Tags
networking, wi-fi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Do I have a path problem, an Apache2 problem or a Javascript problem or any other pro rblampain Linux - Networking 0 12-29-2010 04:50 AM
Slackware 12.0: boot problem & sudo / wifi-radar problem War_Ensemble Slackware 7 01-15-2008 10:49 AM
Sound Card problem(every time i install linux i have diffirent hardware problem) jacka1l Linux - Newbie 7 08-11-2005 07:10 AM
Lan configuration problem - NFS boot problem - RX&TX packets errors 242VDM242 Linux - Networking 4 11-25-2004 02:35 PM
perl problem? apache problem? cgi problem? WorldBuilder Linux - Software 1 09-17-2003 08:45 PM


All times are GMT -5. The time now is 01:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration