LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 10-11-2012, 01:38 AM   #1
Vocay2
LQ Newbie
 
Registered: Jul 2012
Location: Beer Sheva, Israel
Distribution: Ubuntu 13.10
Posts: 24

Rep: Reputation: Disabled
Problem editing grub.cfg


I I am moving to Linux Mint from Ubuntu. (Probably just one of thousands).
I want to edit the grub.cfg file. You know, the one that says, "do not edit this file".
With Ubuntu, I simply opened a terminal, typed in
Code:
gksudo nautilus
, navigated to the grub.cfg file and edited it.
But now, with Linux Mint, I type in gksudo nautilus, and a window opens with the desktop folder in it. I select file system, and boot folder, then select the grub folder. I open grub.cfg and edit the sections I want but cannot save it. I get the following outputs in the terminal:

Quote:
$ gksudo nautilus

(pluma:2316): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.4P19LW': No such file or directory

(pluma:2316): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(pluma:2316): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.I4KULW': No such file or directory

(pluma:2316): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(pluma:2316): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.OMBZLW': No such file or directory

(pluma:2316): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(nautilus:2289): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.6QLWLW': No such file or directory

(nautilus:2289): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory
I could use a little help here.
Thanks
 
Old 10-11-2012, 02:43 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
This is just GTK noise. Don't do this. Learn to edit files properly in a console. stop using noddy junk like nautilus through hacks.

sudo vi /boot/grub/grub.conf

etc.
 
Old 10-11-2012, 04:33 AM   #3
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,220

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
"Do not edit this file" means that your changes will be lost after some update. This file is created automatically from files in /etc/grub.d and these files should be modified or configuration file /etc/default/grub.
 
Old 10-11-2012, 04:57 AM   #4
m.a.l.'s pa
Member
 
Registered: Oct 2007
Location: albuquerque
Posts: 198

Rep: Reputation: 34
Quote:
Originally Posted by eSelix View Post
"Do not edit this file" means that your changes will be lost after some update. This file is created automatically from files in /etc/grub.d and these files should be modified or configuration file /etc/default/grub.
+1

As for the error messages, try doing a web search using "Failed to create file '/root/.local/share/recently-used.xbel"; it seems that you can create the file /root/.local/share/recently-used.xbel to get rid of those error messages:

Code:
su
mkdir -p /root/.local/share/
touch /root/.local/share/recently-used.xbel
In your case (in Linux Mint), try sudo followed by those commands.
 
Old 10-11-2012, 06:26 AM   #5
Vocay2
LQ Newbie
 
Registered: Jul 2012
Location: Beer Sheva, Israel
Distribution: Ubuntu 13.10
Posts: 24

Original Poster
Rep: Reputation: Disabled
I appreciate the advice. Thank you very much. I'll post back when I get some results.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
permission for grub.cfg jone kim Linux - General 1 09-15-2010 01:53 PM
[SOLVED] Grub can't find grub.cfg when booting - error: no such device Breagha Linux - Software 8 03-14-2010 12:40 PM
Big leap... Booting Problem editing GNU GRUB 1.97 gburdine Linux - Newbie 3 11-24-2009 05:15 PM
Problem editing /boot/grub/menu.lst baldur2630 Linux - Server 10 10-03-2008 12:12 PM
grub editing problem in suse 11.0 mobinskariya Suse/Novell 1 09-17-2008 05:01 PM


All times are GMT -5. The time now is 08:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration