LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 03-26-2009, 03:30 PM   #1
salmanal
Member
 
Registered: Jan 2005
Location: Western USA
Distribution: Linux Mint
Posts: 213

Rep: Reputation: 30
Question Possible Screen Resolution Change?


I run Mint Linux 5 on a DELL Optiplex GX400, P4, 1.7,
512 MB RAM, and a nVidia 32 video card. I only have one
choice for video, 800 x 600. I prefer a higher screen
resolution, but can't seem to change this.

I ran: sudo dpkg-reconfigure xserver-xorg
and was still unable to change the screen resolution.
Are there any other options to set?

Thanks for the assistance,

-s
 
Old 03-26-2009, 04:19 PM   #2
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Debian, OS X
Posts: 1,266

Rep: Reputation: 99
Quote:
Originally Posted by salmanal View Post
I run Mint Linux 5 on a DELL Optiplex GX400, P4, 1.7,
512 MB RAM, and a nVidia 32 video card. I only have one
choice for video, 800 x 600. I prefer a higher screen
resolution, but can't seem to change this.

I ran: sudo dpkg-reconfigure xserver-xorg
and was still unable to change the screen resolution.
Are there any other options to set?

Thanks for the assistance,

-s
Try, running system-config-display

you will need to logout and then login, to apply the changes.
 
Old 03-26-2009, 04:23 PM   #3
Earl Parker II
Member
 
Registered: Jan 2002
Location: Shelby, NC, US
Distribution: Slackware 12.2
Posts: 127

Rep: Reputation: 17
Nvidia has excellent Linux support for most of it's graphics cards. I'd try the following:

1. Open a console window and enter 'lspci'. Find the line that details your graphics card specs and make a note of exacly what card you have, i.e., GeForce MX400 32mb or something like that.

2. Go to http://www.nvidia.com/Download/index.aspx?lang=en-us. Make your choices and hit 'Search'. Download the driver- /opt is a good place to put it.

3. Close your desktop and get back to the console. Make sure you 'su' to root then change to the /opt directory. Use 'ls' to make sure the nVidia driver is present, then enter 'sh <name of driver>'. This will start the install process. Just choose 'Accept' or 'OK' to everything that comes up and it should install the driver. After the driver is installed you'll have the option of having your xorg.conf file rewritten- be sure to do this.

4. Crank up your desktop- you should see a quick 'splash screen' with the nVidia logo on it. You desktop should now have the optimum resolution for your video card.

If you don't like what you see, there are a ton of nVidia cards on eBay with a lot more memory that 32mb that are available for a very reasonable amount of money. Before you purchase one, visit the nVidia site and make sure a driver is available for the card. You'll probably be much happier with the performance of your machine- my guess is that your current graphics card is pretty much a bottleneck.

Last edited by Earl Parker II; 03-26-2009 at 04:25 PM.
 
Old 03-27-2009, 05:32 AM   #4
merlwiz79
Linux Mint
 
Registered: Mar 2009
Posts: 5

Rep: Reputation: 0
you could install the driver with
Code:
envyng -t
.
 
Old 03-27-2009, 03:13 PM   #5
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 518

Rep: Reputation: 133Reputation: 133
Nvidia drivers can be a pain in both Linux and Windows.

This is what I have to do to get a resolution higher than 800x600:
Code:
gksu gedit /etc/X11/xorg.conf
Find the "Monitor" section and add something like
Code:
HorizSync 30-80
VertRefresh 50-75
Those numbers are for my monitor, you can find the correct numbers in your monitor's user manual.

Next under the "Screen" section, I have to add:
Code:
SubSection "Display"
  Depth 24
  Modes "1280x1024" # Change 1280x1024 to the resolution you need
EndSubSection

Last edited by piratesmack; 03-27-2009 at 03:15 PM.
 
Old 03-27-2009, 04:14 PM   #6
salmanal
Member
 
Registered: Jan 2005
Location: Western USA
Distribution: Linux Mint
Posts: 213

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by piratesmack View Post
Nvidia drivers can be a pain in both Linux and Windows.

This is what I have to do to get a resolution higher than 800x600:
Code:
gksu gedit /etc/X11/xorg.conf
Find the "Monitor" section and add something like
Code:
HorizSync 30-80
VertRefresh 50-75
Those numbers are for my monitor, you can find the correct numbers in your monitor's user manual.

Next under the "Screen" section, I have to add:
Code:
SubSection "Display"
  Depth 24
  Modes "1280x1024" # Change 1280x1024 to the resolution you need
EndSubSection
This is the result when I run gksu gedit /etc/X11/xorg.conf

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"

So, the lines I'll add "HorizSync 30-80
VertRefresh 50-75" do not need the quotes? And are they written directly below
configured monitor? I do not have a display line in the subsection,
only screen - Identifier, Monitor, and Device. Do I write the desired resolution next to monitor or Device? With or without quotes.
I feel this is closer to what I had before. Thanks :-)

Last edited by salmanal; 03-27-2009 at 04:16 PM.
 
Old 03-27-2009, 06:13 PM   #7
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 518

Rep: Reputation: 133Reputation: 133
Do not use 30-80 and 50-75, those are the numbers for my monitor.
Check in your monitor's user manual for the correct numbers. You might also be able to google your monitors specs for the right numbers. If you can't find the numbers, you may be able to skip that step.

But after you make the changes, it should look something like:

Code:
Section "Monitor"
	Identifier	"Configured Monitor"
        HorizSync 30-80
        VertRefresh 50-75
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
SubSection "Display"
        Depth 24
        Modes "1280x1024"
EndSubSection
EndSection

Last edited by piratesmack; 03-27-2009 at 06:16 PM.
 
Old 03-27-2009, 06:34 PM   #8
salmanal
Member
 
Registered: Jan 2005
Location: Western USA
Distribution: Linux Mint
Posts: 213

Original Poster
Rep: Reputation: 30
Got it!

I'll try this in the AM, and thanks so much for your help.
 
Old 03-31-2009, 02:09 PM   #9
salmanal
Member
 
Registered: Jan 2005
Location: Western USA
Distribution: Linux Mint
Posts: 213

Original Poster
Rep: Reputation: 30
Cool Sorry I took so Long, but It is working now

All I had to do was edit the gksu gedit /etc/X11/xorg.conf file
with my monitor settings as was mentioned earlier.

All is so Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't change screen resolution andmer Suse/Novell 11 11-21-2007 09:06 PM
change screen resolution of xdm login screen in suse linux pseudoxiah Linux - Desktop 2 04-02-2007 09:26 AM
How can I change my screen resolution? Thaidog Linux - Newbie 1 12-24-2006 10:43 PM
Change screen resolution? Brian Knoblauch Solaris / OpenSolaris 2 11-18-2005 02:08 PM
How to change screen resolution linuxmojo Linux - Software 2 04-07-2002 11:18 PM


All times are GMT -5. The time now is 11:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration