LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices



Reply
 
Search this Thread
Old 08-31-2010, 07:25 PM   #1
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 55
No sound as Root, but sound as standard user


How come the sound system in Linux Mint runs just fine as an average user but doesn't respond as Root? I had the same problem with Ubuntu when I used sudo passwd to enable the root account (and this is on an Acer Aspire One AOA110-1545).

Attached is an example of what happens when I run "Sound Preferences" as root:

WaitingForSoundSystemToRespond.jpg
 
Old 08-31-2010, 10:27 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
You aren't supposed to be running as the root user, and in modern desktop-oriented distributions the system may behave in unexpected ways if you try.
 
Old 08-31-2010, 10:37 PM   #3
SkyEye
Member
 
Registered: Sep 2005
Location: Sri Lanka
Distribution: Fedora (workstations), CentOS (servers), Arch, Mint, Ubuntu, and a few more.
Posts: 441

Rep: Reputation: 40
I'm not sure exactly why this is happening, but this might have something to do with both Ubuntu and Mint coming with root account disabled by default. Anyway, it's always a bad idea to do your daily work in root.

The rule of thumb goes as "Never ever log in a root unless you really have to and you can't get su/sudo to do it". Sorry for not being more helpful.
 
Old 08-31-2010, 11:25 PM   #4
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 55
Ubuntu has the root account disabled by default. Mint doesn't. Why? Because I didn't have to run sudo passwd on it. Regardless, it still does this.
 
  


Reply

Tags
root login


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound as normal user but there's sound as root on suse Sleen Linux - Hardware 4 08-27-2006 06:27 AM
root sound ok - user sound not..? captain skywave Suse/Novell 12 06-23-2005 06:24 PM
user sound is fine, Root sound just squeals Doug.Gentry Linux - Newbie 1 09-05-2004 04:27 PM
sound works in root - no sound in user - Debian seanb Debian 9 02-28-2004 01:42 AM
No sound for non-root user rdaves@earthlink.net Linux - General 1 07-14-2001 07:19 AM


All times are GMT -5. The time now is 06:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration