LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 03-25-2013, 05:10 AM   #1
james2b
Member
 
Registered: Feb 2007
Location: Washington state, USA
Distribution: Fedora 13, SUSE 11, Ubuntu 10.04, Mandriva 2010, Mint 8
Posts: 336

Rep: Reputation: 34
Cool Mint 14 64 bit new install does not drop down cooling fan rpm speed


I have a Mint 14 64 bit new install which does not drop down the cooling fan rpm speed as it should when fully loaded into the desktop. Also it is all updated, and this is a store built 2009 Intel Core 2 duo with Asus P5QL Pro motherboard desktop system. There is no hardware driver tool like in Ubuntu to search for available drivers such as the motherboard chip set drivers. So is there some command to run in terminal, or a utility tool to install that will allow that fan speed control ? Thanks.
 
Old 03-25-2013, 10:28 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
Fan speeds on this motherboards usually are controlled by the BIOS, not the OS, so I would check there first if the fan control options are enabled.
 
Old 03-26-2013, 06:45 PM   #3
james2b
Member
 
Registered: Feb 2007
Location: Washington state, USA
Distribution: Fedora 13, SUSE 11, Ubuntu 10.04, Mandriva 2010, Mint 8
Posts: 336

Original Poster
Rep: Reputation: 34
Smile

I have 3 Windows and several other Linux installs on 2 hard drives, and those others do kick down the sound of the fans which that computer has front and rear cooling fans, CPU, and video card fans too. So just the initial fan speeds are set in the BIOS I think, then the operating system takes over fan RPM control, right ?
 
Old 03-26-2013, 08:52 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
Usually the BIOS controls the CPU and chassis fans (if they are connected to the motherboard), while the fan of the videocard is controlled by the video driver.
Which videocard(s) do you have and do you have the proprietary driver installed (if available)?
 
Old 03-28-2013, 08:50 PM   #5
james2b
Member
 
Registered: Feb 2007
Location: Washington state, USA
Distribution: Fedora 13, SUSE 11, Ubuntu 10.04, Mandriva 2010, Mint 8
Posts: 336

Original Poster
Rep: Reputation: 34
Smile

That computer has a 2009 NVIDIA GeForce GT 9600 and now have only the built in free neavou display driver in use.
 
Old 03-31-2013, 04:56 AM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
The free nouveau driver still has no proper support for setting the right clockspeeds (and therefore fanspeed), I would try to install the Nvidia driver, this should solve your problem.
 
Old 04-01-2013, 03:01 AM   #7
james2b
Member
 
Registered: Feb 2007
Location: Washington state, USA
Distribution: Fedora 13, SUSE 11, Ubuntu 10.04, Mandriva 2010, Mint 8
Posts: 336

Original Poster
Rep: Reputation: 34
Thumbs up

Okay I did install that current nvidia display driver with the package manager, then ran this; nvidia-xconfig which the installed nvidia settings tool said to do, then after a re-start this issue is now fixed, as the fans noise now does drop down to a nice quiet sound. Thanks for the help. Why would a graphics driver install control all the desktop computer fans, unless it was just only the video card cooling fan which was running at a high rpm ?
 
Old 04-01-2013, 05:23 AM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
The graphics driver controls only the fan of the videocard (in most cases not even directly, but with setting power-profiles for the videochip, which is in the current state not working correctly for the nouveau and radeon drivers), so most likely it was only the fan for the videocard that was producing the noise.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fan speed problem on my laptop with mint nypd365 Linux Mint 1 04-06-2011 08:13 AM
server cooling fan syphoncode.32 Linux - Hardware 4 05-25-2007 11:11 PM
howto: control CPU fan speed and Northbridge fan speed? hedpe Linux - Software 2 04-18-2005 02:18 AM
Cooling fan is not working. nmrman VectorLinux 1 10-01-2004 10:57 PM


All times are GMT -5. The time now is 08:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration