LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux Mint (http://www.linuxquestions.org/questions/linux-mint-84/)
-   -   Mint 14 64 bit new install does not drop down cooling fan rpm speed (http://www.linuxquestions.org/questions/linux-mint-84/mint-14-64-bit-new-install-does-not-drop-down-cooling-fan-rpm-speed-4175455478/)

james2b 03-25-2013 05:10 AM

Mint 14 64 bit new install does not drop down cooling fan rpm speed
 
I have a Mint 14 64 bit new install which does not drop down the cooling fan rpm speed as it should when fully loaded into the desktop. Also it is all updated, and this is a store built 2009 Intel Core 2 duo with Asus P5QL Pro motherboard desktop system. There is no hardware driver tool like in Ubuntu to search for available drivers such as the motherboard chip set drivers. So is there some command to run in terminal, or a utility tool to install that will allow that fan speed control ? Thanks.

TobiSGD 03-25-2013 10:28 AM

Fan speeds on this motherboards usually are controlled by the BIOS, not the OS, so I would check there first if the fan control options are enabled.

james2b 03-26-2013 06:45 PM

I have 3 Windows and several other Linux installs on 2 hard drives, and those others do kick down the sound of the fans which that computer has front and rear cooling fans, CPU, and video card fans too. So just the initial fan speeds are set in the BIOS I think, then the operating system takes over fan RPM control, right ?

TobiSGD 03-26-2013 08:52 PM

Usually the BIOS controls the CPU and chassis fans (if they are connected to the motherboard), while the fan of the videocard is controlled by the video driver.
Which videocard(s) do you have and do you have the proprietary driver installed (if available)?

james2b 03-28-2013 08:50 PM

That computer has a 2009 NVIDIA GeForce GT 9600 and now have only the built in free neavou display driver in use.

TobiSGD 03-31-2013 04:56 AM

The free nouveau driver still has no proper support for setting the right clockspeeds (and therefore fanspeed), I would try to install the Nvidia driver, this should solve your problem.

james2b 04-01-2013 03:01 AM

Okay I did install that current nvidia display driver with the package manager, then ran this; nvidia-xconfig which the installed nvidia settings tool said to do, then after a re-start this issue is now fixed, as the fans noise now does drop down to a nice quiet sound. Thanks for the help. Why would a graphics driver install control all the desktop computer fans, unless it was just only the video card cooling fan which was running at a high rpm ?

TobiSGD 04-01-2013 05:23 AM

The graphics driver controls only the fan of the videocard (in most cases not even directly, but with setting power-profiles for the videochip, which is in the current state not working correctly for the nouveau and radeon drivers), so most likely it was only the fan for the videocard that was producing the noise.


All times are GMT -5. The time now is 03:24 AM.