LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 07-02-2012, 10:33 PM   #1
kaylajean18
LQ Newbie
 
Registered: Jul 2012
Posts: 3

Rep: Reputation: Disabled
Question I have linux mint 13 need help with get oracle virtualbox - VM Windows xp online


I recently changed my operating system on my laptop to Linux Mint 13(Maya Cinnamon). In order to install certain programs and games, I installed VirtualBox. The problem is that no matter what I do, I can't seem to connect to my home network to get the VirtualBox operating system to go online. Using Oracle VM VirtualBox Manager, I have changed the Adapter to be attached to NAT, with Adapter Type Intel PRO/1000 T Server (82543GC) with cable connected not checked. When I boot the VM (Windows XP), I go to Start>Control Panel>Network Connections, LAN or High-Speed Internet says 'enabled Intel Pro/1000 Server...When I try to open my IE browser, it says, 'No connection to the inernet is currently available...In the same folder, Under 'Incoming', it says Incoming Connections- No clients connected. What should I try now?
 
Old 07-03-2012, 01:52 AM   #2
Slackyman
Member
 
Registered: Mar 2011
Location: Rome - Italy
Distribution: Slackware 13.1
Posts: 347

Rep: Reputation: 44
Select "bridged" intrface and configure the ip address of the guest just if it was another computer fisically connected to the same network. So, if the host has 10.10.10.2 as its IP Address, the guest will have something like 10.10.10.3.
 
Old 07-03-2012, 05:29 AM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,364
Blog Entries: 2

Rep: Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981
Quote:
Originally Posted by kaylajean18 View Post
with cable connected not checked.
Why do you expect the network connection to work if you don't connect the virtual cable to the virtual machine?
 
Old 07-03-2012, 08:45 PM   #4
kaylajean18
LQ Newbie
 
Registered: Jul 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
Why do you expect the network connection to work if you don't connect the virtual cable to the virtual machine?
I did what said and it didn't work.
 
Old 07-03-2012, 08:54 PM   #5
kaylajean18
LQ Newbie
 
Registered: Jul 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Question

Quote:
Originally Posted by Slackyman View Post
Select "bridged" intrface and configure the ip address of the guest just if it was another computer fisically connected to the same network. So, if the host has 10.10.10.2 as its IP Address, the guest will have something like 10.10.10.3.
How do I configure the ip I've never done that before. Can you tell me step by step. Thank you for your help.
 
Old 07-09-2012, 06:31 PM   #6
Thane
Member
 
Registered: Aug 2006
Location: Ontario,Canada
Distribution: Linux Mint16 Cinnamon 64bit
Posts: 178

Rep: Reputation: Disabled
Similar to my case

I recently switched to mint13 cinnamon and initially had no net connection (although I did have a working connection before on mint12.) I solved the problem in my personal case, by staying with NAT and after clicking on "advanced" in network settings, switching the adapter to the "PCnet-FAST III (AM 79C973) option. That's all, that I had to do, to get my system up and running again. Possibly this might work on your machine. cheers
 
Old 07-09-2012, 06:42 PM   #7
Thane
Member
 
Registered: Aug 2006
Location: Ontario,Canada
Distribution: Linux Mint16 Cinnamon 64bit
Posts: 178

Rep: Reputation: Disabled
One other thought...

Another thought came to me. I also installed the "users and groups" program from the gnome repositories via synaptic, to gain access to the users and groups gui, which I used to use in ubuntu to include vbox users into the users' and groups' lists, so that the users could have vbox access. I then created the actual vbox users and included them in the "vboxusers" group, which was necessary. This can also be done via the Terminal if you choose, but the gui is easy. Use a search engine to find how to include the "users and groups" program in a mint installation.
 
Old 07-15-2012, 04:00 PM   #8
ronin701
LQ Newbie
 
Registered: Aug 2002
Location: Austin, TX
Distribution: Mint, Debian, Redhat, Libranet, Smoothwall, SME Server.
Posts: 13

Rep: Reputation: 0
Check this.....

I have XP running on V-Box on Mint 13.
This only works if you have just one virtual machine in your V-Box, if you have more than one VM your going to have to set static address's for the various machines.
But if you have just the one VM;
Open your settings tab for the VM, for adapter 1 (only enable one adapter), check the enable network adapter box, attached to NAT, click the advanced tab, adapter type choose PCnet-PCI II (AM79C970A), don't worry about the mac address as long as it's filled in, click cable connected.
Boot your XP machine, go to start, control panel network connections, should show the network connection described as AMD PCNET Family Ethernet Adapter, right click on the adapter, choose properties, scroll down to Internet Protocol TCP/IP, make sure the box is checked, highlight it and click on properties, in the properties panel select, obtain an IP address automatically and obtain DNS server address automatically, click OK, click OK, close the network connections window, that should fix your problem, let me know if it solves it.
 
Old 07-16-2012, 02:55 PM   #9
Sigshane
LQ Newbie
 
Registered: Oct 2008
Location: Augusta GA
Distribution: LMDE
Posts: 15

Rep: Reputation: 1
I would really appreciate if the OP could report his/her findings, and if successful, some feedback and/or lessons learned!

Thanks!

Shane
 
Old 07-16-2012, 03:48 PM   #10
Thane
Member
 
Registered: Aug 2006
Location: Ontario,Canada
Distribution: Linux Mint16 Cinnamon 64bit
Posts: 178

Rep: Reputation: Disabled
more than one...

Actually I do have more than one vm. I have five and I regularly run two at once plus my mint 13 host.
 
Old 07-16-2012, 03:56 PM   #11
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64&i386, Raspbian Jessie, various VMs
Posts: 3,171

Rep: Reputation: 735Reputation: 735Reputation: 735Reputation: 735Reputation: 735Reputation: 735Reputation: 735
Quote:
Originally Posted by ronin701 View Post
I have XP running on V-Box on Mint 13.
This only works if you have just one virtual machine in your V-Box, if you have more than one VM your going to have to set static address's for the various machines.
This should not be the case. I suspect that either your home router/DHCP server is having problems or you're doing something wrong in your VirtualBox config. If not you ought to report this as a fault with Mint. I've have a few VMs working separately and simultaneously for a few years and never had problems with IP addresses.
 
Old 07-16-2012, 04:02 PM   #12
ronin701
LQ Newbie
 
Registered: Aug 2002
Location: Austin, TX
Distribution: Mint, Debian, Redhat, Libranet, Smoothwall, SME Server.
Posts: 13

Rep: Reputation: 0
Whatever

When I installed the various VM's V-Box gave each new VM the default NAT address (you are using NAT in your V-Box settings right?) of 10.0.2.15, which of course would cause network conflicts so I just set my IP's manually.....
 
Old 07-16-2012, 04:23 PM   #13
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64&i386, Raspbian Jessie, various VMs
Posts: 3,171

Rep: Reputation: 735Reputation: 735Reputation: 735Reputation: 735Reputation: 735Reputation: 735Reputation: 735
Quote:
Originally Posted by ronin701 View Post
When I installed the various VM's V-Box gave each new VM the default NAT address (you are using NAT in your V-Box settings right?) of 10.0.2.15, which of course would cause network conflicts so I just set my IP's manually.....
My apologies, yes, if you're running NAT then it's VirtualBox not your home router that's at fault.
I have just fired up Ubuntu, CentOS, Windows XP and Windows ion VMs all using NAT and all can connect to the internet.
So, if you can only connect to the internet with one client either your configuration is wrong or your copy of VirtualBox has a bug.
 
Old 07-16-2012, 04:32 PM   #14
ronin701
LQ Newbie
 
Registered: Aug 2002
Location: Austin, TX
Distribution: Mint, Debian, Redhat, Libranet, Smoothwall, SME Server.
Posts: 13

Rep: Reputation: 0
Most likley a bug

I think it's probably a bug in the Mint repository vs. of V-Box (4.1.12) or possibly an issue with a 64 bit OS, I RTFM <G> and V-Box is supposed to assign IP's in +2 increments but this vs on Mint 13 x64 Mate keeps assigning the same IP, no big deal setting static IP's is a trivial act.
 
Old 11-21-2012, 04:16 PM   #15
Nico1
LQ Newbie
 
Registered: Nov 2012
Location: Spain
Distribution: Mint, Ubuntu, Debian
Posts: 1

Rep: Reputation: Disabled
I would also love to know the OP findings on the subject!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to run Linux Mint Debian Cinnamon in VirtualBox LXer Syndicated Linux News 1 04-26-2012 07:17 PM
VirtualBox on Oracle Linux 5.6 AsInBen Linux - Newbie 2 09-14-2011 01:28 PM
DVD writers will not mount in Linux Mint 9 running as VM guest in VirtualBox Stuart Stein Linux - Virtualization and Cloud 0 09-06-2010 09:41 AM
dont know how to install virtualbox on linux mint 8? BirdyMan Linux - Virtualization and Cloud 4 01-22-2010 01:51 PM
using usb on virtualbox (through Linux Mint) lewnon Linux - Newbie 1 03-17-2009 05:06 PM


All times are GMT -5. The time now is 09:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration