LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux Mint (http://www.linuxquestions.org/questions/linux-mint-84/)
-   -   How to install Intel HD graphics + GMA (i915) (http://www.linuxquestions.org/questions/linux-mint-84/how-to-install-intel-hd-graphics-gma-i915-879535/)

steward 05-08-2011 07:13 PM

How to install Intel HD graphics + GMA (i915)
 
Hello guys

I have installed Linux Mint on Vaio VPCEA12EG and everything is fine but the GMA is not installed and its really slow and annoying my eyes. Would you please guide me to install the gma.Below is the output for lspci

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Thanks in advance.

adamk75 05-09-2011 07:03 PM

Nearly all distributions included the intel driver by default. Please show us your /var/log/Xorg.0.log file.

Adam

cascade9 05-09-2011 07:35 PM

Intel 'core' series video is still pretty new, and with ubuntu (which mint is based on) there was a few problems with that model video.

You might try adding the xorg-edgers PPA to get the newest version of the drivers. Add this to your software sources-

ppa:xorg-edgers/ppa

Then update, that should get you the newer intel drivers.

steward 05-15-2011 09:38 PM

Quote:

Originally Posted by cascade9 (Post 4351524)
Intel 'core' series video is still pretty new, and with ubuntu (which mint is based on) there was a few problems with that model video.

You might try adding the xorg-edgers PPA to get the newest version of the drivers. Add this to your software sources-

ppa:xorg-edgers/ppa

Then update, that should get you the newer intel drivers.

Thanks for your reply..As u said I added to the repository and then updated but after resetting my laptop,nothing changed, and the screen still is not smooth.Can you help more please. I m new in Linux.

Thanks in advance.

steward 05-15-2011 09:40 PM

Quote:

Originally Posted by adamk75 (Post 4351508)
Nearly all distributions included the intel driver by default. Please show us your /var/log/Xorg.0.log file.

Adam

Here is the log...Would u please guide me what to do...

Quote:

[ 20.349]
X.Org X Server 1.9.2.901 (1.9.3 RC 1)
Release Date: 2010-11-13
[ 20.349] X Protocol Version 11, Revision 0
[ 20.349] Build Operating System: Linux 2.6.24-28-xen i686 Ubuntu
[ 20.349] Current Operating System: Linux Ub 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 19:00:26 UTC 2011 i686
[ 20.349] Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.35-28-generic root=UUID=6a2bf31a-3a65-4f86-92b2-5a12674c1f43 ro quiet splash
[ 20.350] Build Date: 29 November 2010 03:29:38PM
[ 20.350] xorg-server 2:1.9.2.901+git20101129+server-1.9-branch.65f2ab20-0ubuntu0sarvatt2~maverick (For technical support please see http://www.ubuntu.com/support)
[ 20.350] Current version of pixman: 0.21.8
[ 20.350] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 20.350] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 20.350] (==) Log file: "/var/log/Xorg.0.log", Time: Mon May 16 10:23:35 2011
[ 20.460] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 20.639] (==) No Layout section. Using the first Screen section.
[ 20.639] (==) No screen section available. Using defaults.
[ 20.639] (**) |-->Screen "Default Screen Section" (0)
[ 20.639] (**) | |-->Monitor "<default monitor>"
[ 20.639] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 20.639] (==) Automatically adding devices
[ 20.639] (==) Automatically enabling devices
[ 20.686] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 20.686] Entry deleted from font path.
[ 20.807] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
[ 20.807] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 20.807] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 20.807] (II) Loader magic: 0x81fa7c0
[ 20.807] (II) Module ABI versions:
[ 20.807] X.Org ANSI C Emulation: 0.4
[ 20.807] X.Org Video Driver: 8.0
[ 20.808] X.Org XInput driver : 11.0
[ 20.808] X.Org Server Extension : 4.0
[ 20.809] (--) PCI:*(0:0:2:0) 8086:0046:104d:9071 rev 2, Mem @ 0xf0000000/4194304, 0xe0000000/268435456, I/O @ 0x0000e080/8
[ 20.809] (II) Open ACPI successful (/var/run/acpid.socket)
[ 20.809] (II) LoadModule: "extmod"
[ 20.820] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 20.833] (II) Module extmod: vendor="X.Org Foundation"
[ 20.833] compiled for 1.9.2.901, module version = 1.0.0
[ 20.833] Module class: X.Org Server Extension
[ 20.834] ABI class: X.Org Server Extension, version 4.0
[ 20.834] (II) Loading extension MIT-SCREEN-SAVER
[ 20.834] (II) Loading extension XFree86-VidModeExtension
[ 20.834] (II) Loading extension XFree86-DGA
[ 20.834] (II) Loading extension DPMS
[ 20.834] (II) Loading extension XVideo
[ 20.834] (II) Loading extension XVideo-MotionCompensation
[ 20.834] (II) Loading extension X-Resource
[ 20.834] (II) LoadModule: "dbe"
[ 20.834] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 20.849] (II) Module dbe: vendor="X.Org Foundation"
[ 20.849] compiled for 1.9.2.901, module version = 1.0.0
[ 20.849] Module class: X.Org Server Extension
[ 20.849] ABI class: X.Org Server Extension, version 4.0
[ 20.849] (II) Loading extension DOUBLE-BUFFER
[ 20.849] (II) LoadModule: "glx"
[ 20.849] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 20.869] (II) Module glx: vendor="X.Org Foundation"
[ 20.869] compiled for 1.9.2.901, module version = 1.0.0
[ 20.869] ABI class: X.Org Server Extension, version 4.0
[ 20.870] (==) AIGLX enabled
[ 20.870] (II) Loading extension GLX
[ 20.870] (II) LoadModule: "record"
[ 20.870] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 20.871] (II) Module record: vendor="X.Org Foundation"
[ 20.871] compiled for 1.9.2.901, module version = 1.13.0
[ 20.871] Module class: X.Org Server Extension
[ 20.871] ABI class: X.Org Server Extension, version 4.0
[ 20.871] (II) Loading extension RECORD
[ 20.871] (II) LoadModule: "dri"
[ 20.871] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 20.906] (II) Module dri: vendor="X.Org Foundation"
[ 20.906] compiled for 1.9.2.901, module version = 1.0.0
[ 20.906] ABI class: X.Org Server Extension, version 4.0
[ 20.906] (II) Loading extension XFree86-DRI
[ 20.906] (II) LoadModule: "dri2"
[ 20.906] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 20.907] (II) Module dri2: vendor="X.Org Foundation"
[ 20.907] compiled for 1.9.2.901, module version = 1.2.0
[ 20.907] ABI class: X.Org Server Extension, version 4.0
[ 20.907] (II) Loading extension DRI2
[ 20.907] (==) Matched intel as autoconfigured driver 0
[ 20.907] (==) Matched vesa as autoconfigured driver 1
[ 20.907] (==) Matched fbdev as autoconfigured driver 2
[ 20.907] (==) Assigned the driver to the xf86ConfigLayout
[ 20.907] (II) LoadModule: "intel"
[ 20.919] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 20.959] (II) Module intel: vendor="X.Org Foundation"
[ 20.959] compiled for 1.9.2.901, module version = 2.14.0
[ 20.959] Module class: X.Org Video Driver
[ 20.959] ABI class: X.Org Video Driver, version 8.0
[ 20.959] (II) LoadModule: "vesa"
[ 20.959] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 20.965] (II) Module vesa: vendor="X.Org Foundation"
[ 20.965] compiled for 1.9.2.901, module version = 2.3.0
[ 20.965] Module class: X.Org Video Driver
[ 20.965] ABI class: X.Org Video Driver, version 8.0
[ 20.965] (II) LoadModule: "fbdev"
[ 20.965] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 20.965] (II) Module fbdev: vendor="X.Org Foundation"
[ 20.965] compiled for 1.8.99.904, module version = 0.4.2
[ 20.965] ABI class: X.Org Video Driver, version 8.0
[ 20.965] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
Sandybridge, Sandybridge
[ 20.966] (II) VESA: driver for VESA chipsets: vesa
[ 20.966] (II) FBDEV: driver for framebuffer: fbdev
[ 20.966] (++) using VT number 7


adamk75 05-16-2011 06:16 AM

Sorry, but that is not the full Xorg log file.

Adam


All times are GMT -5. The time now is 01:02 AM.