LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 02-29-2012, 07:34 PM   #1
oldschoolguy
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Rep: Reputation: Disabled
how do I set up a second hard drive in mint 12 ?


Computer is a HP AMD Phenom X4. The first hard drive is a WD 500 GB, The second added hard drive is a WD 500 GB also. The disc utility does show both hard drives with the first one at 7200 RPM with used space and free space. The second one shows 500 GB of free space and does not show an RPM speed, and nothing is being recorded to it. How do I activate the second hard drive, and will Linux Mint show these as different letter drives and allow me to send files to which drive I want the file to be in, or is it just additional storage when the first drive is full ? I am fine with working programs but know very little about the workings of the computer or the linux software, so it would help if the solution is fully explained.
 
Old 02-29-2012, 09:25 PM   #2
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,550

Rep: Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709
Do you have Mint installed on the first drive?
Have you had it for some time or is this a new install?
Is the second drive a new drive? or have you used it before? and if so, how?
If you have Mint on the first drive and want to use the second drive, you would need to create a partition, format the partition(s) and if you are using it just as extra space for storage/data for you Mint on the first drive, create a mount point in Mint and mount it. If you give more specific answers someone will give you more detailed instructions.
 
Old 03-02-2012, 12:59 PM   #3
oldschoolguy
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
yancek, thank you for your reply. The computer had both drives installed when I installed Mint 12 and eliminated Vista. The second drive was tested and found to be defective and sent back to WD for a new one. The second drive is new and has been installed in the computer, nothing else has been done to it. Linux Mint is on the first drive where Vista was removed. Linux Mint has been on the computer for about 13 months, the new HD has been installed for about 5 weeks. I would like to use the second HD as extra space for storage/data and would love to know how to create a mount point and mount it. I have about 5,000 vinyl albums and am recording them to a 1 Terrabyte external hard drive and would also like to use the new HD for transitional recording.
 
Old 03-03-2012, 04:59 AM   #4
Roken
Member
 
Registered: Oct 2011
Location: Bolton, UK
Distribution: Arch local, Debian on VPS
Posts: 252

Rep: Reputation: 40
Go to your administration menu and find gparted. Use that to set up the drive with a filesystem (You can select the drive from the drop down at the top right corner of the gparted window). Once done you will need to mount the drive to actually use it. You can do this manually as required by creating a mount point and issuing the mount command. For example, assuming you format it with ext4 and that the drive is seen as /dev/sdb and has one partition:

Code:
sudo mkdir /media/newdrive
sudo mount -t ext4 /dev/sdb1 /media/newdrive
or you can have it mounted at boot by adding it to fstab. If you post back with your exact configuration we can tell you the entry to make to fstab.
 
Old 03-03-2012, 03:49 PM   #5
oldschoolguy
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Roken, thank you for the instructions, I went to gparted and formatted the new HD as follows. Partition: /dev/sdb1, format: ext4, Label: F-Drive, size: 465.76 GiB, Used: 7.50 GiB, unused: 458.26 GiB. I tried to use the code you provided to create a mount point and issue the mount command but I must have done it incorrectly. The F-drive icon will not let me open it, it has an X on it and is labeled lost+found. Do I type the first sudo line then enter it, and then type the second sudo line and enter that ? Do I only have to create a mount point and mount command once or every time I want to open the new HD ? If I can just double click on F-drive to open it like the external hard drive I would prefer that. If I have to do it every time I use F-Drive I will have to get better at using code. I clicked on fstab and it is some kind of cloud service, I don't know how clouds work but I do not like my information anywhere but in my computer, I'm not paranoid I just think everyone is out to get everybody. P.S. how much patience does it take to deal with the new kids on the block ?
 
Old 03-03-2012, 06:24 PM   #6
Roken
Member
 
Registered: Oct 2011
Location: Bolton, UK
Distribution: Arch local, Debian on VPS
Posts: 252

Rep: Reputation: 40
OK, open a terminal and type:

Code:
sudo mkdir /media/fdrive
sudo gedit /etc/fstab
This will create the mount point and open the fstab file in gedit, which will already have a bunch of stuff in it. At the end of the file (starting on a new line) enter the following:

Code:
# Entry for F-Drive
/dev/sdb1	/media/fdrive	ext4	defaults	0	0
Then you can either run:

Code:
sudo mount -a
or reboot, and the drive should be mounted. If it doesn't appear in your filemanager, navigate to filesystem/media/fdrive and the contents should be listed there. You can create a shortcut to it for easy access if needed.
 
Old 03-03-2012, 07:45 PM   #7
oldschoolguy
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Roken, thank you for your help. I entered the code in the first block, It will not let me enter one sudo line under the first one it will only let me type in a continuous line, it did not open the fstab file in gedit-it just moves to another line ready to type in. I entered the code in the second block and hit enter and it says etc/F-Drive already exists and moved to another line ready to type in. I entered the code in the third box, hit enter and it moved to another line ready to type in. I went to the file system and found F-Drive and it is in the same condition as before, there is an X on the folder of "lost+found". If I double click on the folder I get a red error notice with the following; The folder contents could not be displayed , you do not have the permissions necessary to view the contents of "lost+found". I have entered my password when it asks for it. I am now wondering if I screwed this up the first time I got the same results and if I should undo everything and start over.
 
Old 03-03-2012, 07:55 PM   #8
Roken
Member
 
Registered: Oct 2011
Location: Bolton, UK
Distribution: Arch local, Debian on VPS
Posts: 252

Rep: Reputation: 40
Oh - want a minute....

You mean if you navigate to /media/F-Drive and open it you then find Lost+Found there? If so, that's normal. It's a directory that's automatically created on your new partition and is used by fsck (filesystem checker). You should be able to create and delete files on the drive without a problem (don't do anything with lost+found - it's a system directory, as I said).

As for the problem you had in the terminal, are you sure that you typed everything exactly as shown? Usually you will only go to a second line if bash thinks that you haven't finished typing the command and it's waiting for more input. Each separate line above should be terminated with Enter (as in, Enter on the keyboard). The second block isn't for entering into the terminal, it's for adding to the file that should open after typing:

Code:
sudo gedit /etc/fstab
Also note that when you start a command with "sudo" bash should ask for your password to proceed, so are you sure it wasn't waiting for your password to be entered?
 
Old 03-04-2012, 01:03 PM   #9
oldschoolguy
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Roken, you are correct, I was focusing on the lost+found folder and not noticing where it was. I can get to F-Drive very easily and it appears as a location choice when I want to save a file. It was that way after the first solution you asked me to try, and I am now trying to convince myself why I didn't realize that sooner. I thought I typed the sudo commands as you showed them, but it did not ask for my password after "enter" on any of them, maybe because they were already done with the first try? Now, even though I can get to F-Drive easily it will not let me access, create, or delete files. I checked the properties of F-Drive and it will not give me the options to create files or folders, it says "you are not the owner, so you cannot change these permissions", I am sure it is because I did not go through the process correctly, but is there a simple way to become the owner ?
 
Old 03-04-2012, 03:26 PM   #10
Roken
Member
 
Registered: Oct 2011
Location: Bolton, UK
Distribution: Arch local, Debian on VPS
Posts: 252

Rep: Reputation: 40
OK - first unmount it:

[code]sudo umount /media/F-Drive[code]

Then make the edit to fstab:

Code:
sudo gedit /etc/fstab
And add to the end of the file:

Code:
# Entry for F-Drive
/dev/sdb1	/media/F-Drive	ext4	defaults	0	0
Save the changed file. Then remount with:

Code:
sudo mount -a
It should give you read/write access to the drive. Adding to fstab will ensure that the drive is mounted automatically at boot time.
 
Old 03-05-2012, 06:39 PM   #11
oldschoolguy
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Roken, The same thing happens when I try to use the code, It says the command does't exist. I opened the disk utility in Linux Mint and it had an edit option to take ownership and format the drive. I did that and it fixed the problem. Thank you for your help and thank you for your patience, it is people like you who keep people like me using Linux.
 
Old 03-05-2012, 06:42 PM   #12
Roken
Member
 
Registered: Oct 2011
Location: Bolton, UK
Distribution: Arch local, Debian on VPS
Posts: 252

Rep: Reputation: 40
I find it surprising that you get the error, but it occurs to me with so many flavours of mint, maybe gedit isn't installed on yours (I'd be surprised, but it's possible). What desktop environment are you using (gnome, kde, xfce etc)?
 
Old 03-07-2012, 05:33 PM   #13
oldschoolguy
LQ Newbie
 
Registered: Feb 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Roken, I am using gnome and gedit is installed on my computer. I think I did not show enough patience when trying to run the code. Also, I tried to run the new hard drive right after I used gparted to set it up and the "lost+found" folder got my attention. I did not recognize I was at the point I needed to be and the code I was trying to enter was trying to get me where I already was. These things happen when I just don't know enough about linux. Linux Mint is the most forgiving and helpful OS I can find and I should suffer at least some learning curve to be more independent. Disk utility in Linux Mint would have made my chore much easier had I been clever enough to know it was there, and what it did. It made it easy. Again, thank you for your help.
 
Old 03-07-2012, 06:16 PM   #14
Roken
Member
 
Registered: Oct 2011
Location: Bolton, UK
Distribution: Arch local, Debian on VPS
Posts: 252

Rep: Reputation: 40
Whilst I think that LQ is a fabulaous resource for Linux help - generally, for distro specific help you can rarely go far wrong with dedicated support forums/channels. I know that some (or even many) forums have a more elitist attitude than most newcomers to Linux would want. However, I can recommend mint IRC (go to your menu, internet, xchat and it will take you there) as a valuable and friendly channel where you can get real time help for problems that may have their basis in the quirks of Mint (rather than Linux in general). Whilst I go there less often these days, you may even bump into me trying to talk a newbie through a complex issue
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Adding one hard drive to Linux Mint 9.(Western digital 250G) darkstarbyte Linux - Hardware 3 10-10-2010 11:42 AM
Can't enter set up hard drive failure? r-t Linux - Hardware 16 05-27-2010 03:31 PM
Not able to set write permissions on external hard drive. jpen8560 Linux - Hardware 19 03-22-2006 10:44 AM
how to set cylinders in partition of new hard drive bry21 Linux - Hardware 4 01-27-2006 07:35 PM
is it possible to set up a network to hard drive dma jwstric2 Programming 5 06-24-2004 04:03 AM


All times are GMT -5. The time now is 03:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration