LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 05-16-2010, 07:29 AM   #1
Paul Griesbaum
Member
 
Registered: Dec 2008
Posts: 48

Rep: Reputation: 15
headphones won't work in Linux Mint Helena


I have a dual boot Linux setup with Linux Mint Helena on one partition and windows 7 on the other. When I plug my headphones into my laptop jack in windows 7 the headphones work, but not while in Linux Mint. I'm using a HP dv7 laptop. I've used many alsa mixers to no avail. I've read something about editing the alsa file. Any ideas?
 
Old 05-16-2010, 09:43 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,297

Rep: Reputation: 205Reputation: 205Reputation: 205
Do you get sound normally? I've noticed that Mint sometimes loads up with the sound in a muted state.
 
Old 05-17-2010, 05:43 AM   #3
Paul Griesbaum
Member
 
Registered: Dec 2008
Posts: 48

Original Poster
Rep: Reputation: 15
The sound is normal except I don't get any sound when I plug in the headphones. Sometimes I lose sound, but I haven't been able to hear any audio from my headphone while in Linux Mint. No problem in windows.

Last edited by Paul Griesbaum; 05-17-2010 at 06:54 AM.
 
Old 06-02-2010, 10:40 AM   #4
decapole
LQ Newbie
 
Registered: May 2004
Location: Germany
Distribution: Mandrake
Posts: 6

Rep: Reputation: 0
headphones won't work in Linux Mint Helena

Hi

I had the same problem for me with a laptop Dell Studio with Intel i5 and Pulse.
I could resolve it as following:

Did a sudo gedit /etc/modprobe.d/alsa-base, and added the following line to the file:
options snd-hda-intel model=dell-m6

Thanks to this thread
http://chrisjean.com/2009/01/29/head...unning-ubuntu/

PS: i m wondering why this old problem in Mint is still not resolved...

Cheers

Last edited by decapole; 06-02-2010 at 11:04 AM. Reason: Solved
 
Old 06-04-2010, 02:10 PM   #5
Paul Griesbaum
Member
 
Registered: Dec 2008
Posts: 48

Original Poster
Rep: Reputation: 15
I typed sudo gedit /etc/modprobe.d/alsa-base and got a seperate window with alsa base in the left hand corner. I selected open and then selected alsa.base.conf. Is this the correct file? If it is since my laptop is a hp would I simply replace dell with hp? Do I also keep the m6?
 
Old 06-16-2010, 04:49 AM   #6
tdockery97
LQ Newbie
 
Registered: Jun 2010
Posts: 2

Rep: Reputation: 0
You want to use sudo gedit /etc/modprobe.d/alsa-base.conf to bring up the config file. Then at the bottom put in what he said but show your model as hp-dv5 (that's what worked for me with the same problem on my HP laptop).
 
Old 06-18-2010, 12:30 PM   #7
Paul Griesbaum
Member
 
Registered: Dec 2008
Posts: 48

Original Poster
Rep: Reputation: 15
I'm using a HP Pavillion dv7 notebook PC so I put dv7 instead of dv5 so this line (options snd-hda-intel model=hp-dv7) has been added to alsa-base.conf.
Since I've done this, I'm still not getting any sound from my headphones. I do get sound from my headphones when I'm using windows 7 What have I done wrong. Here is what my alsa base conf looks like:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
options snd-hda-intel model=hp-dv7
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Power down HDA controllers after 10 idle seconds
#options snd-hda-intel power_save=10 power_save_controller=N
 
Old 12-27-2010, 03:49 PM   #8
UNIXSOLDIER187
LQ Newbie
 
Registered: Dec 2010
Posts: 18

Rep: Reputation: 0
often time laptops have small lil problems like this with linux installs. I use mint julia64 and my video card dosent produce sound have to use the integrated sound card or the audio jack to hear sound.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to play WMV files in Helena (Linux Mint 8) lilchakki Linux Mint 4 08-04-2010 08:52 AM
how to make a moving .gif wallpaper on linux mint helena BirdyMan Linux - General 0 01-17-2010 03:40 PM
to install nvidia drivers on linux mint 8 Helena rhklinux Linux - Newbie 1 01-16-2010 12:45 AM
Mint 8 Helena does not see my hard drives aquaboot Linux Mint 0 12-06-2009 07:52 PM
LXer: The Perfect Desktop - Linux Mint 8 (Helena) LXer Syndicated Linux News 0 12-01-2009 05:30 PM


All times are GMT -5. The time now is 04:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration