LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 05-17-2014, 12:45 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Desktop icon font color does not stick


LMDE fully updated, Mate desktop.

I disabled the desktop background wallpaper. The desktop icon font color is black. I want white.

When I tinker with changing the background the font color changes to white. When I logout and login the font color reverts to black.

As long as I select an image for the background the font color is white. Yet I don't want an image wallpaper. Gradients don't help either.

I tested this with the LMDE Mate DVD as well. Same results, thus I don't think the problem is on my desktop.

The process seems hard-coded: With image backgrounds use white fonts, else use black fonts.

Any ideas how to fix?

The fonts also seem stuck with some kind of drop-shadow. Is there a way to disable the shadows?

Thanks.
 
Old 05-17-2014, 02:16 PM   #2
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Rep: Reputation: 294Reputation: 294Reputation: 294
Hi there,

Quote:
Originally Posted by Woodsman View Post
LMDE fully updated, Mate desktop.
I disabled the desktop background wallpaper. The desktop icon font color is black. I want white.
AFAIK the MATE desktop determines the icon font color from the desktop color: White if the desktop color is dark, black if the desktop color is pale. Seems familiar; Windows used to do it the same way.

Quote:
Originally Posted by Woodsman View Post
As long as I select an image for the background the font color is white.
Is it? Okay, on my systems that use the MATE desktop, the icon font color is actually white. But I realize that's a bad choice when the wallpaper is dominated by bright colors. Then the icon labels are hard to read, their shadow effect being the only thing that retains some legibility.

Quote:
Originally Posted by Woodsman View Post
Any ideas how to fix?
I guess you'd have to dig into creating your own desktop theme. I considered to do that a few times, but never actually got around to it.

Quote:
Originally Posted by Woodsman View Post
The fonts also seem stuck with some kind of drop-shadow. Is there a way to disable the shadows?
Same answer as above, probably.

[X] Doc CPU
 
Old 05-18-2014, 10:09 AM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
AFAIK the MATE desktop determines the icon font color from the desktop color:
I have a dark background with no wallpaper. The fonts are black.
 
Old 05-27-2014, 08:43 AM   #4
rabirk
Member
 
Registered: Dec 2012
Location: Maryland, US
Distribution: Debian
Posts: 83
Blog Entries: 5

Rep: Reputation: Disabled
I wonder if my problem is related. I wiped Debian-Testing, with which I was quite happy Gnome3(classic), and installed LMDE running Gnome3(classic). I navigate to where I can change my background image, select the picture I want, and nothing comes up. I only see the image for a few seconds after booting, then it goes away and leaves me with a blank gray backtop, no image. The display has also failed 3-4 times in the less than 24 hours that I've had LMDE running on the laptop, with an "oops, something went wrong" message appearing and requiring a reboot. My LMDE test is failing so far and I'm thinking I might have to return to Debian-Testing.
 
Old 05-27-2014, 12:52 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
My original post is about Mate rather than LMDE. I confirm the problem is Mate. I tested PCLOS Mate and had the same desktop font color problem. LMDE is using Mate 1.6 while PCLOS Mate is using 1.8. Thus the problem is not yet resolved in Mate.
 
Old 06-06-2014, 03:18 PM   #6
ten0rman
LQ Newbie
 
Registered: Jan 2005
Location: Cumbria, UK
Distribution: Linux Mint
Posts: 13

Rep: Reputation: 0
I too am using, or attempting to use, Mint 17 with Mate, and I have the same problem. E.G. I have set my desktop to black, and I want my desktop text to be white. Having just logged on, I have very faint desktop text. Change to green and the text becomes white with an outline or shadow around it. Change back to black background, and the text remains white with no obvious shadow/outline.

Under Customise theme. I have:
Windows: Light gray background/black text
Input boxes: White background/black text
Selected items: Pale green background/White text
Tooltips: Yellow background/black text.

I seem to recall something similar happening initially with Mint 13 & Mate, but it eventually disappeared.

Regards,

ten0rman
 
Old 06-06-2014, 06:22 PM   #7
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
I confirm this behavior with Mate in Slackware. Thus the problem seems to be Mate and not Mint.
 
Old 07-23-2014, 09:41 AM   #8
Zuon
LQ Newbie
 
Registered: Jun 2014
Location: Southern Alberta
Distribution: Linux Mint DE
Posts: 14

Rep: Reputation: Disabled
Don't use a solid colour background use an image and this problem will not occur.

Last edited by Zuon; 07-23-2014 at 11:48 PM.
 
Old 07-23-2014, 12:27 PM   #9
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
Don't use a solid colour background use an image and this problem will not occur.
If you really want a solid colour background than make an image of that colour and install as if it were a "regular" background.
Sorry, but that is crap advice.

I found a solution:

Code:
style "desktop-icon-font"
{
  text[NORMAL] = "#FFFFFF"
}
widget_class "*DesktopIcon*" style "desktop-icon-font"
 
1 members found this post helpful.
Old 07-23-2014, 12:37 PM   #10
Zuon
LQ Newbie
 
Registered: Jun 2014
Location: Southern Alberta
Distribution: Linux Mint DE
Posts: 14

Rep: Reputation: Disabled
123

Last edited by Zuon; 07-23-2014 at 11:49 PM.
 
Old 09-21-2014, 06:04 AM   #11
revkarol
LQ Newbie
 
Registered: Sep 2014
Posts: 1

Rep: Reputation: Disabled
works for me too. The code above needs to go into $HOME/.gtkrc-2.0
 
Old 09-21-2014, 09:42 AM   #12
ten0rman
LQ Newbie
 
Registered: Jan 2005
Location: Cumbria, UK
Distribution: Linux Mint
Posts: 13

Rep: Reputation: 0
Help! I need my hand holding.

Please could someone explain:

a)Where should this:

style "desktop-icon-font"
{
text[NORMAL] = "#FFFFFF"
}
widget_class "*DesktopIcon*" style "desktop-icon-font"


go, and how to get it there; and

b) Where is this to be found?

The code above needs to go into $HOME/.gtkrc-2.0


I understand that $HOME refers to the "home" folder, assuming that as mine is in lowercase $home, but can't find the rest of it.

MTIA,

ten0rman
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change KDE 3.3 Desktop font color ? s34n Linux - Software 6 08-25-2009 12:38 PM
How to change font color and font size in terminal ? wlaw Linux - Newbie 3 05-15-2007 08:57 PM
gnome desktop font color reddazz Linux - Software 3 11-07-2004 08:17 PM
Change KDE desktop font color TheOneAndOnlySM Slackware 5 01-24-2004 06:55 PM
change font in gmc icon desktop rainman Linux - Software 0 04-22-2001 12:13 AM


All times are GMT -5. The time now is 06:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration