LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux Mint (http://www.linuxquestions.org/questions/linux-mint-84/)
-   -   Desktop icon font color does not stick (http://www.linuxquestions.org/questions/linux-mint-84/desktop-icon-font-color-does-not-stick-4175505311/)

Woodsman 05-17-2014 01:45 PM

Desktop icon font color does not stick
 
LMDE fully updated, Mate desktop.

I disabled the desktop background wallpaper. The desktop icon font color is black. I want white.

When I tinker with changing the background the font color changes to white. When I logout and login the font color reverts to black.

As long as I select an image for the background the font color is white. Yet I don't want an image wallpaper. Gradients don't help either.

I tested this with the LMDE Mate DVD as well. Same results, thus I don't think the problem is on my desktop.

The process seems hard-coded: With image backgrounds use white fonts, else use black fonts.

Any ideas how to fix?

The fonts also seem stuck with some kind of drop-shadow. Is there a way to disable the shadows?

Thanks. :)

Doc CPU 05-17-2014 03:16 PM

Hi there,

Quote:

Originally Posted by Woodsman (Post 5172707)
LMDE fully updated, Mate desktop.
I disabled the desktop background wallpaper. The desktop icon font color is black. I want white.

AFAIK the MATE desktop determines the icon font color from the desktop color: White if the desktop color is dark, black if the desktop color is pale. Seems familiar; Windows used to do it the same way.

Quote:

Originally Posted by Woodsman (Post 5172707)
As long as I select an image for the background the font color is white.

Is it? Okay, on my systems that use the MATE desktop, the icon font color is actually white. But I realize that's a bad choice when the wallpaper is dominated by bright colors. Then the icon labels are hard to read, their shadow effect being the only thing that retains some legibility.

Quote:

Originally Posted by Woodsman (Post 5172707)
Any ideas how to fix?

I guess you'd have to dig into creating your own desktop theme. I considered to do that a few times, but never actually got around to it.

Quote:

Originally Posted by Woodsman (Post 5172707)
The fonts also seem stuck with some kind of drop-shadow. Is there a way to disable the shadows?

Same answer as above, probably.

[X] Doc CPU

Woodsman 05-18-2014 11:09 AM

Quote:

AFAIK the MATE desktop determines the icon font color from the desktop color:
I have a dark background with no wallpaper. The fonts are black.

rabirk 05-27-2014 09:43 AM

I wonder if my problem is related. I wiped Debian-Testing, with which I was quite happy Gnome3(classic), and installed LMDE running Gnome3(classic). I navigate to where I can change my background image, select the picture I want, and nothing comes up. I only see the image for a few seconds after booting, then it goes away and leaves me with a blank gray backtop, no image. The display has also failed 3-4 times in the less than 24 hours that I've had LMDE running on the laptop, with an "oops, something went wrong" message appearing and requiring a reboot. My LMDE test is failing so far and I'm thinking I might have to return to Debian-Testing.

Woodsman 05-27-2014 01:52 PM

My original post is about Mate rather than LMDE. I confirm the problem is Mate. I tested PCLOS Mate and had the same desktop font color problem. LMDE is using Mate 1.6 while PCLOS Mate is using 1.8. Thus the problem is not yet resolved in Mate.

ten0rman 06-06-2014 04:18 PM

I too am using, or attempting to use, Mint 17 with Mate, and I have the same problem. E.G. I have set my desktop to black, and I want my desktop text to be white. Having just logged on, I have very faint desktop text. Change to green and the text becomes white with an outline or shadow around it. Change back to black background, and the text remains white with no obvious shadow/outline.

Under Customise theme. I have:
Windows: Light gray background/black text
Input boxes: White background/black text
Selected items: Pale green background/White text
Tooltips: Yellow background/black text.

I seem to recall something similar happening initially with Mint 13 & Mate, but it eventually disappeared.

Regards,

ten0rman

Woodsman 06-06-2014 07:22 PM

I confirm this behavior with Mate in Slackware. Thus the problem seems to be Mate and not Mint.

Zuon 07-23-2014 10:41 AM

Don't use a solid colour background use an image and this problem will not occur.

Woodsman 07-23-2014 01:27 PM

Quote:

Don't use a solid colour background use an image and this problem will not occur.
If you really want a solid colour background than make an image of that colour and install as if it were a "regular" background.
Sorry, but that is crap advice.

I found a solution:

Code:

style "desktop-icon-font"
{
  text[NORMAL] = "#FFFFFF"
}
widget_class "*DesktopIcon*" style "desktop-icon-font"


Zuon 07-23-2014 01:37 PM

123

revkarol 09-21-2014 07:04 AM

works for me too. The code above needs to go into $HOME/.gtkrc-2.0

ten0rman 09-21-2014 10:42 AM

Help! I need my hand holding.

Please could someone explain:

a)Where should this:

style "desktop-icon-font"
{
text[NORMAL] = "#FFFFFF"
}
widget_class "*DesktopIcon*" style "desktop-icon-font"


go, and how to get it there; and

b) Where is this to be found?

The code above needs to go into $HOME/.gtkrc-2.0


I understand that $HOME refers to the "home" folder, assuming that as mine is in lowercase $home, but can't find the rest of it.

MTIA,

ten0rman


All times are GMT -5. The time now is 10:56 AM.