LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux Mint (http://www.linuxquestions.org/questions/linux-mint-84/)
-   -   Change user permissions , wireless and bluetooth (http://www.linuxquestions.org/questions/linux-mint-84/change-user-permissions-wireless-and-bluetooth-4175425335/)

lghizoni 09-02-2012 10:28 PM

Change user permissions , wireless and bluetooth
 
Hello all,

I was a Debian user in the past, but started using Linux Mint MATE, and it works great! It recongizes everything! I'm very satisfied!

I just got three things to solve:

1. I would like to change the user permissions, as I had in Debian, in which only root could make changes. Mint gives almost all permissions to the user by default, and I would like to change it like it was in Debian, but I don't know how. Could someone help me?

2. Another thing is wireless, which by default works just fine. It's just that I disabled it once, and now I always have to enable it manually when I start the system;

3. Finally, Mint works with bluetooth by default, but today I tried to connect my cell phone and couldn't do it. It's a Nokia phone. I would like to pass some data from the computer to the cell phone.

Could someone help me with these 'problems'?

Thanks a lot!

abrinister 09-02-2012 11:07 PM

Quote:

1. I would like to change the user permissions, as I had in Debian, in which only root could make changes. Mint gives almost all permissions to the user by default, and I would like to change it like it was in Debian, but I don't know how. Could someone help me?
What do you mean by this? Everything is given to sudo, which the user interface to the root account. If you want to enable the root account,

Code:

sudo su -

passwd root

Quote:

It's just that I disabled it once
How did you disable it?

Alex Brinister

lghizoni 09-03-2012 07:00 PM

I've already changed the root password. But the user still gets access to lots of things with his own password, and I would like to change that. I would like just the root can get access to updates, installations etc.

As the wireless, I disabled it manually with right-click on the connection icon. Now it doesn't connect automatically anymore. I always have to enable it with the keyboard.

Thanks in advance!

abrinister 09-03-2012 10:59 PM

You can remove the line with your username in the /etc/sudoers file.

Alex Brinister

lghizoni 09-26-2012 12:52 PM

Sorry not to answer quickly...

That's exactly what I want, get the user out of the sudoers file, but I tried it once and I thing I've made some mess, because I had to reinstall the system to work properly.

I'll show the output of my /etc/sudoers here. Can you, please, tell exactly what to erase???

Thanks a lot!

lghizoni 09-26-2012 01:01 PM

#
# This file MUST be edited with the 'visudo' command as root.
#
# Please consider adding local content in /etc/sudoers.d/ instead of
# directly modifying this file.
#
# See the man page for details on how to write a sudoers file.
#
Defaults env_reset
Defaults secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification
root ALL=(ALL:ALL) ALL

# Members of the admin group may gain root privileges
%admin ALL=(ALL) ALL

# Allow members of group sudo to execute any command
%sudo ALL=(ALL:ALL) ALL

# See sudoers(5) for more information on "#include" directives:

#includedir /etc/sudoers.d


All times are GMT -5. The time now is 09:52 AM.