LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux Mint (http://www.linuxquestions.org/questions/linux-mint-84/)
-   -   Can't select XP OS in a dual boot with Isadora at boot screen (grub problem) (http://www.linuxquestions.org/questions/linux-mint-84/cant-select-xp-os-in-a-dual-boot-with-isadora-at-boot-screen-grub-problem-823708/)

faby1321 08-03-2010 12:00 AM

Can't select XP OS in a dual boot with Isadora at boot screen (grub problem)
 
Hey guys , I had a dual boot
Mint9 and Xp, everything works
perfect before, but now after the last mint
update, my keyboard doesn't work, i can't select
xp, arrows or any key doesn't work until it boots
in linux, key board works perfect after login in mint, but
I need to boot in xp to retrieve some files.

any help!!

business_kid 08-03-2010 03:52 AM

you need to put an entry in grub.cfg (I think) for XP. Something like

title your pet name for XP - feel free to be abusive
rootnoverify (your xp drive in grub speak, hd0.0 or that sort of thing in round brackets)
chainloader +1

faby1321 08-03-2010 03:38 PM

To Business kid
What are your talking about? ,
computer works perfect since i installed
Xp and LM9, no need to config grub.cfg,
or put a name o label to xp!
beside that XP is installed in a partition not on
a drive, and you don't have a chainloader+1 in
Grub2
Please if you don't know, don't guess

I have a 160GB HD, partitioned like this:
15gb-ext4-mounted at / installed Linux mint- /dev/sda1
2gb -swap space
86gb-extended partition- ext4-(2gb for swap & 84gb for separated home partition), /dev/sda2
31gb-NTFS-bootable-I installed Window$ XP Pro in this partition= /dev/sda3
27gb-NTFS- I use this partition for data and storage-(I can mount this partition from linux or from XP)- /dev/sda4

When I installed Xp, the entry that you talk about
is already done automatically by the installer itself
so there isn't a need to mess around with grub.cfg, (that's the installer job).

markmurf 08-04-2010 01:57 AM

I assume your keyboard is a USB keyboard? Do you have the option of trying a PS2 keyboard to see if the same behaviour is exhibited?
Check your BIOS and make sure USB input devices is enabled, or whatever option your particular BIOS has.
If none of these options help, you might need to update grub, and that may help with your issue.

faby1321 08-05-2010 03:04 PM

NO, my keyboards are(have 2) PS2,
and of course I can't go to bios
because the keyboard doesn't respond
when booting up!!

none of the key works when booting up,
so i can't select any of my 2 OS, but it
works after the computer
boots in linux, (after the 10 seconds count)

and yes, i already updated grub
thanks for your answer, and your time spent
i appreciated.

markmurf 08-06-2010 01:45 AM

Well, that has me completely stumped. I don't see how or why updating Mint would cause a PS2 type keyboard to stop responding at boot time. It may be a worthwhile exercise looking through your history log file in /var/log/apt to see what packages you last updated and that will at least give you a starting point as to what may be causing the problems. Post your results here if you wish.

faby1321 08-06-2010 11:23 PM

After looking to /var/log/apt,
i found this:



Start-Date: 2010-07-24 21:43:37
Upgrade: xulrunner-1.9.2 (1.9.2.6+nobinonly-0ubuntu0.10.04.1, 1.9.2.7+build2+nobinonly-0ubuntu0.10.04.1), apt-transport-https (0.7.25.3ubuntu9, 0.7.25.3ubuntu9.1), mintsystem (7.6.8, 7.6.9), apt-utils (0.7.25.3ubuntu9, 0.7.25.3ubuntu9.1), apt (0.7.25.3ubuntu9, 0.7.25.3ubuntu9.1), firefox (3.6.6+nobinonly-0ubuntu0.10.04.1, 3.6.7+build2+nobinonly-0ubuntu0.10.04.1), mintupdate (4.0.5, 4.0.6), firefox-gnome-support (3.6.6+nobinonly-0ubuntu0.10.04.1, 3.6.7+build2+nobinonly-0ubuntu0.10.04.1), firefox-branding (3.6.6+nobinonly-0ubuntu0.10.04.1, 3.6.7+build2+nobinonly-0ubuntu0.10.04.1), ureadahead (0.100.0-4.1, 0.100.0-4.1.2)
End-Date: 2010-07-24 21:44:14

Start-Date: 2010-07-27 17:03:53
Upgrade: xulrunner-1.9.2 (1.9.2.7+build2+nobinonly-0ubuntu0.10.04.1, 1.9.2.8+build1+nobinonly-0ubuntu0.10.04.1), thunderbird (3.0.5+build2+nobinonly-0ubuntu0.10.04.1, 3.0.6+build2+nobinonly-0ubuntu0.10.04.1), firefox (3.6.7+build2+nobinonly-0ubuntu0.10.04.1, 3.6.8+build1+nobinonly-0ubuntu0.10.04.1), gdm (2.30.2.is.2.30.0-0ubuntu2, 2.30.2.is.2.30.0-0ubuntu3), firefox-gnome-support (3.6.7+build2+nobinonly-0ubuntu0.10.04.1, 3.6.8+build1+nobinonly-0ubuntu0.10.04.1), firefox-branding (3.6.7+build2+nobinonly-0ubuntu0.10.04.1, 3.6.8+build1+nobinonly-0ubuntu0.10.04.1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2010-07-27 17:04:20

Start-Date: 2010-07-28 09:47:11
Upgrade: ubuntu-system-service (0.1.20, 0.1.20.1)
End-Date: 2010-07-28 09:47:22


My problem started
between july 24 and july 28,
so I don't know what to do or where to
look up I think the las one screwed up my computer
the ubuntu system service update,
thank for checking

Drakeo 08-06-2010 11:56 PM

here is the problem you did what your system asked you to do up date the O/S. updated.
Quote:

Hey guys , I had a dual boot
Mint9 and Xp, everything works
perfect before, but now after the last mint
update, my keyboard doesn't work, i can't select
xp, arrows or any key doesn't work until it boots
in linux, key board works perfect after login in mint, but
I need to boot in xp to retrieve some files.
now please be kind look at this
Quote:

, i can't select
xp, arrows or any key doesn't work until it boots
Befor O/s boots it is bios. Not a operating system.
this is a grub hard ware bios problem ???????? not sure.
usb key board? how about a little info.

let me guess ps2 mouse that was pulled out and put back in and a keyboard that has ps 2 connection also.
since nothing is running
Because you said
Quote:

key doesn't work until it boots
trust me I do hardware for a living. Intel board will not boot with out keyboard. Look back. this is the first thing you learn. Dirty keys? etc.
Quote:

works after the computer
boots in linux, (after the 10 seconds count)
switch the ps2 mouse with the ps2 keyboard yes this is a bios read old
old problem. Xp has the ability to play with bios not Linux.
get rid of xp and put bios in none windows none os environment
Yes you did up grade doze xp.

pierre2 08-08-2010 08:16 AM

Quote:

switch the ps2 mouse with the ps2 keyboard yes this is a bios read old
old problem. Xp has the ability to play with bios not Linux.
get rid of xp and put bios in none windows none os environment
Yes you did up grade doze xp.
Don't follow that bit ..

I generally set the bios to "no plugNplay" aware O/S.
that way,, only the O/S can set, how the hardware operates.

& anyway, a kernel upgrade is not going to cause the OPs problems.

Drakeo 08-09-2010 07:51 AM

Quote:

Don't follow that bit ..

I generally set the bios to "no plugNplay" aware O/S.
that way,, only the O/S can set, how the hardware operates.
That is the same thing I said no pnp. ok if you go back 25 years the pnp was not there it was OS select when we had OS2 from IBM and a IBM spin off company M$ from Bill Gates. and Unix.
sorry if I did not make sense to you. to day plug N play has gone different directions in bios
Quote:

pierre2 you actually know his version of bios and see the no plug n play settings
proprietary bios by mother board manufactures vary so much I have to give a generic answer in order for them to find select os. and that option is not on all proprietary boards.
Quote:

I generally set the bios to "no plugNplay" aware O/S.
that way,, only the O/S can set, how the hardware operates.
when set to NONE plug N Play this allows the bios to set the IRQ's
then The kernel will read them and set up to them.
That said Linux is not designed to run bios never will. PNP was experimental for 10 years. UDEV hotplug just reads the bios and sets up the hardware hal runs them.
Since this problem.
Quote:

Since this problem is before the O/S is started what is this going to do
this is why we set to No O/S Select or NO plug N play No windows or no OS/2 they all mean the same thing let bios run the board and do not let the O/S change IRQ addresses.

faby1321 08-10-2010 06:07 PM

after more than 2 weeks, i got a little frustrated
so i decided to reinstall LinuxMint 9 (again), and that
did the trick or solution, unfortunately i didn't find
out what was the problem that caused the keyboard stop
working, so in the future I can't help someone with the
same problem.

Anyway my problem is solved
I just wanna say thanks to everyone that tried to help me

Now I'm so happy with my 2 worlds (Linux & Window$)

Thanks and bye.


All times are GMT -5. The time now is 03:25 AM.