LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 06-27-2014, 07:18 AM   #1
michael295007
LQ Newbie
 
Registered: Jun 2014
Posts: 4

Rep: Reputation: Disabled
Can't install mintupdate 4.5.6-1 (Linux Mint 16)


I can't install mintupdate 4.5.6-1 under Linux Mint 16.

When mintupdate tries to upgrade version 4.5.6 to version 4.5.6-1 the following error pops up:

E: Could not open lock file /var/cache/apt/archives/lock - open (21: Is a directory)
E: Could not open file descriptor -1
E: Unable to lock the download directory

I tried “sudo apt-get update”, no joy. I can download the update but I can’t install it. The same error message appears.
What can I do to fix this? Every suggestion is highly appreciated.
 
Old 06-28-2014, 09:34 AM   #2
ondoho
Senior Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 1,063

Rep: Reputation: 147Reputation: 147
http://ubuntuforums.org/showthread.php?t=1894744

[ i'm pretty sure i answered this yesterday, but it was late at night and maybe i pressed the wrong button, preview instead of submit, who knows... anyhow, everything i wrote is also in the linked forum thread. ]
 
Old 06-28-2014, 11:00 AM   #3
michael295007
LQ Newbie
 
Registered: Jun 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
"sudo rmdir /var/cache/apt/archives/lock" did the job.

Everything seems to work fine now.

Thanks for your help.
 
Old 08-12-2014, 04:52 AM   #4
nomko
Member
 
Registered: Feb 2011
Location: The Netherlands
Posts: 32

Rep: Reputation: 1
Quote:
I can't install mintupdate 4.5.6-1 under Linux Mint 16.
Mint 16 is obsolete and no longer supported and maintained, not even by the Mint community. It is recommended to upgrade to Mint 17 which is a Long Term Support (LTS) version. Info about upgrading you can find here: http://forum.linuxmint.com/viewtopic.php?f=143&t=173378
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
install guide for linux mint 15 upgrade to linux mint 17? OMouse Linux Mint 8 06-18-2014 07:43 PM
mintupdate 4.4.7 problems in Mint 14 ahzthecat Linux Mint 11 12-26-2012 10:47 AM
Linux mint install clayton71740 Linux - Newbie 4 04-04-2012 12:29 AM
Using VB to install Linux Mint Slightly Disoriented Linux - Newbie 17 12-06-2010 04:30 PM
Newbie with Mint/ Linux needs to install Clam AV in Mint after 4 Wdws Trogan attack BAKEAPPLEFARM Linux Mint 6 03-24-2010 08:38 PM


All times are GMT -5. The time now is 09:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration