LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices



Reply
 
Search this Thread
Old 02-15-2010, 10:50 PM   #1
newbie236
LQ Newbie
 
Registered: Jan 2010
Posts: 20

Rep: Reputation: 0
Authentication to restart and turn off?


Recently I turned on autologin, but had to turn it off for privacy. Now, everytime I turn off, or reboot it asks for authentication because I have multiple users logged on. Any ideas? I can post whatever details you need.
(It hasnt felt normal lately anyways, sometimes normal things dont load right (The menu icon, volume, etc) It also may have to do with me uninstalling virtualbox, not deleting my hard drive. No idea, Im a bit tired to fix this, it may be really obvious.)
 
Old 02-17-2010, 07:39 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Before trying to shutdown, could you enter the command:
users

Do any other users show up besides yourself?

Does Linux mint use policy kit. I suspect that a policy may have been disabled when you made the autologin change (don't know why it should) and not re-granted when you changed it back.

To check if it does use policy-kit, enter this command as your regular user:
Code:
polkit-auth

...
org.freedesktop.hal.power-management.shutdown
org.freedesktop.hal.power-management.shutdown-multiple-sessions
org.freedesktop.hal.power-management.reboot
org.freedesktop.hal.power-management.reboot-multiple-sessions
...
If some policies are shown but the four above aren't I think that granting these policies may fix the problem. First see if they are available:
Code:
polkit-auth --show-obtainable
To change the policies, use the "polkit-gnome-authentication" program.
It has a graphical interface and more importantly will save your changes.

Another area to look is in your configuration for users & groups, or for the power-save configuration.
 
Old 02-18-2010, 06:11 PM   #3
newbie236
LQ Newbie
 
Registered: Jan 2010
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks the setting was off. I just went in the program and fixed, lots of help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My CnMBook Manual page 5 shows how to turn off on desk top, but how do I turn on? salmagundi Linux - Newbie 2 04-04-2009 03:46 PM
windows domain authentication - winbind restart needed bigearsbilly Linux - Server 1 10-01-2008 03:31 AM
How do I set the regulatory daemon to restart when I restart the network service? zahadumy Linux - Networking 0 11-05-2006 12:24 PM
How to start, stop, turn on, and turn off deamons BuckRogers01 Debian 3 08-16-2005 10:39 AM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 09:05 AM


All times are GMT -5. The time now is 04:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration