LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   XFCE with Unichrome graphics (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/xfce-with-unichrome-graphics-848275/)

Lord_Grave 12-04-2010 03:12 AM

XFCE with Unichrome graphics
 
I am trying to set up my laptop computer to work with OpenSUSE 11.3 and XFCE. When I installed the system and started XFCE, the desktop was at 1024x768 resolution but it was horizontally stretched over the laptop's wide screen. XFCE's display settings is stuck at 1024x768 at 76Hz and is not offering any alternatives.
My lspci output for graphics card is:

Code:

01:00.0 VGA compatible controller: VIA Technologies, Inc. CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro] (rev 01)
I tried to resolve this by installing xorg-x11-driver-video-unichrome package from OpenSUSE repository. After X restart, it gave me much sharper graphics, but my resolution was still stuck at 1024x768 at 76Hz and instead of stretched desktop, it was exactly at 4:3 aspect ratio, along the left edge of the screen, with some space along the right edge left black and unused.

I tried to fix this by editing the conf files in /etc/X11/xorg.conf.d. I typed "cvt 1280 720" and pasted its output into newly created modlines section of the monitors conf file. I also created a section in screens conf file, telling the X to use the mode I just created. After X restart, I got an error: UNICHROME(0): No valid modes found. I only managed to get back into desktop to post this by renaming the xorg.conf.install file into xorg.conf.

Any ideas on how to get XFCE settings to display more resolution choices with Unichrome drivers?

Lord_Grave 12-04-2010 04:19 AM

Additional info:

I've managed to change the resolution by generating a new xorg.conf file and adding a Modes line to the Screen section, but my desktop is still being fit into the 4:3 area in the right part of my screen. Is there any way to make the driver or xorg realise that my screen is not 4:3?

princeharris13 12-06-2010 04:54 AM

I tried to fix this by editing the conf files in /etc/X11/xorg.conf.d. I typed "cvt 1280 720" and pasted its output into newly created modlines section of the monitors conf file. I also created a section in screens conf file, telling the X to use the mode I just created. After X restart.


All times are GMT -5. The time now is 04:23 PM.