LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 01-25-2009, 09:40 PM   #1
frznchckn
Member
 
Registered: Jun 2006
Location: CA
Distribution: Ubuntu, CentOS, Scientific Linux
Posts: 97

Rep: Reputation: 15
Question XFCE fails to initialize and logs me out


I'm running Eeebuntu 2.0 on an ASUS EEE 1000. I am trying to switch from gnome to XFCE4.

When I log in after selecting XFCE4, I get an error message saying:

your session only lasted less than 10 seconds

or something to that affect and it directs me to check

.xsession-errors

The dump of that file is below. Any ideas?
[~][2]$ cat .xsession-errors
/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=en_US.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
x-session-manager[17828]: WARNING: Could not parse desktop file /etc/xdg/autostart/eeepc-statusicon.desktop: Permission denied
x-session-manager[17828]: WARNING: could not read /etc/xdg/autostart/eeepc-statusicon.desktop
x-session-manager[17828]: WARNING: Unable to find provider 'gnome-wm' of required component 'windowmanager'
Window manager warning: Failed to read saved session file /home/<username>/.config/metacity/sessions/101e96928cf7f9d5e7123294013133846700000178280008.ms: Failed to open file '/home/<username>/.config/metacity/sessions/101e96928cf7f9d5e7123294013133846700000178280008.ms': No such file or directory
seahorse nautilus module initialized
Initializing nautilus-share extension
Unable to open desktop file evolution-mail.desktop for panel launcher
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

x-session-manager[17828]: WARNING: Application 'libcanberra-login-sound.desktop' failed to register before timeout
Failure: Module initalization failed
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x300000a (Terminal)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
 
Old 01-29-2009, 03:57 PM   #2
cheftec
Member
 
Registered: Jan 2009
Location: Pennsyltucky
Distribution: Debian, Ubuntu, DeLiLinux, others
Posts: 144

Rep: Reputation: 19
Well, you could try to update your 'libcanberra-login-sound.desktop'.
Try apt-get install libcanberra

see what happens then, you may have to rmmod something. Post your xdm.log. Should be in /var/log/.
 
Old 02-02-2009, 08:38 PM   #3
frznchckn
Member
 
Registered: Jun 2006
Location: CA
Distribution: Ubuntu, CentOS, Scientific Linux
Posts: 97

Original Poster
Rep: Reputation: 15
installed libcanberra

xfce still failed almost immediately after logging in

xdm.log is not in /var/log/
 
Old 02-03-2009, 04:33 PM   #4
cheftec
Member
 
Registered: Jan 2009
Location: Pennsyltucky
Distribution: Debian, Ubuntu, DeLiLinux, others
Posts: 144

Rep: Reputation: 19
Ok, so your gnome still runs, right? so its probably not a xorg.conf issue. Try running xfce4 in gnome, and see what happens. You could try strace xfce4 (or whatever the startup is for xfce, i think its xfce4)and post what it does. If you're willing to try, I think Waaaay back in the day I had to remove gdm to get xfce to work, but that was on debian sarge; I don't rightly know what that'll do to your system.

Also, have you tried loggin in with gnome, quitting x (or, starting with text login entirely), then starting xfce manually at the prompt on tty1? If that works, its more than likely a gdm/xdm/login manager problem.
 
Old 02-03-2009, 07:45 PM   #5
frznchckn
Member
 
Registered: Jun 2006
Location: CA
Distribution: Ubuntu, CentOS, Scientific Linux
Posts: 97

Original Poster
Rep: Reputation: 15
Okay, i did learn that this is based on the debian xfce packages as told by the "about"

This is all the xfce stuff I can run:

[~][12]$ xfce
xfce4-about xfce4-panel xfce4-terminal
xfce4-autostart-editor xfce4-popup-menu xfce4-terminal.wrapper
xfce4-kiosk-query xfce4-popup-windowlist xfce4-tips
xfce4-menueditor xfce4-session xfce-mcs-manager
xfce4-mixer xfce4-session-logout xfce-setting-show

I can start xfce4-terminal, it opens another terminal window.

when I run "xfce4-autostart-editor I get

[~][13]$ xfce4-autostart-editor

(xfce4-autostart-editor:21657): libxfce4util-CRITICAL **: Failed to parse file /etc/xdg/autostart/eeepc-statusicon.desktop, ignoring.

(xfce4-autostart-editor:21657): GLib-CRITICAL **: g_string_chunk_insert: assertion `chunk != NULL' failed

(xfce4-autostart-editor:21657): GLib-CRITICAL **: g_string_chunk_insert: assertion `chunk != NULL' failed
Segmentation fault


When I try to run "xfce4-session" I get the following

xfce4-session: Another session manager is already running
 
Old 02-04-2009, 10:14 AM   #6
cheftec
Member
 
Registered: Jan 2009
Location: Pennsyltucky
Distribution: Debian, Ubuntu, DeLiLinux, others
Posts: 144

Rep: Reputation: 19
You may have done this, but if you /haven't/ I think this may be your ticket.

From xfce faq:

Setting up GDM

If you installed Xfce system-wide and you want to use the GNOME Display Manager (gdm) to start your Xfce session, you will have to create a .desktop file to teach gdm how to start the Xfce session. This is a sample desktop file, Xfce.desktop:

[Desktop Entry]
Encoding=UTF-8
Name=Xfce 4.4 Session
Comment=Use this session to run Xfce 4.4 as your desktop environment
Exec=/usr/local/bin/startxfce4
Icon=/usr/local/share/pixmaps/xfce4_xicon1.png
Type=Application

It is usually enough to simply copy the example file to the Session directory used by gdm; this directory is usually located in /etc/dm/Sessions, /etc/X11/gdm/Sessions, /usr/share/xsessions, /usr/X11/share/gnome/xsessions or some other location, refer to the documentation of your system for details. You need to restart gdm after you created the file.

If you have done this, maybe try reinstalling gdm.
 
Old 02-04-2009, 10:38 AM   #7
frznchckn
Member
 
Registered: Jun 2006
Location: CA
Distribution: Ubuntu, CentOS, Scientific Linux
Posts: 97

Original Poster
Rep: Reputation: 15
I'll have to try this when I get back to that computer, but doesn't that defeat the point of using xfce? I'm trying to not use gnome to save on processing power and RAM.

or am I not understanding how this all works?
 
Old 02-04-2009, 04:47 PM   #8
cheftec
Member
 
Registered: Jan 2009
Location: Pennsyltucky
Distribution: Debian, Ubuntu, DeLiLinux, others
Posts: 144

Rep: Reputation: 19
Well then, you can remove gdm and install xdm. That's as easy as

sudo apt-get install xdm (unless its already installed, but won't hurt to do)

then set your xdm to be the default login manager:

sudo dpkg-reconfigure xdm

and follow the prompts. Then

sudo apt-get remove gdm
 
Old 02-06-2009, 02:19 PM   #9
frznchckn
Member
 
Registered: Jun 2006
Location: CA
Distribution: Ubuntu, CentOS, Scientific Linux
Posts: 97

Original Poster
Rep: Reputation: 15
Okay, tried xdm, it worked but I was unable to selected a different window manager so it started gnome. So I switched back to gdm.

I'll be trying to get gdm to start xfce next. Just ran out of time before I had to get Xilinx FPGA tools up and running which is turning out to be a chore.

Thanks though, I'll let you know when I break something else soon.
 
  


Reply

Tags
asus, eeebuntu, xfce4


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X fails to initialize the NVIDIA graphics device jimbogray Linux - Hardware 1 04-28-2008 08:07 PM
Working interface fails to initialize on startup ja203 Linux - Wireless Networking 1 12-10-2006 01:12 PM
nvidia + xorg = death (fails to initialize) scius Linux - Software 6 10-11-2004 09:36 AM
CD Rom fails to initialize audio CD's general774 Linux - Hardware 6 01-12-2004 12:54 AM
Fails to initialize network card sometimes jwstric2 Linux - Networking 8 01-10-2004 11:20 AM


All times are GMT -5. The time now is 12:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration