LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   XF86Config: how to avoid black frame : Suse 8.2 + new nvidia driver (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/xf86config-how-to-avoid-black-frame-suse-8-2-new-nvidia-driver-79516/)

muellla 08-06-2003 10:07 AM

XF86Config: how to avoid black frame : Suse 8.2 + new nvidia driver
 
Hi there!
Semi-Newbie needs help:
How can I persuade ;-) the driver or what do I have to edit in XF86config to use the right mode 1400x1050 and full screen of my dell laptop???
The issue:
I am facing a problem with the right mode and or screen size of my dell inspiron 4100 laptop under suse 8.2:
Installation of the new 4496 version nvidia driver went fine for me and sax2 produded a working XF86config; (I had one before).

So now I get as before full screen picture in 1400x1050 mode - so far there is no problem;

However the problem starts when I try to use 3D support .
After editing XF86config ("nv" to "nvidia" ... etc. ) the 3D support also works fine now (- for the first time with powermanagement, woh) - so far so good ;

But, I always get the wrong resolution ; 1280X1024 instead of 1400X1050. When I switch to 1400x1050 by typing [Alt F7] the screen is not used fully and I get this black frame around it !
It is not possible to use sax2 for it - it always produces the wrong 1280X1024 resolution.

How can I persuade ;-) the driver or what do I have to edit in XF86config to use the right mode 1400x1050 and full screen of my dell laptop:
-------------
I am using SUSE 8.2 ; default kernel out of the box;
hardware: Dell Inspiron 4100 Laptop with nvidia Geforce 2 Go (32 mb) and a 14'' TFT with 1400x1050 pixels

hope somebody knows what to do - thanks in advance

muellla

[B]

aaa 08-06-2003 11:42 AM

Can you post your XF86Config file?

muellla 08-08-2003 02:08 AM

solution found - thanks
 
Hi there !
Thanks for the reply – finally – after another night of trying and playing around with the various options in the nvidia driver readme I found the solution :

Below I include the relevant part of the XF86config that works now flawlessly :-)) I am uncertain which of the changes in the Monitor section was the crucial amendment that did the trick - I added several things at the same time
–an additional modeline for 1400x1050 (from the readme).
– Option "IgnoreEDID" "1"
–the corrected display size in millemeter which sax2 put completely wrong.
–And

Note: I also included in the file /etc/modules.conf the option line for Dell laptops which was likely as helpful as the "IgnoreEDID" "1" in XF86Config:

/etc/modules.conf:
options nvidia Nvreg Mobile=1

thanks again for the help
muellla

Init-0 08-09-2003 10:21 AM

http://www.thorstenhaas.de/toshiba2410/

Theres a section at this web adress that deals with X and NVIDIA drivers.

Its on Debian but it seems to work for Suse too :)

It may also fix some other bug bears you might find


All times are GMT -5. The time now is 01:08 PM.