LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-28-2011, 11:07 PM   #1
wilson47
Member
 
Registered: Jan 2009
Posts: 50

Rep: Reputation: 15
x120e no sound through headphones, fine through speaker


I'm setting up Slackware 13.37 on a Lenovo x120e. I've ran into plenty of problems so far, and my next challenge is the audio. So far I have managed to get it to work through the built-in speakers. But when I plug in headphones, sound just continues to come out of the speakers. I tried adding in different options for alsaconf, but that didn't seem to work. Does anybody have any ideas?

output of lspci -v | grep Audio
Code:
Audio device: ATI Technologies Inc Device 1314
I did run alsaconf to get my speakers to work properly. Perhaps there is some driver issue?

Last edited by wilson47; 11-29-2011 at 06:37 AM.
 
Old 11-29-2011, 03:28 PM   #2
wilson47
Member
 
Registered: Jan 2009
Posts: 50

Original Poster
Rep: Reputation: 15
So I think I somehow got it to work. I uninstalled alsa-lib using the slackpkg tool, then I installed alsa-lib and alsa-driver from the alsa website. Without running alsaconf or anything, I rebooted my machine and everything works fine. You even get a nifty little beep!

The sound card alsamixer tells me it is using is: HDA ATI SB with Chip: Conexant CX20582 (Pebble). I also have a modified .asoundrc whose contents can be found in my other thread on setting up x120e with slackware 13.37.


Edit: So the above worked at first. Then after a reboot, the sound went all screwy. I then blacklisted a bunch of drivers and got it to work. I'm sure there is a better way to do this, but here is what I added to /etc/modprobe.b/blacklist.conf
Code:
blacklist snd_hwdep
blacklist snd_pcsp
blacklist snd_seq_dummy
blacklist snd_seq_oss
blacklist snd_seq
blacklist snd_seq_device
blacklist snd_pcm_oss
blacklist snd_mixer_oss
blacklist snd_hda_intel
blacklist snd_hda_codec
blacklist snd_timer

Last edited by wilson47; 11-29-2011 at 05:55 PM.
 
Old 11-29-2011, 09:28 PM   #3
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
can you post the sound specs of the laptop pls

I assume you have a jack for speakers and a separate jack for headphone.

but sometimes they share one of those jacks or stacks with input device like a mic because they may have only 3 jacks.

better still give us an image of running alsamixer after running the command
Code:
alsamixer -V all
forgive me if you have solved it ...edit your first to solved if so
 
Old 11-29-2011, 09:35 PM   #4
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
oh can you post the lsmod output for your sound module as well if not solved

http://www.kernel.org/doc/Documentat...figuration.txt
 
Old 08-26-2012, 02:31 PM   #5
Malacoda93
LQ Newbie
 
Registered: Apr 2012
Distribution: Slackware 14.0
Posts: 11

Rep: Reputation: Disabled
Seeing that this is listed as solved, but I'm having the same issue, and going and blacklisting a set of seemingly relevant drivers seems somewhat sketchy to me. Anyone have a different approach, or can reassure that wilson47's is okay?
 
Old 09-01-2012, 02:02 AM   #6
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,411

Rep: Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837
Why are you posting this when you reported that the problem was solved here? http://www.linuxquestions.org/questi...3/#post4649176
 
Old 09-01-2012, 11:37 AM   #7
Malacoda93
LQ Newbie
 
Registered: Apr 2012
Distribution: Slackware 14.0
Posts: 11

Rep: Reputation: Disabled
That was getting the audio working at all. I rarely use headphones, so I didn't bother to check the headphone jack to see if it was working.
 
Old 09-01-2012, 09:41 PM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,411

Rep: Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837
OK - Got it. You have speakers but not headphones.
After seeing this page http://wiki.debian.org/InstallingDeb...kpad/X120e/Sid you could try
Code:
echo "options snd-hda-intel index=1, model=ideapad" > /etc/modprobe.d/snd-hda-intel.conf
 
Old 09-04-2012, 08:20 PM   #9
Malacoda93
LQ Newbie
 
Registered: Apr 2012
Distribution: Slackware 14.0
Posts: 11

Rep: Reputation: Disabled
I have a thinkpad, not an ideapad, and had already tried handing it the former. Not only did it not work, it actually caused the entire alsa module to get messed up, so I had no sound at all, although deleting that section of the entry did get it back to its previous status. I tried the latter just for shits and giggles, and as I expected it made no difference, although it didn't cause the issues handing it thinkpad did.

My guess is that handing it thinkpad was for a different soundcard for a previous iteration of the computer.
 
  


Reply

Tags
alsa, audio, slackware 13.37


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Headphones don't turn speaker off Bth8 Linux - Software 4 01-24-2014 08:03 PM
Sound seems to be confused with itself. Speakers work fine, headphones are buggy. WickDaddy Ubuntu 4 08-14-2011 12:51 PM
[SOLVED] No speaker sound in Lucid - headphones work ok joham34 Linux - Newbie 3 10-04-2010 04:13 PM
HP laptop w/ hda-intel - headphones/speaker problem. ocularb0b Linux - Hardware 6 11-15-2007 12:44 PM
FC3 / AC97 - headphones and internal speaker switched Freespacer Linux - Hardware 0 01-31-2005 06:58 AM


All times are GMT -5. The time now is 09:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration