LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 07-24-2005, 12:55 PM   #1
gbergeson
LQ Newbie
 
Registered: Jul 2005
Location: Utah
Posts: 6

Rep: Reputation: 0
Angry wpa_supplicant (AGAIN)


I'm running an Asus M6800N with a 1.7 MHz Pentium M and Intel Centrino chip set. I have the IPW-2200 wireless radio. I'm currently running Fedora Core 4 (kernel 2.6.12-1.1398) as it come from Fedora all upgraded done using yum (so it's plain vanilla kernel).

When I disable the security I can get on my wireless access point and wander my network and the web.... However I want to run wpa encryption on this network (okay, call me parinoid..... but I want to). When I enable the wpa encryption on the AP I get strange errors for wpa_supplicant. For the record, the AP works correctly because the windoze boxes on the network can access it.

Here is the output of wpa_supplicant:

[root@localhost ~]# wpa_supplicant -Dipw -ieth1 -c/etc/wpa_supplicant.conf -dd
Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'ipw'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
Line: 1 - start of a new network block
ssid - hexdump_ascii(len=8):
62 65 72 67 79 6e 65 74 bergynet
proto: 0x1
key_mgmt: 0x2
PSK (ASCII passphrase) - hexdump_ascii(len=10): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 0
id=0 ssid='bergynet'
Initializing interface (2) 'eth1'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0

wpa_driver_ipw_init is called
ioctl[SIOCSIWPMKSA]: Operation not supported
Own MAC address: 00:0e:35:46:e0:0a
wpa_driver_ipw_set_wpa: enabled=1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.

wpa_driver_ipw_set_countermeasures: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_drop_unencrypted: enabled=1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Setting scan request: 0 sec 100000 usec
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)


This never, never links up with an access point. It continues to report that no suitable access point is found. I am concerned with the reports in red above. Wpa_supplicant is a build of 0.4.2 that I compiled myself because none of the rpm's I could find supported the HP "native Linux" IPW driver.

Any thoughts about why these setup commands fail? This appears to be why I cannot access my wireless network.

Thanks!!!
 
Old 07-25-2005, 09:23 AM   #2
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
I'm making some guesses based on doing things with XSupplicant, but I've not used wpa_supplicant so take this for what it's worth.

This stuff and the other errors make me think the interface never really initializes:
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED

Do you have SSID broadcast disabled on the AP? If so, turn it on.

Can you try manually bringing up the interface before running wpa_supplicant?

What's the output of iwconfig eth1?
 
Old 07-25-2005, 10:07 AM   #3
Iron_Mike74
LQ Newbie
 
Registered: Jul 2005
Location: Mesa, Az
Distribution: Fedora Core 4
Posts: 4

Rep: Reputation: 0
Quick questions,

Are you trying to run wpa_supplicant as a user or as root?????

What ipw2200 drivers and firmware do you have installed????

What does your .config and wpa_supplicant.conf look like????

Did you run "make" ?????


Mike....
 
Old 07-27-2005, 10:14 PM   #4
gbergeson
LQ Newbie
 
Registered: Jul 2005
Location: Utah
Posts: 6

Original Poster
Rep: Reputation: 0
Sorry, the real world got in the way.... Something about a kid turning 9 and thinking he should have a party......

I have just reinstalled the driver and the firmware to be sure of what I've got. I followed the instructions at http://www.ces.clemson.edu/linux/fc2-ipw2200.shtml I have IPW2200-1.0.6 and IPW2200.fw.2.3 installed. As noted before I followed the instructions at the site listed above in the notes for kernel 2.6.12-1.1398_FC4 (which is the patch level of kernel I'm running)

I'm running wpa_supplicant-0.4.3 and my .config is:
#CONFIG_DRIVER_HOSTAP=y
#CONFIG_DRIVER_HERMES=y
#CONFIG_DRIVER_MADWIFI=y
#CONFIG_DRIVER_ATMEL=y
#CONFIG_DRIVER_WEXT=y
CONFIG_DRIVER_NDISWRAPPER=y
#CONFIG_DRIVER_BROADCOM=y
CONFIG_DRIVER_IPW=y
#CONFIG_DRIVER_BSD=y
#CONFIG_DRIVER_NDIS=y
CONFIG_WIRELESS_EXTENSION=y
#CONFIG_IEEE8021X_EAPOL=y
#CONFIG_EAP_MD5=y
#CONFIG_EAP_MSCHAPV2=y
#CONFIG_EAP_TLS=y
#CONFIG_EAP_PEAP=y
#CONFIG_EAP_TTLS=y
#CONFIG_EAP_GTC=y
#CONFIG_EAP_OTP=y
#CONFIG_EAP_SIM=y
#CONFIG_EAP_AKA=y
CONFIG_EAP_PSK=y
#CONFIG_EAP_PAX=y
#CONFIG_EAP_LEAP=y
CONFIG_PCSC=y

And my wpa_supplicant.conf is:
network={
ssid="bergynet"
proto=WPA
key_mgmt=WPA-PSK
psk="MyVeryVerySecretPassPhrase"
}

Still the same error as before.
All built with make and make install (sudo)
wpa_supplicant is run a su or root (it doesn't seem to matter)
 
Old 07-28-2005, 09:32 AM   #5
Iron_Mike74
LQ Newbie
 
Registered: Jul 2005
Location: Mesa, Az
Distribution: Fedora Core 4
Posts: 4

Rep: Reputation: 0
Let's take it down to the bare minimum:


.config

DRIVER_CONFIG_IPW=y

Comment all the rest out.....


wpa_supplicant.conf

IF your router it is NOT broadcasting the SSID add this to you wpa_supplicant.conf.

AP_SCAN=2

network={
ssid="bergynet"
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
psk="MyVeryVerySecretPassPhrase"
}



Add the pairwise=TKIP, becuase you want to use TKIP.
Now hop into the router and go to wireless security and check your WPA settings, change the setting to TKIP only, not AES+TKIP. Check your passphrase, mine had a ^ symbol in it and wpa_supplicant choked until I remove. I suggest using straight ASCII characters until you get it working. No go back and run Make, copy your wpa_supplicant.conf file to the /etc directory and copy the 2 other files wpa_supplicant.sh and wpa_passphrase.sh to the recommended directory outlined in the README file.

Hope this helps, let us know what happens....

Mike....
 
Old 07-28-2005, 05:38 PM   #6
gbergeson
LQ Newbie
 
Registered: Jul 2005
Location: Utah
Posts: 6

Original Poster
Rep: Reputation: 0
Question

Okay, following your instructions I rebuilt wpa_supplicant with only the ipw active. I copied the files to /usr/local/bin as the readme suggested. I added the "pairwise=TKIP" to the wpa_supplicant.conf.

At the bottom of the console window the final message is:

WPA: Key negotiation completed with 00:11:50:04:f3:c5 [PTK=TKIP GTK=TKIP]
Cancelling authentication timeout
State: GROUP_HANDSHAKE -> COMPLETED
CTRL-EVENT-CONNECTED - Connection to 00:11:50:04:f3:c5 completed (auth)


This suggests to me that I'm connected. Is this true?????
I tried to ping the AP and failed. I tried to ping the network printer driver and it failed too.
What am I missing now??????
 
Old 07-29-2005, 10:57 AM   #7
Iron_Mike74
LQ Newbie
 
Registered: Jul 2005
Location: Mesa, Az
Distribution: Fedora Core 4
Posts: 4

Rep: Reputation: 0
Yes, that is what you are looking for. You mentioned you couldn't ping the AP, did you try opening a browser window???
About the pings, check the firewall and see if it is blocking them.


Mike....
 
Old 07-29-2005, 07:25 PM   #8
gbergeson
LQ Newbie
 
Registered: Jul 2005
Location: Utah
Posts: 6

Original Poster
Rep: Reputation: 0
Okay, now I frustrated!

I've watched it longer today. After the report from yesterday, it sits for a while and then goes through it all over again.

Meanwhile I cannot ping anything. ifup fails and I can't find anything in a browser window....... ARGGGGGG!
 
Old 08-02-2005, 07:11 PM   #9
gbergeson
LQ Newbie
 
Registered: Jul 2005
Location: Utah
Posts: 6

Original Poster
Rep: Reputation: 0
Talking

Bump to the top........
 
Old 08-02-2005, 08:54 PM   #10
gbergeson
LQ Newbie
 
Registered: Jul 2005
Location: Utah
Posts: 6

Original Poster
Rep: Reputation: 0
Talking

WooHoo!!!!!!!!!!

Okay, with some patience it works.

IronMike74 provided the path in the posts above. After that, as I reported things didn't work. Then it hit me, order matters! So I started wpa_supplicant and then went into the Network Manager tool (yes I am a GUI junky) and started eth1 (my wireless card) and it found an IP address. I can ping my network AP and printer. I can access the web and e-mail. Life appears to be good.

From there, I went to http://www.ces.clemson.edu/linux/auto_connect.shtml

I followed those instructions and now I can use Network Manager to start either the wireless network or the wired network depending on what I have. When I start the wireless, wpa_supplicant starts too. When I stop the wireless, wpa_supplicant stops too.

The final part will be when school starts later this month to enable the school networks in my wpa_supplicant.conf so that I can associate with them too.

Thanks IronMike74 for your suggestions and direction. This linux newbie is much happier now!!
 
Old 08-03-2005, 08:28 AM   #11
Iron_Mike74
LQ Newbie
 
Registered: Jul 2005
Location: Mesa, Az
Distribution: Fedora Core 4
Posts: 4

Rep: Reputation: 0
Glad to be of some help. Hopefully your school is either running a open network or just using TKIP. If it is running some other security, you will have to recompile the wpa_supplicant.conf file. One thing to remember if you do have to recompile, remove the 3 previous made files, passphrase.sh, wpa_cli.sh, and wpa_supplicant.sh. That way when you run "Make" you will see the new files created and can copy them other to the proper directory.


Mike..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wpa_supplicant settings help takky Linux - Wireless Networking 2 03-27-2005 07:20 AM
wpa_supplicant/ndiswrapper seifenblasen Linux - Laptop and Netbook 3 03-24-2005 12:40 PM
driverloader and wpa_supplicant nraponi Linux - Wireless Networking 3 01-22-2005 11:48 AM
WPA_Supplicant Fraudulent Linux - Wireless Networking 0 10-04-2004 07:07 AM
WPA_supplicant from linuxant.com crazibri Linux - Wireless Networking 1 03-24-2004 02:23 AM


All times are GMT -5. The time now is 05:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration