LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-05-2007, 12:42 AM   #1
JMC8501
LQ Newbie
 
Registered: Feb 2007
Posts: 9

Rep: Reputation: 0
Unhappy Wireless not working Ubuntu Gutsy (7.10)


Hi,

I've always had problems with wireless on my laptop in the Ubuntu OS. I've recently upgraded to Ubuntu Gutsy Gibbon, but wireless is still not working. My wireless card is not the source of the problem. This is the problem:

I've never been able to get Network Manager to work. Neither the applet nor in terminal have ever gotten me results. However, the applet under the name "Network-Monitor" has always been around. This, I believe, is linked to "Network" under System->Administrator->Network. Sometimes this will show wireless networks, other times it will not, but there is no clear way to update which networks it sees, etc... Yet, using this I am able to connect to some wireless network, but only the unprotected kind.

I tried installing other programs, most recently the much hailed "WICD," but this was also a disappointment. The applet also failed to work, and when I tried to connect to a network with WPA security, it absolutely failed to connect.

Please help me as I am new to Linux and am in need of guidance.
 
Old 11-05-2007, 02:40 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
When something like this is not working, it is much easier for us to help you if you are using the command line rather than the GUI. So, for a start, please open a terminal and post the output of these commands:

sudo iwlist scanning
cat /etc/network/interfaces
ifconfig
 
Old 11-07-2007, 10:55 PM   #3
JMC8501
LQ Newbie
 
Registered: Feb 2007
Posts: 9

Original Poster
Rep: Reputation: 0
ok, here is what I get with "sudo iwlsit scanning":

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Scan completed :
Cell 01 - Address: 00:17:3F:45:17:56
ESSID:"Wireless Home"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=95/100 Signal level=-48 dBm Noise level=-68 dBm
IE: WPA Version 1
Group Cipher : WEP-40
Pairwise Ciphers (1) : WEP-40
Authentication Suites (1) : PSK
Extra: Last beacon: 164ms ago
Cell 02 - Address: 00:14:6C:FF:00:74
ESSID:"Johnson Family"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=77/100 Signal level=-75 dBm Noise level=-64 dBm
IE: WPA Version 1
Group Cipher : WEP-40
Pairwise Ciphers (1) : WEP-40
Authentication Suites (1) : PSK
Extra: Last beacon: 612ms ago
Cell 03 - Address: 00:14:BF:38:EE:CB
ESSID:"george"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=72/100 Signal level=-82 dBm Noise level=-70 dBm
Extra: Last beacon: 1400ms ago

Then for "cat /etc/network/interfaces":

auto lo
iface lo inet loopback


auto eth2
#iface eth2 inet dhcp

auto ath0
#iface ath0 inet dhcp

auto wlan0
#iface wlan0 inet dhcp




iface dsl-provider inet ppp
provider dsl-provider












iface eth0 inet dhcp
address 150.108.***.***
netmask 255.255.***.***
gateway 150.108.***.***






iface eth1 inet dhcp
wireless-essid Building A







auto eth0

auto eth1


Finally for "ifconfig":

eth0 Link encap:Ethernet HWaddr 00:19:B9:57:8C:5B
inet addr:192.168.2.2 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::219:b9ff:fe57:8c5b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:41020 errors:0 dropped:0 overruns:0 frame:0
TX packets:36160 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:39959297 (38.1 MB) TX bytes:7791592 (7.4 MB)
Interrupt:22

eth1 Link encap:Ethernet HWaddr 00:19:7D:79B:1D
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:190 overruns:0 frame:0
TX packets:130 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:6500 (6.3 KB)
Interrupt:5

eth1:avah Link encap:Ethernet HWaddr 00:19:7D:79B:1D
inet addr:169.254.6.124 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
Interrupt:5

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:17 errors:0 dropped:0 overruns:0 frame:0
TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:888 (888.0 b) TX bytes:888 (888.0 b)

I'm not sure what the "eth1:avaih" is, but whevever I select it from the Network Monitor applet, it gives me a message that the interface does not exist. I think it first appeared as an option in the Network Monitor applet (and thus in the "Network" option from System->Administrator->Network) when I tried to install WICD, a program I saw around a number of forums that was supposed to solve my internet problems.

Any help would be greatly appreciated.
 
Old 11-08-2007, 05:09 AM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Your wireless interface is seeing 3 Access Points:
ESSID:"Wireless Home"
ESSID:"Johnson Family" and
ESSID:"george"

Which one of these is yours? (Note that as a general principle, it is better to have ESSIDs without spaces in the name eg Johnson_Family)

eth0 is up and running with an IP address of 192.168.2.2 Presumably this is your wired ethernet connection. You have downloaded 38MB via this interface.

Are you trying to have both an ethernet and a wireless connection at the same time? (I do not know how to configure this situation)

/etc/network/interfaces shows that you are trying to establish a wireless connection with "Building A", but this is not one of the three access points your card can see, and in any case, you have not entered any encryption information.

All in all, this is a mess But this link will help you sort it out:
http://www.linuxhomenetworking.com/w...ess_Networking

When you read that document, where it refers to "Debian", it is also referring to (k)ubuntu, as that is based on Debian. Basically, you need to sort out the /etc/network/interfaces file and then bring up your wireless interface, either by rebooting (if you have set eth1 to auto) or sudo ifup eth1
 
Old 11-10-2007, 12:30 AM   #5
JMC8501
LQ Newbie
 
Registered: Feb 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks, tredegar, the link was very helpful (and indeed the website is chuck-full of information). However, for this specific problem, I followed the directions to connect to the wireless network, but to no avail. It would show me connected, sending but not receiving (although it would show the signal strength through "Network-admin.") However, my original question was concerning the Network manager program with supposedly took care of this automatically. As I explained before, I can't even get the program to run in the conventional sense. I tried re-installing, etc.. through the synaptic package Manager, and through the terminal, but this still did not fix the problem. Any Ideas on this front?

PS: I am not looking to connect to through both wired and wireless connections (what would be the point?)- I just need to be online to download stuff and to search through forums for helpful advice!

Last edited by JMC8501; 11-10-2007 at 12:34 AM.
 
Old 11-10-2007, 04:48 AM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
You really haven't given me any useful information, or answered my questions
Quote:
Your wireless interface is seeing 3 Access Points:
ESSID:"Wireless Home"
ESSID:"Johnson Family" and
ESSID:"george"

Which one of these is yours?
Quote:
/etc/network/interfaces shows that you are trying to establish a wireless connection with "Building A"
What is ""Building A"? Such a wireless AP does not exist within range.
Quote:
the Network manager program with supposedly took care of this automatically
As I said before, when things are not working then go back to the command line, and edit the interfaces file until it works. Telling me "I can't even get the network manager to run in the conventional sense" tells me nothing. What "Network Manager"? What do you mean you cannot get it to run "in the conventional sense"? It either runs or it does not. Perhaps it gives error messages? If the GUI (Network manager) isn't working for you, then do not use it.

The relevant part of my interfaces file looks like this:
Code:
# eth1 is my wireless interface
# I want it brought up at boot
auto eth1
# I also want a static address of 10.0.0.8
iface eth1 inet static
broadcast 10.0.0.255
address 10.0.0.8
netmask 255.255.255.0
# This is the IP address of my AP
gateway 10.0.0.2
# This is my security, the AP is using WPA
wpa-passphrase itsasecret
# This is the name of my wireless AP
wpa-ssid MyWiress
# And it is using channel 11
wireless-channel 11
If you were to post your /etc/network/interfaces file (without all the blank lines please) and all the details for your wireless AP [ESSID, LAN IP address, encryption details (Relax, nobody knows where you live, and you can always change it when you have it working), channel, security mode etc], then maybe I could make some sense of it.
 
Old 11-10-2007, 10:40 PM   #7
JMC8501
LQ Newbie
 
Registered: Feb 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Yeah, sorry about that!

My Wireless is "Wireless Home"; "Building A" refers to the wireless of a building on my university campus, but I never put it on this list, I'm not sure how it got there. Sorry about the blank lines in the /etc/network/interfaces file, but I just copied and pasted what was there.

Here is the /etc/network/interfaces file:

auto lo
iface lo inet loopback
auto eth2
#iface eth2 inet dhcp
auto ath0
#iface ath0 inet dhcp
auto wlan0
#iface wlan0 inet dhcp
iface dsl-provider inet ppp
provider dsl-provider
iface eth0 inet dhcp
address 150.108.80.126
netmask 255.255.225.0
gateway 150.108.80.1
iface eth1 inet dhcp
wireless-essid Building A
auto eth0
auto eth1

A few other points: the IP address, netmask, etc. listed in /etc/network/interfaces are from my university, although right now I'm at home using the "192.168.2.2" which is what came up when I typed "iwconfig" in the terminal. I'm guessing this would be the LAN IP address for my wireless. As I mentioned, the ESSID is "Wireless Home" and the encryption is WPA type. I'm also guessing the wpa-ssid is the same as the essid. The wpa-passphrase is password123. I think the channel is 6.

Thanks for all your help.


PS: When I mention the network manager, I meant that it doesn't show up as a applet, even though it should run automatically since it is enabled as one of my startup programs. When I try to run "nm" in terminal, it says

nm: 'a.out': No such file

When I try "nm-tools" it says:

NetworkManager Tool

State: connected

print_devices(): didn't get a reply from NetworkManager.

If I try "nm-applet" it just prints a blank line until I manually stop it by ctrl+z.
 
Old 11-11-2007, 03:35 AM   #8
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Your interfaces file is a mess.
Try replacing it with this:
Code:
# lo is the loopback interface. You need this
auto lo
iface lo inet loopback

# eth0 is your ethernet cable interface
# we want to use the wireless connection,
# so do not try to bring up eth0 at boot
# so the next line is commented out
#auto eth0
iface eth0 inet dhcp

# eth1 is your wireless interface
# we want it to come up at boot
auto eth1
iface eth1 inet dhcp
wpa-passphrase password123
wpa-ssid "Wireless Home"
wireless-channel 6
Make sure eth0 is not being used:
sudo ifdown eth0
Then restart eth1 like this:
sudo ifdown eth1
sudo ifup eth1

Wait a moment for the connection to be authenticated.
You should be connected

To find the address of your router, read the manual.
It is probably 192.168.2.1, but you may have changed it.
You should be able to connect to its setup page with http://IP.NUMBER.OF.ROUTER

I do not want to hear any more about "Network Manager", which does not seem to be working
 
Old 11-11-2007, 09:17 PM   #9
JMC8501
LQ Newbie
 
Registered: Feb 2007
Posts: 9

Original Poster
Rep: Reputation: 0
This worked perfectly, Thanks!
 
Old 11-22-2007, 01:44 AM   #10
pvincent
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Rep: Reputation: 0
interfaces ok, knetworkmanager fails

I follow your advice consisting of editing the /etc/network/interfaces and appending the WEP/WPA key besides the essid.

Manually, i can ifdown, ifup eth1 successfully.
So, wireless is working fine.

However, the GUI interface knetworkmanager does not work the same way. I've also tried on ubuntu 7.10 trhough nm-applet and it does not work neither.
As with GUI interface, WEP/WPA keys are stored separetly, that allow dynamic connection to various wifi spot without editing files and it is supposed to be secure.

At this point, I connect to my own access point like a charm. Although I may miss the GUI interface when travelling, I would like to understand how to reinitalise either nm-applet or knetworkmanager without rebooting.
I did not point out that after rebooting GUI interfaces restart working properly.

thank you for any suggestion.
 
Old 03-09-2008, 06:42 PM   #11
koelemay
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Rep: Reputation: 0
Also relatively new to Linux and can't seem to get wireless to work

I am just have a heck of a time getting my wireless to work in Gutsy. I tried "copying" the instructions on this post but did not have any luck. Any help would be greatly appreciated. I will take the recommendation posted and post the output for the following lines below. Also note that y SSID is "hidden"--is that a problem for Ubuntu?

"sudo iwlist scanning"

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Scan completed :
Cell 01 - Address: 00:19:7E:4D:78:4E
ESSID:"53df"
Protocol:IEEE 802.11bg
Mode:Master
Channel:1
Frequency:2.412 GHz (Channel 1)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=70/100
Extra: Last beacon: 344ms ago
Cell 02 - Address: 00:1C:10:0E:28:68
ESSID:"Park Avenue 4"
Protocol:IEEE 802.11bg
Mode:Master
Channel:3
Frequency:2.422 GHz (Channel 3)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=23/100
IE: WPA Version 1
Group Cipher : WEP-40
Pairwise Ciphers (1) : WEP-40
Authentication Suites (1) : PSK
Extra: Last beacon: 284ms ago
Cell 03 - Address: 00:13:10:9F:37:7C
ESSID:"PuttyIs#1"
Protocol:IEEE 802.11g
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=29/100
IE: WPA Version 1
Group Cipher : WEP-40
Pairwise Ciphers (1) : WEP-40
Authentication Suites (1) : PSK
Extra: Last beacon: 192ms ago
Cell 04 - Address: 00:11:95:74:97:A0
ESSID:"riley"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 9 Mb/s; 11 Mb/s
6 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=17/100
Extra: Last beacon: 216ms ago
Cell 05 - Address: 00:12:17:E2:493
ESSID:"Melissalinksys"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=11/100
IE: WPA Version 1
Group Cipher : WEP-40
Pairwise Ciphers (1) : WEP-40
Authentication Suites (1) : PSK
Extra: Last beacon: 220ms ago
Cell 06 - Address: 00:11:50:CF:F8:4C
ESSID:"<hidden>"
Protocol:IEEE 802.11g
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=100/100
IE: WPA Version 1
Group Cipher : WEP-40
Pairwise Ciphers (1) : WEP-40
Authentication Suites (1) : PSK
Extra: Last beacon: 88ms ago
Cell 07 - Address: 00:19:7E:57:4D:54
ESSID:"c9f6"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=11/100
Extra: Last beacon: 100ms ago
Cell 08 - Address: 00:13:46:49:E8:90
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 9 Mb/s; 11 Mb/s
6 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=35/100
Extra: Last beacon: 228ms ago


"cat /etc/network/interfaces"

auto lo
iface lo inet loopback

#auto eth0
iface etho0 inet dhcp

auto eth1
iface eth1 inet dhcp
wpa-passphrase mypassword
wpa-ssid myssid
wireless-channel 11


and last, "ifconfig"

eth0 Link encap:Ethernet HWaddr 00:0D:9D:45:AB:A2
inet addr:192.168.2.4 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::20d:9dff:fe45:aba2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1184 errors:0 dropped:0 overruns:0 frame:0
TX packets:1050 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1070925 (1.0 MB) TX bytes:188960 (184.5 KB)
Interrupt:10 Base address:0xe000

eth1 Link encap:Ethernet HWaddr 00:18:6E:35:FD:51
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:421 dropped:1 overruns:0 frame:419
TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:924 (924.0 b)

eth1:avah Link encap:Ethernet HWaddr 00:18:6E:35:FD:51
inet addr:169.254.7.29 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1037 (1.0 KB) TX bytes:1037 (1.0 KB)


If anybody is able to help I would appreciate it so much. Thanks!

-Mike
 
Old 03-10-2008, 03:16 AM   #12
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Welcome to LQ!

Several things in your configuration look strange:

I do not know which of these two "hidden" WAP's is yours, although cell 06 looks to be a stronger signal:
Code:
Cell 06 - Address: 00:11:50:CF:F8:4C
ESSID:"<hidden>"
Protocol:IEEE 802.11g
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Encryption key:On
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=100/100 
IE: WPA Version 1
Group Cipher : WEP-40
Pairwise Ciphers (1) : WEP-40
Authentication Suites (1) : PSK
Extra: Last beacon: 88ms ago

Cell 08 - Address: 00:13:46:49:E8:90
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Encryption key:On
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 9 Mb/s; 11 Mb/s
6 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=35/100 
Extra: Last beacon: 228ms ago
If cell 08 is yours, it is using channel 6, and you have your /etc/network/interfaces set for eth1 to use channel 11. Maybe you need to correct this?

If cell 06 is yours, try unhiding your ESSID - you really don't need to hide as you are encrypted with WPA, which, unlike WEP, is currently considered to be secure.

ifconfig says eth1:avah is up, with an address of 169.254.7.29 That is not (AFAIK) a LAN IP address.

Your listing of your /etc/network/interfaces makes no reference to eth1:avah Did you post the whole file? Have you been using nasty-GUIs (which generally seem to mess things up by adding rubbish to that file)?

One last point: eth0 is also connected and working (perhaps to enable you to make this post?). Don't try to have both a cabled connection and a wireless one. Use one or the other.

I'd start by:
- unplugging eth0
- checking the file /etc/network/interfaces again (eg remove any references to eth1:avah, check the channel)
- unhiding my ESSID

Hope this helps.
 
Old 03-15-2008, 11:47 AM   #13
koelemay
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Rep: Reputation: 0
It works now!

tredegar, thanks you very much. Unhiding the ESSID and unplugging eth0 seems to have worked for the most part. I also had to reconfigure firestarter to work for eth1 instead of eth0 (which may be obvious to most people but I wouldn't have thought of it right away).

One more thing. Everytime I reboot, it seems to connect to eth1:avah and the internet doesn't work. If I "sudo ifdown eth1" and then "sudo ifup eth1" then it works fine, but should I have to do this every time I boot??

Thank you for your help!

-Mike K
 
Old 03-15-2008, 03:13 PM   #14
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Quote:
One more thing. Everytime I reboot, it seems to connect to eth1:avah and the internet doesn't work. If I "sudo ifdown eth1" and then "sudo ifup eth1" then it works fine, but should I have to do this every time I boot??
You are making progress, good

Please post the output of cat /etc/network/interfaces and ifconfig after you have booted, and not done anything else.
That way we can see what is being configured by default, and help you change it where necessary.
 
Old 03-18-2008, 05:36 PM   #15
koelemay
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Rep: Reputation: 0
Hi tredegar,

Thank you for all your help. Below is the info you requested--like I said previously, when I boot it doesn't work, but after "ifdown eth1" followed by "ifup eth1" it works just fine.

Output of cat /etc/network/interfaces:

auto lo
iface lo inet loopback

#auto eth0
iface etho0 inet dhcp

auto eth1
iface eth1 inet dhcp
wpa-passphrase [mypassword]
wpa-ssid [myssid]
wireless-channel 11


Output of ifconfig:

eth0 Link encap:Ethernet HWaddr 00:0D:9D:45:AB:A2
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:10 Base address:0xa000

eth1 Link encap:Ethernet HWaddr 00:18:6E:35:FD:51
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:94 dropped:0 overruns:0 frame:94
TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:462 (462.0 b)

eth1:avah Link encap:Ethernet HWaddr 00:18:6E:35:FD:51
inet addr:169.254.7.29 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:352 (352.0 b) TX bytes:352 (352.0 b)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Upgrade Ubuntu 7.04 (Feisty Fawn) to Ubuntu 7.10 (Gutsy Gibbon) LXer Syndicated Linux News 1 03-28-2009 01:17 PM
LXer: The Perfect Server - Ubuntu Gutsy Gibbon (Ubuntu 7.10) LXer Syndicated Linux News 0 10-21-2007 11:20 AM
LXer: Ubuntu Gutsy Wireless Help LXer Syndicated Linux News 0 10-19-2007 08:10 AM
sleep and hibernate not working on ThinkPad T60 with Ubuntu 7.10 (Gutsy Gibbon) CharlieBucket Linux - Laptop and Netbook 4 10-10-2007 08:18 AM
LXer: Ubuntu 7.10 (Gutsy Gibbon) Release Dates and Mark Shuttleworth About Gutsy LXer Syndicated Linux News 0 04-12-2007 04:31 PM


All times are GMT -5. The time now is 11:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration