LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 05-12-2008, 04:33 AM   #1
Su-Shee
Member
 
Registered: Sep 2007
Location: Berlin
Distribution: Slackware
Posts: 509

Rep: Reputation: 41
Wifi gets disabled according to X suspend (possible ACPI prob?)


I'm running Slackware 12 on a Thinkpad T61 with a 2.6.24.4 kernel which already has drivers for the Intel wifi card included and supports certain IBM Thinkpad powermanagement extras ("Thinkpad Extras 0.17"). I enabled everything related to Thinkpad/ACPI/Intel Wifi. As the T61's got the Nividia graphics chip, I use the driver of Nvidia itself.

I didn't configure much ACPI stuff but putting a standard acpi-handler script into /etc/acpi/ which essentially just grabs any event and logs it.

Everything runs just fine despite one very annoying thing: Wifi gets disabled after my configured X inactivity no matter how much network traffic there actually is. The disabling of wifi corresponds with the standby/suspend time outs I set in my xorg.conf.

I checked in the logs of acpid, syslog, messages - no event, no message of anything disabling wifi for power saving purposes or something like that.

What I don't get: WTH is even the connection between X inactivity and wifi? I can see an ACPI-related message in the X log ("(II) Open ACPI successful (/var/run/acpid.socket)"), but why does X even meddle with my network connections?

Maybe I'm just overlooking something really simple...then please enlighten me.
 
Old 05-14-2008, 01:28 PM   #2
biophysics
Member
 
Registered: Jan 2002
Location: Germany
Distribution: Kubuntu
Posts: 444

Rep: Reputation: 30
Are you using USB wireless dongle ?

Alternatively, change in xorg.conf dpms to off (but you can configure it in gnome-power-manager or similar thing in KDE
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
acpi, usb, and irq disabled sonicbuddha Linux - General 1 01-03-2006 12:30 AM
ACPI disabled because bios is from 99 and too old laurahlane Linux - Newbie 2 06-04-2005 09:32 PM
Software suspend and GRUB - swsusp disabled adriaanbw Linux - Software 2 01-17-2005 05:35 PM


All times are GMT -5. The time now is 08:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration