LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 01-09-2009, 07:38 AM   #1
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Rep: Reputation: 25
wifi, eeepc 900,debian lenny


Hi Guys,

I am coming to you Guys to try to have a better understanding of networking in Debian.
I have installed Debian Lenny and eeepc 900 and I have to say that everything works well. I am just having trouble understanding how the wireless is handled in debian lenny.
I have installed as suggested in many posts the madwifi driver for my atheros wifi card

lsmod | grep ath --> ath_pci 202712 0
ath_rate_sample 11104 0
wlan 194000 4 ath_pci, wlan_wep, wlan_scan_sta, ath_rate_sample
ath_hal 300768 2 ath_pci, ath_rate_sample

the wifi works, but one of the symptom that I have noticed is that it never actually displays wpa/wpa2 protocol.
I only get WEP (ASCII)/Hexadecimal. Now, I know that I am not really understanding how this should be working, nevertheless, I have installed WPA supplicant but still I get no signs of the WPA protocols in my network preferences. I suppose that is why my wifi connection is not working....
I would really appreciate if someone with more knowledge than me could shed some light on this ?
Finally, when I have a look at /etc/network/interfaces I see all my wifi connections are written there. I do travel a lot and when I activate the wifi card it automatically reverts back to the old wifi connection that I may have had. Isn't there a way that it could automatically search for new wifi connection and may be not write all the wifi connection in /etc/network/interfaces ? I do travel a lot I get a file that fattens really fast. Most of all, when it reverts back to the old wifi connection since most of time I am not in the hotspot anymore, it won't find it.

Thank you very much for all your help

Riganta
 
Old 01-09-2009, 08:01 AM   #2
PresGas
Member
 
Registered: Jul 2008
Location: Bloomington, IN
Distribution: Ubuntu/Debian
Posts: 51
Blog Entries: 5

Rep: Reputation: 18
Real quick counter question for you. What do you use to connect to the wireless networks? Are you using Network Manager? For mobile platforms, I highly recommend it.
 
Old 01-09-2009, 08:14 AM   #3
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Original Poster
Rep: Reputation: 25
Quote:
Originally Posted by PresGas View Post
Real quick counter question for you. What do you use to connect to the wireless networks? Are you using Network Manager? For mobile platforms, I highly recommend it.
Yes I am using network manager
 
Old 01-09-2009, 08:31 AM   #4
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
Take a look at http://wiki.debian.org/DebianEeePC/HowTo/Wifi
 
Old 01-09-2009, 08:37 AM   #5
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
I've never been a fan of Network-Manager, I've found wicd to be a better network configuration applet imho..

For WPA to work you must select the wext driver in your WPA configuration with the Atheros cards. This is simple to do in wicd.

I have my Acer AspireOne running Debian Lenny with the Atheros ar5007 wireless, running WPA2, and it works like a charm.




Could just be because I'm running the Updated Madwifi drivers though..
Quote:
A little note about WiFi and network-manager: It has been observed that network-manager does not work properly with the updated MadWiFi driver (incompatible hal, perhaps). You may need to configure the WLAN (e.g. ESSID, WEP/WPA) manually. Alternatively, wicd is performing beautifully for me. First remove network-manager, then add the following to /etc/apt/sources.list
Code:
deb http://apt.wicd.net lenny extras
then get the key:
Code:
wget -q http://apt.wicd.net/wicd.gpg -O- | sudo apt-key add -
then aptitude update, aptitude install wicd. See here for more info: http://wicd.sourceforge.net/download.php



http://wiki.debian.org/DebianEeePC/Model/900
http://wiki.debian.org/DebianEeePC/H...AtherosModules

WPA Workaround for the EEEPC
http://wiki.debian.org/DebianEeePC/B...f99812ba6339fb
 
Old 01-09-2009, 01:51 PM   #6
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Original Poster
Rep: Reputation: 25
Quote:
Originally Posted by craigevil View Post
I have actually configured my network interfaces the way explained in the link: but I still have a question. since i do not know the type of protocols used on the wifi network. I know that it is just wpa but do not know if it is wpa 2 or even PSK / EAP or whatnot
How would I get around this ? How would I configure my wifi card to connect directly to any wifi network and feed me back the type of wifi network. Then I would just enter the pass-phrase or hex key

Thank you all for your response

Riganta
 
Old 01-09-2009, 03:36 PM   #7
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
As far as I know you need to get that info from the person running the WAP. or log into the router and get the settings.
If someone is going to provide you with the PSK or whatever you need to connect they should be able to provide the rest of the information as well.

http://hostap.epitest.fi/wpa_supplicant/

Not sure if wpa_cli would be able to show you any of that configuration info or not..
http://linux.die.net/man/8/wpa_cli
 
Old 01-11-2009, 02:09 PM   #8
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Original Poster
Rep: Reputation: 25
Quote:
Originally Posted by farslayer View Post
As far as I know you need to get that info from the person running the WAP. or log into the router and get the settings.
If someone is going to provide you with the PSK or whatever you need to connect they should be able to provide the rest of the information as well.

http://hostap.epitest.fi/wpa_supplicant/

Not sure if wpa_cli would be able to show you any of that configuration info or not..
http://linux.die.net/man/8/wpa_cli
I understand that I should be provided with all the settings to connect to the wifi network, but I suppose my point in not there really. I am sorry, but I am kind of a new guy on linux.
I have a laptop that runs leopard Mac OS X, a Nokia N95 8G, and and i Phone that connects fine to the network. They all never asked me for the type of protocol used on the network and they all connected to the network and when input the password. Now, if I understood right, and following http://wiki.debian.org/DebianEeePC/HowTo/Wifi :"Everything single time, I would need to provide my eeepc with the type of protocol used to configure my wifi network ?" is it how linux networking works ? or may be more so network manager ?
I have followed step by step the tutorial in the link above and I still cannot connect to my wifi network.
I have configured my /etc/network/interfaces following the how to above as followed
# The loopback network interface
auto lo
iface lo inet loopback
# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
allow-hotplug ath0
iface ath0 inet manual
wpa-driver wext
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

any correction is much appreciated

in my wpa_supplicant.conf file

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=netdev
ap_scan=1
fast_reauth=1
eapol_version=1
network={
ssid="Airport Network"
psk=0123456789abcdef (dont really know if I have to put that or the password. I tried the password but didn't work out. Plus, I dont know the type of protocol used)
id_str="cafe"
scan_ssid=1 (not broadcasting so I thought that would help)
priority=5 (haven't got a clue what that does )
}

network={
key_mgnt=NONE (I added that line for any additional network that would be using WEP or NONE
}

Again, if you think that I need correction here, feel free to correct me.

Then I rebooted but no connection whatsoever. I opened up "network manager" and I don't even have the wpa_supplicant driver there. Only WEP.

I then opened up my logs in /var/log/ and there I found an interesting log which I do not comprehend

wpa_action.ath0.log -->

I have got my dhcpack from my airport network. so yes I should normally be connected with an IP address 17.64.214.247 but I have got no internet connection at all. Wouldn't my network manager showing me that connection ? Please help because I don't really what is happening here. Everything seems to be telling me that I am connected but I do not have access to internet not can I get my emails.

bssdid=xx:xx:xx
ssid=Aiport Network
id=0
id_str=Cafe
pairwise_cipher=CCMP
group_cipher=CCMP
key_mgmt=WPA2-PSK (very interesting. I finally got my answer there)
wpa_state=COMPLETED
ip_address=17.64.214.247 ( does that mean that I am connected ?)

##################################################################

when I run ifconfig I can see that ath0 hasnt got any ip address at all
I see as well wifi0 with no ip address. Is wifi0 a replicant of ath0 ?

Again, thank you all for your help

Riganta

Last edited by riganta; 01-11-2009 at 02:11 PM. Reason: clarity
 
Old 01-11-2009, 10:32 PM   #9
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Whew looks way overly complicated to me..

I ditched Network-manager since it's never worked properly for me. then I installed wicd. http://wicd.sourceforge.net/
I did all my wireless configuration through Wicd and can setup multiple wireless profiles and also configure it to connect automatically to one of them on boot up. all with a simple gui and a couple check boxes.

My WAP is running WPA2-PSK AES

The atheros wireless cards in Linux need to run the WPA_Supplicant driver wext to properly authenticate, this is a option in your configuration, and was simple to select in wicd for my wireless card..

I have also seen postings about the Airports being difficult to connect to from OS's other than OS X.
http://www.symphonious.net/2005/12/1...rport-and-you/
http://support.apple.com/kb/HT1790


Hope that helps...
 
Old 01-12-2009, 04:11 AM   #10
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Original Poster
Rep: Reputation: 25
I have to thank you all for your support. I couldn't have done without you guys. I finally managed to get it running. Don't really know why because between yesterday and today, I didn't do anything different.
I know have a network manager that is a lot better looking. When I am not wired up, network manager actually shows up with all the available wifi network. So i got connected to the Airport Network that was troubling me for the past two days without any problem. I went to a friend's house and could connect to his wifi network using WEP. Again, I haven't got a clue as to what has changed between yesterday and today...
I still am puzzled though. By entering the network in /etc/network/interfaces, wouldn't I be connected automatically ? because I have to manually select the networks and retype the password(s).
Again, you guys are great and a thousand thanks.

Riganta

Last edited by riganta; 01-12-2009 at 04:34 AM. Reason: clarity
 
Old 01-12-2009, 09:21 AM   #11
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
No, if you manually configure a network interface in /etc/network/interfaces, network-manager ignores that interface and doesn't display anything for it. That's one of the things that annoys me about network-manager. Since you tried to manually configure your atheros card in the config file network-manager was pretending it didn't exist.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Lenny AMD64 Intel IWL4965 WiFi WolfCub Linux - Wireless Networking 9 02-25-2009 07:03 AM
debian on Asus EEEPC cccc Debian 6 10-26-2008 01:04 PM
LXer: 9-inch EeePC named EeePC 900 and gets detailed specs LXer Syndicated Linux News 1 03-11-2008 07:11 AM
LXer: Debian-eeepc: the little next big thing LXer Syndicated Linux News 0 11-11-2007 01:30 AM


All times are GMT -5. The time now is 12:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration