LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 07-02-2012, 05:23 PM   #1
pouldney
LQ Newbie
 
Registered: Oct 2011
Posts: 14

Rep: Reputation: Disabled
Wi-Fi stops working occasionally


My Wi-Fi stops working occasionally ,usually when downloading lots of data such
as when viewing a video.
The only way to get it back up is to Re-Boot
I have an Acer Aspire 1551-3671 with Ubuntu 12.04 (Precise Pangolin)



Here is some data on the problem
Note that phy0 is Hard Blocked


george@george-Aspire-1551:~$ sudo rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no

george@george-Aspire-1551:~$ iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: C0:83:0AF:79:E9
Channel:9
Frequency:2.452 GHz (Channel 9)
Quality=48/70 Signal level=-62 dBm
Encryption keyn
ESSID:"2WIRE263"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=000000872e55e181
Extra: Last beacon: 19760ms ago
IE: Unknown: 00083257495245323633
IE: Unknown: 010882848B0C12961824
IE: Unknown: 030109
IE: Unknown: 0706434120010B1B
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: 2A0100
IE: Unknown: 32043048606C

lspci -v
06:00.0 Network controller: Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
Subsystem: Foxconn International, Inc. Device e034
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at d0300000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: ath9k
Kernel modules: ath9k
 
Old 07-06-2012, 02:36 PM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,195

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
That's enough signal and a reasonably reliable driver. It could be your isp. Investigate when you lose it and see what you lose,

I would try changing the channel to 13 or something in case some dweeb is using the same channel as you.
 
Old 07-08-2012, 12:18 PM   #3
Meneley
LQ Newbie
 
Registered: Jul 2012
Posts: 9

Rep: Reputation: 0
Did you check if there is any packet loss. If you find any packet loss happening then its your ISP problem.
To check the packet loss, try to connect LAN cable and verify instead of checking from Wifi mode.

Thanks
Wall stickers
 
Old 02-21-2014, 10:57 AM   #4
pouldney
LQ Newbie
 
Registered: Oct 2011
Posts: 14

Original Poster
Rep: Reputation: Disabled
Finally found the trouble

Finally found the trouble

Two modules were loading

Before sudo rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no

Had to edit ect\modprobe\blacklist.conf
Add acer_wmi

now ~$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

This seems to fix it
 
  


Reply

Tags
wi-fi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Feisty - Sound was working, but mysteriously stops working after reboot. woodsy934 Linux - Software 7 07-04-2011 06:39 PM
__attribute__ ((weak)) suddenly stops working / starts working ta0kira Programming 3 08-15-2007 11:31 AM
"USB device stops working after a time" 'fix' stops cdrom device mount/readability adamben Slackware 6 04-18-2007 01:18 PM
Hotplug stops working Javasnob Linux - Hardware 5 01-03-2007 01:05 PM


All times are GMT -5. The time now is 12:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration