LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 07-22-2007, 11:42 AM   #1
Hewson
Member
 
Registered: Feb 2007
Location: /home
Distribution: Kubuntu and CentOS
Posts: 214

Rep: Reputation: 32
Angry wg511t WLAN card and FC7


Just spun up FC7 on my home laptop, and as I feared the only thing that got hungup is my cardbus netgear wg511t wireless lan adapter. I have no previous experience installing/configuring wlan stuff on linux, so I'm in the dark to some degree.

So far I have installed madwifi (http://atrpms.net/dist/f7/madwifi/) and added an interface description for ath0 (filename: ifcfg-ath0) into the /etc/sysconfig/network-scripts directory.

Where do I go from here? Any help would be appreciated.

thanks.

-s

Last edited by Hewson; 07-22-2007 at 11:44 AM.
 
Old 07-22-2007, 11:55 AM   #2
Hewson
Member
 
Registered: Feb 2007
Location: /home
Distribution: Kubuntu and CentOS
Posts: 214

Original Poster
Rep: Reputation: 32
Ok. According to http://madwifi.org/wiki/UserDocs/FirstTimeHowTo After installing I have to add a kernel module.

Code:
modprobe ath_pci
when i try the above my system complained:
Code:
FATAL: Error inserting ath_pci (/lib/modules/2.6.22.1-27.fc7/updates/net/ath_pci.ko): Unknown symbol in module, or unknown parameter (see dmesg)
i checked /var/log/dmesg. Nothing related to my attempted kernel mod. Am I using the right mod? is there a different one for pcma/cardbus than the 'ath_pci'?
 
Old 07-22-2007, 12:05 PM   #3
Hewson
Member
 
Registered: Feb 2007
Location: /home
Distribution: Kubuntu and CentOS
Posts: 214

Original Poster
Rep: Reputation: 32
dmesg didn't have anything but /var/log/messages did.

Code:
Jul 22 09:47:59 localhost kernel: ath_pci: Unknown symbol _ath_hal_attach
Jul 22 09:47:59 localhost kernel: ath_pci: Unknown symbol ath_hal_process_noisefloor
Jul 22 09:47:59 localhost kernel: ath_pci: Unknown symbol ath_hal_computetxtime
Jul 22 09:47:59 localhost kernel: ath_pci: Unknown symbol ath_hal_mhz2ieee
Jul 22 09:47:59 localhost kernel: ath_pci: Unknown symbol _ath_hal_detach
Jul 22 09:47:59 localhost kernel: ath_pci: Unknown symbol ath_hal_probe
Jul 22 09:47:59 localhost kernel: ath_pci: Unknown symbol ath_hal_init_channels
Jul 22 09:47:59 localhost kernel: ath_pci: Unknown symbol ath_hal_getwirelessmodes
 
Old 07-22-2007, 01:10 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Which rpms did you install. Post output from this command.
rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}\n" kernel 'madwifi' | sort

Brian
 
Old 07-23-2007, 02:00 AM   #5
Hewson
Member
 
Registered: Feb 2007
Location: /home
Distribution: Kubuntu and CentOS
Posts: 214

Original Poster
Rep: Reputation: 32
Brian thanks for the reply.

I ended up getting it working.

1. Did a full wipe and reinstall.
2. then "yum update"
3. then I added ATrpms to /etc/yum.conf
Code:
 [atrpms]
name=Fedora Core $releasever - $basearch - ATrpms
baseurl=http://dl.atrpms.net/f$releasever-$basearch/atrpms/stable
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms
gpgcheck=1
4. then "yum install madwifi madwifi-kmdl-`uname -r`"

-s
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Netgear WG511T Rangemax Card JM11 Linux - Wireless Networking 1 03-03-2007 12:47 PM
Using Netgear WG511T PC-Card with Slackware Linux Dngrsone Slackware 3 10-25-2006 06:21 PM
WG511T network card help alanalover89 Linux - Hardware 2 05-04-2005 08:41 PM
Dell wireless WLAN 1450 Dual Band WLAN Mini-PCI card not recognised pitts68 Linux - Wireless Networking 102 02-28-2005 07:21 AM
Trouble with wireless card WG511T luth Linux - Hardware 0 10-25-2004 02:21 AM


All times are GMT -5. The time now is 10:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration