LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   virtual resolution issue - xorg.conf - eeepc 1000ha - debian 5.0 (lenny) (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/virtual-resolution-issue-xorg-conf-eeepc-1000ha-debian-5-0-lenny-698087/)

checkmate3001 01-18-2009 04:57 AM

virtual resolution issue - xorg.conf - eeepc 1000ha - debian 5.0 (lenny)
 
Hello everyone,

I'm trying to get my baby laptop to have a virtual resolution that is larger than the standard 1024x600. I sort of need it because some windows in Debian are larger than the 600 vertical I have so I can't hit the 'ok' button to make the changes I need to make.

I did a
Code:

Xorg -configure
to get a good standard for my hardware.
Here is my current (modified) xorg.conf:
Code:

Section "ServerLayout"
        Identifier    "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/etc/X11/rgb"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/X11/misc"
        FontPath    "/usr/share/fonts/X11/cyrillic"
        FontPath    "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath    "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath    "/usr/share/fonts/X11/Type1"
        FontPath    "/usr/share/fonts/X11/100dpi"
        FontPath    "/usr/share/fonts/X11/75dpi"
        FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load  "dbe"
        Load  "GLcore"
        Load  "glx"
        Load  "record"
        Load  "dri"
        Load  "extmod"
        Load  "xtrap"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        #DisplaySize          220  130        # mm
        Identifier  "Monitor0"
        VendorName  "HSD"
        ModelName    "3e9"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "NoAccel"                    # [<bool>]
        #Option    "SWcursor"                  # [<bool>]
        #Option    "ColorKey"                  # <i>
        #Option    "CacheLines"                # <i>
        #Option    "Dac6Bit"                    # [<bool>]
        #Option    "DRI"                        # [<bool>]
        #Option    "NoDDC"                      # [<bool>]
        #Option    "ShowCache"                  # [<bool>]
        #Option    "XvMCSurfaces"              # <i>
        #Option    "PageFlip"                  # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName  "Mobile 945GME Express Integrated Graphics Controller"
        BusID      "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport  0 0
                Depth    16
                Modes  "1024x600" "800x600" "640x480"
                Virtual 2048 2048
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    24
                Modes  "1024x600" "800x600" "640x480"
                Virtual 2048 2048
        EndSubSection
EndSection

Unfortunately I still only get a 1024x600 desktop and it doesn't scroll anywhere. Does anyone know what I'm doing wrong?


All times are GMT -5. The time now is 12:01 AM.