LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-02-2003, 06:06 PM   #1
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
Using a Kyocera 7135 Smartphone with SuSE 8.2


I finally got around to figuring out how to get this to work this afternoon and I thought I'd share in case anyone else is looking to get this working as well.

Current system:
Dell Inspiron 8200
SuSE 8.2 Professional
Kyocera 7135 Smartphone hooked up via COM1: (/dev/ttyS0)

First, in order to use the phone as a modem, you must launch the FaxModem program from the main menu of the phone.

To set up and use the phone as a modem...
Essentially, I went through YAST2 | Network Devices | Modems. It detected an AT modem attached to COM1. Either configure the one it detects or add a new modem and use the following settings:

Modem Parameters
---------------------
Modem device : /dev/ttyS0 (although if you have it hooked up to a different COM port, this value will vary)
Dial Prefix : none
Dial mode : Tone
Special Settings : Speaker on - No, Detect Dial Tone - Yes
Details : Baud rate - 115200, Init 1 - ATZ, Init 2 - AT$QCMDR=3, Init 3 - (nothing)

Select Internet Provider
-------------------------
Custom Provider, add USA.
Select "New" and enter information for Verizon Wireless (which is who I go through)
Provider Name : Verizon Wireless
Phone Number : #777
UserName : xxxxxxxxxx@vzw3g.com (where xxx's are replaced with your phone #)
Password : vzw

Connection Parameters
-------------------------
Dial-on Demand : I said No, but you may want to say Yes to enable this feature
Modify DNS : Yes
Stupid Mode : Yes
Firewall : Yes
Idle timeout : 180

You can leave the IP details alone.

The next page should show you both the new modem (ppp0 on mine) and the new provider (provider0 on mine).

Click Finish and the configuration will be written. If the system asks you if you want to configure mail, choose No if you are simply setting up an Internet connection. I believe this is for KMail if you are using it. I'm not, so I choose simply to abort at that point.

To make the connection, start KInternet (although KInternet wouldn't actually successfully connect, for some reason). Once KInternet is started, open up a shell, change to user root via "su" and then issue the command "wvdial". It should connect and within a few moments, you should be online. Honestly, I haven't done enough testing to be sure that KInternet is even required. It may have just been coincidence on my machine that it worked only when KInternet was running.

I should mention that you must have the "wvdial" application installed before you can run it from the command line.

Happy surfing!
 
Old 11-08-2003, 01:33 AM   #2
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Original Poster
Rep: Reputation: 30
You'll have to excuse my complete n00b-ness at this...I ended up getting things to work and I wasn't entirely sure how.

Wvdial operates completely independently of KInternet. I still have not been able to connect via KInternet (of which the configuration options are posted above).

I can eventually connect via "wvdial", but it seems rather hit or miss. Sometimes it will try four or five times to connect and it will fail. Then suddenly it will go through. Just for the sake of completeness, I'll post the contents of my /etc/wvdial.conf file so that you can see the correlation to the settings I entered into Yast for KInternet.

[Dialer Defaults]
Modem = /dev/modem
Modem Type = Digital Modem
Baud = 115200
Init1 = ATZ
Init2 = AT$QCMDR=3
Init3 =
Area Code =
Phone = #777
Username = xxxxxxxxxx@vzw3g.com
Password = vzw
Ask Password = 0
Dial Command = ATDT
Stupid Mode = true
Compuserve = 0
Force Address =
Idle Seconds = 180
DialMessage1 =
DialMessage2 =
ISDN = 0
Auto DNS = 1

(obviously, replace the xxx's with the cell number)

So, my next question (ah, yes, here again comes the n00b-ness)...is there a reason why wvdial is hit-or-miss? Most times, it calls the first Init string (ATZ), pauses, and then issues a quit signal (ATQ0) before ever calling the second init string.

For now, it's not a big deal to call wvdial 3 or 4 times in a row before getting a connection...but if there is something I am doing wrong that I can correct so I get a connection the first time, that'd definitely be something I'd like to correct!

TIA!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kyocera 7135 on Linux DrSkeezix Linux - Hardware 1 03-04-2006 10:47 PM
pilot-xfer w/ Kyocera 7135 "device lied about number of ports" meznak Linux - Laptop and Netbook 2 11-17-2005 05:33 PM
Best application for SAA 7135 card chipset devnux Linux - Hardware 5 09-25-2005 11:33 AM
Kyocera KPC650 cstayton Linux - Hardware 1 08-17-2005 02:12 PM
kyocera 1010 and suse 8.2 solar_neutrino Linux - Hardware 1 09-15-2004 01:22 PM


All times are GMT -5. The time now is 08:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration