LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   User accounts and wireless admin (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/user-accounts-and-wireless-admin-899879/)

r3g 08-28-2011 01:38 AM

User accounts and wireless admin
 
Hi,

I've recently installed Ubuntu 10.04 netbook remix on my HP2133 Mini.

All seems to have gone well. The only thing I had to do after install was to install the Broadcom STA drivers for the built in wireless adaptor.

My problem arose when I decided to add additional user accounts for the rest of the family to use.

I added three more user accounts and then tested each one by logging into them. At first everything looked OK, but then I noticed that whenever I logged in under any of the new accounts, the wifi connection was not made and the icon for it was not on the task bar. It's as though the adaptor isn't there when using any of these accounts.

Logging back in with my own account connected to the wifi straight away.

So I tried giving the other accounts admin permissions to see if that made any difference, but it didn't.

Can anyone suggest why this might be happening and how to get around it?

Thanks,

Richard

xeleema 08-28-2011 03:19 AM

Greetingz!

I would make sure everyone's a member of the same set of groups that your account belongs to.
From a terminal, type "id username" (where username is your username).
Then do that for each account.

Make sure everyone's in the same groups you are.

r3g 08-28-2011 11:53 AM

Hi,

I decided to delete the accounts (except the main one) and then added them back again.

Looking at the groups, it appears that the additional accounts are members of more groups than the main admin account but they were things like "fax", "tape", "video". So I removed these to get it as close to the main account as I can. Though using the checkboxes in the user admin panel, I can't seem to get the accounts to be identical, for examplke, there isn't a checkbox for "dip" whatever that is.

I did make sure that the checkbox for "connect to wireless and ethernet networks" is checked.

The main account groups are;
4(adm)
20(dialout)
24(cdrom)
46(plugdev)
105(lpadmin)
112(netdev)
118(admin)
121(sambashare)

The additional account groups are;
4(adm)
20(dialout)
24(cdrom)
30(dip)
46(plugdev)
104(fuse)
112(netdev)

When I log on under the additional account, I still don't see any icon to manage the wifi connection.

Thanks,

Richard


All times are GMT -5. The time now is 11:50 AM.