LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   USB webcam port not working (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/usb-webcam-port-not-working-799013/)

jpg178 03-30-2010 11:13 PM

USB webcam port not working
 
HI I installed Ubuntu 9.1 on my Acer Aspire 5102 WLMi laptop computer.
AMD 64x2 mobile Tec
I have not been able to get the usb ports my webcam and my blue tooth to work. I have a hardware program and it identified that I have ATI usb hub but it also says I have not power to them?
Funny thing is my sd card reader works so for now this is the only way I can get info into my machine beside the cd and downloading.
Not sure what else to do any suggestions?
Here is the terminal coding from putting in what is suggested.

eter@peter-laptop:~$ /sbin/lspci
bash: /sbin/lspci: No such file or directory
peter@peter-laptop:~$ lspci
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 83)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]
06:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
06:02.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
06:04.0 CardBus bridge: ENE Technology Inc CB-712/4 Cardbus Controller (rev 10)
06:04.1 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller (rev 01)
06:04.2 SD Host controller: ENE Technology Inc ENE PCI Secure Digital Card Reader Controller (rev 01)
06:04.3 FLASH memory: ENE Technology Inc FLASH memory: ENE Technology Inc: (rev 01)
06:04.4 FLASH memory: ENE Technology Inc SD/MMC Card Reader Controller (rev 01)
peter@peter-laptop:~$ uname -r
2.6.31-20-generic
peter@peter-laptop:~$ /sbin/cardctl ident
bash: /sbin/cardctl: No such file or directory
peter@peter-laptop:~$ sbin/cardctl ident
bash: sbin/cardctl: No such file or directory
peter@peter-laptop:~$ cardctl ident
cardctl: command not found
peter@peter-laptop:~$ sbin
sbin: command not found
peter@peter-laptop:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
peter@peter-laptop:~$

michaelk 04-01-2010 08:04 AM

Are there any settings in the BIOS to enable the USB ports?

jpg178 04-01-2010 09:21 PM

Sorry I not sure how I check the settings in the BIOS to enable the USB ports?

allend 04-02-2010 08:49 PM

Have you tried the 'wiggle' trick?
https://bugs.launchpad.net/ubuntu/+s...58/comments/42
Otherwise, does 'gspca' show in the output of 'lsmod'?

jpg178 04-02-2010 09:36 PM

this is what I got when following the link and then doing the lsmod.
peter@peter-laptop:~$ gsca
No command 'gsca' found, did you mean:
Command 'nsca' from package 'nsca' (universe)
Command 'gsc' from package 'gambc' (universe)
gsca: command not found
peter@peter-laptop:~$ nsca
The program 'nsca' is currently not installed. You can install it by typing:
sudo apt-get install nsca
nsca: command not found
peter@peter-laptop:~$ gsc
The program 'gsc' is currently not installed. You can install it by typing:
sudo apt-get install gambc
gsc: command not found
peter@peter-laptop:~$ gsca
No command 'gsca' found, did you mean:
Command 'nsca' from package 'nsca' (universe)
Command 'gsc' from package 'gambc' (universe)
gsca: command not found
peter@peter-laptop:~$ lsmod
Module Size Used by
binfmt_misc 8356 1
ppdev 6688 0
clip 12016 1
atm 38836 3 clip
snd_hda_codec_realtek 203328 1
snd_hda_intel 26920 2
snd_hda_codec 75708 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 7200 1 snd_hda_codec
snd_pcm_oss 37920 0
snd_mixer_oss 16028 1 snd_pcm_oss
iptable_filter 3100 0
ip_tables 11692 1 iptable_filter
snd_pcm 75296 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
x_tables 16544 1 ip_tables
arc4 1660 2
snd_seq_dummy 2656 0
ecb 2524 2
snd_seq_oss 28576 0
snd_seq_midi 6464 0
joydev 10240 0
snd_rawmidi 22176 1 snd_seq_midi
snd_seq_midi_event 6940 2 snd_seq_oss,snd_seq_midi
snd_seq 50224 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
pcmcia 36808 0
ath5k 124772 0
snd_timer 22276 2 snd_pcm,snd_seq
mac80211 181140 1 ath5k
ath 8060 1 ath5k
snd_seq_device 6920 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
psmouse 56500 0
lp 8964 0
yenta_socket 24296 1
cfg80211 93052 3 ath5k,mac80211,ath
snd 59204 16 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_se q_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
sdhci_pci 7100 0
sdhci 17504 1 sdhci_pci
parport 35340 2 ppdev,lp
rsrc_nonstatic 11644 1 yenta_socket
acer_wmi 15936 0
soundcore 7264 1 snd
snd_page_alloc 9156 2 snd_hda_intel,snd_pcm
k8temp 4188 0
shpchp 32272 0
pcmcia_core 36528 3 pcmcia,yenta_socket,rsrc_nonstatic
led_class 4096 3 ath5k,sdhci,acer_wmi
serio_raw 5280 0
i2c_piix4 9932 0
8139too 22620 0
8139cp 19260 0
mii 5212 2 8139too,8139cp
video 19380 0
output 2780 1 video
ati_agp 6760 0
agpgart 34988 1 ati_agp
peter@peter-laptop:~$
Hope this helps you as it does not mean much to me... I did not install the packages as I don't know what they are for.

michaelk 04-03-2010 06:40 AM

sdhci-pci is the module for the card reader which you say is working but I do not see any modules being loaded for USB.
usbcore
uhci-hcd
ehci-hcd
usb_storage
sd_mod

You can manually load the modules listed and see if the ports start working via the modprobe command i.e.
modprobe usbcore

jpg178 04-04-2010 10:46 PM

Sorry not sure how to load modules listed and see if the ports start working... how do you do this as I cannot find an answer anywere?

michaelk 04-05-2010 07:17 AM

Use the modprobe command i.e. (must be root)
modprobe <module name as listed above>


All times are GMT -5. The time now is 09:59 PM.