LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 09-05-2004, 02:02 AM   #1
jpgillivan
LQ Newbie
 
Registered: Aug 2004
Location: oh
Distribution: Mandrake 10
Posts: 22

Rep: Reputation: 15
upgraded kernel to 2.6.8.1 now no sound


I upgraded the kernel from 2.6.3.7 to 2.6.8.1 and now the sound doesn't work. Even if I boot back into 2.6.3.7 it does not work.

Sound did work before I updated. btw, i compiled from complete source, not patch.

lspci returns
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio Controller (rev 01)

Exactly what options should I have set when configuring the kernel. I used xconfig.
I tried selecting intel for the sound card but no luck. ALSA and OSS are selected.

It appears that there are no mixers installed anymore. ??

When trying to set the sound settings in control center I get :
device /dev/dsp can't be opened (No such file or directory)

I verified that there is indeed no directory with that name but there is
/dev/snd
and
/dev/sound

did I do something wrong when configuring the kernel or is there something else that I should install.

OS: Mandrake 10.0
Computer: Dell 600m laptop

I think that everything else is working ok.
 
Old 09-05-2004, 08:18 AM   #2
spacedoubtman
LQ Newbie
 
Registered: Feb 2004
Location: Brisbane, QLD, Australia
Distribution: Debian
Posts: 29

Rep: Reputation: 15
seems strange.

try this command as root:
/dev/MAKEDEV audio

that will make the file /dev/dsp

if your using alsa you might need to add the OSS PCM API and OSS Mixer API options
 
Old 09-28-2004, 10:11 PM   #3
z35
LQ Newbie
 
Registered: Sep 2004
Posts: 6

Rep: Reputation: 0
same here

I have the same Problem, I have not changed anything. I just upgraded? I have not done any extensive looking, just a quick search. I did not look at any changes or anything due to the dredful thing called limited time. A quick make oldconfig, make menuconfig, changed PentiumM and added cpu freq scaling stuff (Inspiron 8200). And that was that, cp, blah and etc (I have done this a couple times). I do not know what the problem is. Any advice, help, aid etc, thank you in advance.

stephen
 
Old 09-29-2004, 03:49 AM   #4
christhom
Member
 
Registered: Sep 2004
Distribution: Debian sarge/sid
Posts: 41

Rep: Reputation: 15
I had this problem recently on my 500m. Are you using hotplug and alsa? the problem is most likely that the old sound modules are being loaded first, before the alsa ones and this screws things up. Well, that's what happened with my debian laptop.

Try editing the blacklist in
/etc/hotplug/blacklist
and add the OSS modules to it. mine contains the following:

======
#try to get sounds working again
audio
snd-usb-audio
i810_audio
snd-intel8x0m
#i810_audio is OSS module and snd_intel8x0m is modem
======

if this doesn't fix the problem, hopefully it'll put you on the right track...
 
Old 09-30-2004, 01:08 AM   #5
z35
LQ Newbie
 
Registered: Sep 2004
Posts: 6

Rep: Reputation: 0
I am using alsa... so I tried adding a a couple of these to the /etc/hotplug/blacklist, then did (each time the <file> was editied
/etc/init.d/hotplug restart ; /etc/init.d/alsasound restart
Alright, lsmod:
Code:
Module                  Size  Used by
snd_intel8x0           30472  0 
snd_ac97_codec         66692  1 snd_intel8x0
snd_mpu401_uart         6400  1 snd_intel8x0
snd_rawmidi            20644  1 snd_mpu401_uart
snd_seq_oss            31872  0 
snd_seq_midi_event      6400  1 snd_seq_oss
snd_seq                50192  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          7048  3 snd_rawmidi,snd_seq_oss,snd_seq
snd_pcm_oss            50216  0 
snd_pcm                86920  2 snd_intel8x0,snd_pcm_oss
snd_page_alloc          9352  2 snd_intel8x0,snd_pcm
snd_timer              22020  2 snd_seq,snd_pcm
snd_mixer_oss          18048  1 snd_pcm_oss
snd                    49508  12 snd_intel8x0,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_oss,snd_seq_midi_event,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore               7776  1 snd
nvidia               4815988  10 
sg                     30880  0 
rtc                    10680  0 
3c59x                  36136  0
I will prob try a restart, and if all else fails, I will work on it more this week-end-ish-maybe. But if rebooting does not work, I will just use my previous version: 2.6.6-rc1. Until I find time to get it working...
 
Old 10-01-2004, 07:19 PM   #6
Krugger
Member
 
Registered: Oct 2004
Posts: 229

Rep: Reputation: 30
/dev/dsp is the device for the OSS which is now deprecated. So we are supposed to stop using it.

But there is some problems with this card with ALSA. I still have to updated to a newer version of the kernel, but

I found out that if you

modprobe snd_intel8x0
rmmod snd_intel8x0
modprobe i810_audio
chmod 777 /dev/dsp
chmod 777 /dev/mixer

gives me sound in a version that didn't give sound because of a buggy snd_intel8x0 module. There was a warning on the alsa project site. The downside is that it wasn't made to work this way and therefor probably makes the system a bit unstable. Because as long as we inicialize the ALSA submodules the OSS emulation is there. Don't forget that in the new 2.6.x kernel if you are trying to use OSS modules.
 
Old 10-05-2004, 01:21 AM   #7
otoomet
Member
 
Registered: Oct 2004
Location: Tartu, Ċrhus,Nürnberg, Europe
Distribution: Debian, Ubuntu, Puppy
Posts: 588

Rep: Reputation: 45
I had a somewhat similar problem with HP d530 sff, programs were complaining about
/dev/dsp. I simply repaced ALSA by OSS and it "just worked" for my big surprise. This is probably an ALSA bug related with intel8x0.

Ott
 
Old 11-15-2004, 06:09 AM   #8
jfromcanada
LQ Newbie
 
Registered: Nov 2004
Posts: 22

Rep: Reputation: 15
ALSA works with a little pushing... also need to make sure all your apps are using ALSA. and/or build OSS compatibility mode into the kernel along with ALSA.
Also, you can try just using a daemon like esound or something; I do that, my env is gnome with enlightenment as wm, and I just use the esound daemon and get all apps to play through that
last but not least, check your mixer settings, the upgrade might have reset them all to zero (use alsamixer).
have fun!
hope this helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
upgraded kernel, won't let me compile kernel once Suspend2 patches are applied microsoft/linux Linux - Laptop and Netbook 3 10-02-2005 03:37 PM
Just upgraded my kernel, and lost my sound... WTF TheCowboy Linux - Hardware 1 02-24-2005 08:26 PM
Upgraded Kernel, No Sound Tip Slackware 4 01-14-2005 08:48 PM
Upgraded to kernel 2.6.7 no sound with Aureal Vortex2 and no error Cullen Linux - Hardware 2 08-21-2004 10:16 AM
no sound - just upgraded kernel - HELP! tjay Linux - Hardware 2 06-17-2004 11:54 AM


All times are GMT -5. The time now is 07:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration