LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 12-28-2005, 01:03 AM   #1
Sedmic
LQ Newbie
 
Registered: Feb 2005
Location: Saint Louis, MO
Distribution: Fedora Core 6
Posts: 8

Rep: Reputation: 0
Unable to load i915 driver using FC4 on an Inspiron 6000


I recently bought an Inspiron 6000 with Intel's built-in graphics (GMA 900). I installed Fedora Core 4 and have used it for a few weeks with no problems. However, I have been running the display with the VESA drivers. I have been struggling to get X to accept the Intel drivers and have not had much success.

System specifics: I installed Fedora Core 4 and it is running on kernel 2.6.14-1.1653_FC4. I am running X.org version 6.8.2. After some searching, I decided to follow the instructions from a similar thread. I installed the latest DRI snapshot (i915-20051220-linux.i386) and did not get any errors.

The output of lspci shows this output:

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

My xorg.conf file contains the following relevant lines:

>Section "Device"
> Identifier "Videocard0"
> Driver "i810"
> VendorName "Intel Corp."
> BoardName "Intel(r)915GM/910ML/915MS Graphics Controller"
> BusID "0:2:0"
>EndSection

When I try startx, I get the following errors:

>(WW) I810: No matching Device section for instance (BusID PCI:0:2:0) found
>(WW) I810: No matching Device section for instance (BusID PCI:0:2:1) found
>(EE) No devices detected.
>
>Fatal server error:
>no screens found
>XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
> after 0 requests (0 known processed) with 0 events remaining.

At this point, I did an lsmod and noticed that neither i810 nor i915 modules were loaded. I managed to insmod i810 successfully, but i915 did not go so well. The output of dmesg looks like this:

>[drm] Initialized drm 1.0.0 20040925
>i915: disagrees about version of symbol drm_open
>i915: Unknown symbol drm_open
>i915: disagrees about version of symbol drm_fasync
>i915: Unknown symbol drm_fasync
>i915: disagrees about version of symbol drm_poll
>i915: Unknown symbol drm_poll

and so on for about 20 lines. Since rebooting, however, I can no longer insmod i810 or i915 and get the following error

>insmod: can't read 'i810': No such file or directory

At this point, I'm confused on what to do next. I found a site in fedoraforum.org that recommended downloading dri-I915-v1.1-20041217.i386.rpm from the Intel website. There is also another site that suggests you update i810 and common at the same time as the i915 drivers. I apologize for not posting URLs but since I'm new to this site I'm not allowed to post URLs.

Can anyone please suggest the best way to proceed? I do not have the freedom to change distros to Ubuntu or anything else. I am really dependent on my computer for school and can't spend hours and hours tinkering with it to get the i915 drivers to work. If someone can tell me a good way to proceed, I would be immensely grateful.

Thanks,

Ramin
 
Old 01-06-2006, 08:26 PM   #2
uxdesign
LQ Newbie
 
Registered: Jan 2006
Posts: 1

Rep: Reputation: 0
Lightbulb Partialy Solved !!

Hi Rammin
It is not fair to say that you are in the wrong way. But, certainly: you are wrong.

This issue its due to the hardware specific nature: it is a i950.

Said that you are in a double trouble trying to install i81x, i91x series. If somebody show something more suitable: think my words like garbage: it will cease to exist by his own means ...

============================
Solutions my friend:
============================
Install VESA generic driver from Xorg-8.6.2. Give it a try!! I installed this in a notebook travelmate 2410 LCi series with success.

Try also fb (frame buffer) -I didn't- and say here "LQ" what is the better solution if you consider that is OK!

You will see your graphics for now. May be in the future we will see something more interesting or a specific driver for this hardware.

Bye and good Luck.

Last edited by uxdesign; 01-06-2006 at 08:28 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to detect onboard LAN on i915 board with RHL9.0 asowani Red Hat 4 12-06-2005 10:47 PM
ATI Driver With Inspiron 6000 Chryzmo Linux - Software 5 11-05-2005 09:52 PM
Inspiron 6000 namboothiri Linux - Laptop and Netbook 2 10-20-2005 01:46 PM
KDE unable to load after driver-installation primetime2 Linux - General 3 12-19-2004 03:55 AM
Unable to boot install/live CDs on PB with i915 chip jeffix Linux - Hardware 0 12-08-2004 04:17 AM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration