LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Ubuntu 13.04 - Black screen on finish of install. (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/ubuntu-13-04-black-screen-on-finish-of-install-4175475249/)

pizzipie 08-29-2013 07:15 PM

Ubuntu 13.04 - Black screen on finish of install.
 
Hi all,

I have a DEll Latitude E6510 laptop. Two years old.

I have tried to install Ubuntu 13.04 and it won't work.

I run through the process (new fresh install, whole disk, no windows) and at the last after you are instructed to remove the cd and it tries to finish it hangs up. Black screen. The live version works ok.

I don't have a clue as to how to fix this.

Apreciate any help to solve this.

Thanks R.

Ztcoracat 08-30-2013 01:50 AM

Hi:

Just a thought but nomodeset might work-

I used these instructions the other day for Ubuntu 12.10 and it worked for me.;)

The newest kernels have moved the video mode setting into the kernel. So all the programming of the hardware specific clock rates and registers on the video card happen in the kernel rather than in the X driver when the X server starts.. This makes it possible to have high resolution nice looking splash (boot) screens and flicker free transitions from boot splash to login screen. Unfortunately, on some cards this doesnt work properly and you end up with a black screen. Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded.

If you boot ubuntu from a livecd (or USB stick), right after the bios splash screen you will get a purple screen with a keyboard logo at the bottom.
Press any key at that moment to access a menu. Select your language with the arrow keys, press enter and you will see this menu-
If you press the F6 key, a menu at the bottom will open allowing you to set kernel options with the space bar or enter key. You can close the menu with escape key and resume booting by selecting the option “try ubuntu without installing” (please note that session does allow you to install ubuntu once you found the kernel options cured your problem).

If you need to add kernel options not provided by the F6 menu, you can just type them in at the end of the boot options line.


Important: if you select a kernel boot option from the F6 menu and proceed to boot and later install ubuntu, those boot options will NOT be applied to your installation. If you needed nomodeset to get the livecd to boot, you will almost certainly need it again once you reboot in to your fresh install. See below how to set those options on an installed ubuntu.

During the install are you manually creating your own partition and a swap space?
What distribution did you have on your laptop before you tried to install Ubuntu 13.04? Do you have UEFI BIOS?
It is possible that the graphic card could be on it's way out:-

Also, it could be your boot order.
I had to set my laptop to boot to the CD/DVD ROM drive first in order to install Fedora. The next on the boot order list in my BIOS is the HDD-

pizzipie 08-30-2013 03:04 PM

Thanks for the reply,

I had 11.10 installed previously and my boot order has the CD/DVD ROM as first order.

I don't know what UEFI is so doubt that I have it. I know very little about any of this kernel or hardware stuff.

Since installing 13.04 failed I installed 12.10. It works ok so I would imagine the graphics card is ok. Is this one of the "newest distributions"?

I chose to have Ubuntu re-partition the hard drive.

I'll run 13.04 live again and make sure of what is going on. I thought it worked in live mode.

Thanks, R

yancek 08-30-2013 05:01 PM

If you accepted the defaults in the installation, it should have booted unless you have some unusual and unsupported hardware.
Try 13.04 again and see if the Live CD works.
For future reference, you might check the support period for different versions. For Ubuntu, version 12.04 will be supported for more than three years after support for 13.04 ends so unless something doesn't work or there is some super-duper new software available that you have to have, not much point in installing a newer version.

Ztcoracat 08-30-2013 11:25 PM

Yes Ubuntu 13.04 Rairing Ringtail is fairly new.
April 25, 2013 I do believe--
https://wiki.ubuntu.com/RaringRingtail/ReleaseNotes
http://fridge.ubuntu.com/2013/04/25/...tail-released/

Try again like Yancek advises and let us know what happens.

Quote:

I chose to have Ubuntu re-partition the hard drive.
That's actually easier that manually partitioning as I'm sure you'll agree-

I'm running Ubuntu 12.04 and it's supported until 2015-;)
Normal Ubuntu releases are supported for 9 months.

If you had UEFI you wouldn't be able to install Ubuntu 12.10. I found this out the hard way and here's how:- I tried to install Ubuntu 12.10 on a brand new build with a brand new mobo that has UEFI BIOS.
The screen stayed black no matter what I tried. But when I ran that same Live CD: "Ubuntu 12.10" on the older desktop of mine that does not have UEFI BIOS it booted on problem and allowed me to interact with the Live CD and install it if I wanted to.

yancek 08-31-2013 12:15 AM

Quote:

I'm running Ubuntu 12.04 and it's supported until 2015
Actually, April, 2017.

https://wiki.ubuntu.com/Releases

Ztcoracat 08-31-2013 12:49 AM

Quote:

Originally Posted by yancek (Post 5019197)
Actually, April, 2017.

https://wiki.ubuntu.com/Releases

Thank You Yancek! That's even better news yet!;)

pizzipie 08-31-2013 10:14 PM

Hi,

I ran the live cd for 13.04 and it ran fine!!

I installed 13.04 w/o updates and 3rd party software then booted and got a black screen again.

I then booted again and things seem to work although in large format.

I will get the updates and keep going. I don't consider this solved so will be back.

So far, progress.

Thanks, guys/gals

R

Ztcoracat 09-01-2013 12:57 AM

The first update after the fresh install should help.

How is your new distro running now?

pizzipie 09-03-2013 05:00 PM

SOLVED - I think.

Thanks for your help. I updated the distro and it appears everything is running ok. In that process I had to re-boot and that worked OK.

So, thanks again for for your help guys and girls!!!!

R

Ztcoracat 09-03-2013 10:35 PM

Your Welcome: pizzipie
Have a good week-:)


All times are GMT -5. The time now is 03:05 AM.